Тема : IntegerЗадача : Дано одно целое число, проверить, является ли оно простым?

Информатика | 5 - 9 классы

Тема : Integer

Задача : Дано одно целое число, проверить, является ли оно простым.

(делится на 1 и на само себя).

Помогите пожалуйста).

Ответить на вопрос
Ответы (1)
Truhin 10 мая 2020 г., 21:21:20

Var i : integer ; x : boolean ; n : integer ;

begin

readln(n) ;

for i : = 2 to n - 1 do

begin

if n mod i = 0 then

x : = true ;

end ;

if (x = false) and (n < ; > ; 1) then

writeln('yes')

else

writeln('no') ;

end.

Elena1986502 2 июл. 2020 г., 02:58:22 | 5 - 9 классы

Дано число А?

Дано число А.

Определить, является ли оно простым (простое это натуральное число имеющие ровно два различных натуральных делителя : пшеницы и само себя).

PrOStoLeka 22 дек. 2020 г., 00:06:39 | 5 - 9 классы

Пользователь вводит целое число?

Пользователь вводит целое число.

Программа должна ответить, четным является это число или нечетным, делится она на 3 или нет, и делиться оно на 6 или нет.

Salnikovavika 20 сент. 2020 г., 20:58:25 | 5 - 9 классы

Помогите решить задачу по информатике : дано целое число n , если оно является степенью числа 3 то вывести : истина, иначе вывести ложь?

Помогите решить задачу по информатике : дано целое число n , если оно является степенью числа 3 то вывести : истина, иначе вывести ложь.

Vkills 10 июн. 2020 г., 06:03:29 | 10 - 11 классы

Дано целое число?

Дано целое число.

Определить является ли оно кратным 3.

(написать программу).

Заремка2004 31 янв. 2020 г., 07:48:26 | 5 - 9 классы

Задача по информатике Проверить является ли целое число не четным?

Задача по информатике Проверить является ли целое число не четным.

Помогите пожалуйста.

Очень нужно.

Van 21 мар. 2020 г., 19:07:34 | 10 - 11 классы

В паскале сделать используя циклы : Ввести число и определить является ли оно простым (если его делители являются 1 и само число)?

В паскале сделать используя циклы : Ввести число и определить является ли оно простым (если его делители являются 1 и само число).

Diii99 19 февр. 2020 г., 22:15:51 | 5 - 9 классы

Решить данную задачу в Паскале через тип integer?

Решить данную задачу в Паскале через тип integer.

Задача : Известна масса тела в килограммах.

Определить сколько целых тонн содержится в данном числе.

Xayal2405 18 февр. 2020 г., 23:08:54 | 5 - 9 классы

Дано целое число N(> ; 0)Если оно является степенью числа 2, то вывести True , если не является Folse?

Дано целое число N(> ; 0)Если оно является степенью числа 2, то вывести True , если не является Folse.

Ашад 20 мая 2020 г., 16:54:09 | 5 - 9 классы

Напишите сколько сможете программ для решения вот таких задач : If1?

Напишите сколько сможете программ для решения вот таких задач : If1.

Дано целое число.

Если оно является положительным, то прибавить к нему 1 ; в противном случае не изменять его.

Вывести полученное число.

If2. Дано целое число.

Если оно является положительным, то прибавить к нему1 ; в противном случае вычесть из него2.

Вывести полученное число.

If3. Дано целое число.

Если оно является положительным, то прибавить к нему 1 ; если отрицательным, то вычесть из него 2 ; если нулевым, то заменить его на 10.

Вывести полученное число.

Помогите очень надо.

Tigrandog 24 сент. 2020 г., 14:04:32 | 10 - 11 классы

Даны 2 целых числа?

Даны 2 целых числа.

Проверить, заканчиваются ли они на одну и ту же цифру.

На этой странице сайта вы найдете ответы на вопрос Тема : IntegerЗадача : Дано одно целое число, проверить, является ли оно простым?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.