Помогите пожалуйсто?

Информатика | 10 - 11 классы

Помогите пожалуйсто!

1). Составить алгоритм и программу определения расстояния между точкамиМ( х, у) и М1( х1, у1).

2)составить алгоритм и программу для заданного трехзначного числа вычислить среднее арифметическое и среднее геометрическое цифр , образующих это число .

Ответить на вопрос
Ответы (1)
Софа90 6 февр. 2020 г., 04:29:49

Алгоритм :

1 - введите числа для х, х1, у, у1

2 - мы знаем что формула нахождения точек равна : Мм1 = sqrt[(x1 - x) ^ 2 + (y1 - y) ^ 2] sqrt это корень.

3 - подставляем

4 - потом мы вычитаем в скобках числа

5 - умножаем полученные цифры на квадрат

6 - вычитаем корень

Вот сама программа :

Var x, x1, y, y1, t, a, b : real ;

Begin

Readln(x, x1, y, y1) ;

A : = sqr(x1 - x) ;

B : = sqr(y1 - y) ;

T : = sqrt(a + b) ;

Write(t) ;

End.

Если будут ошибки в проге, то сори, с телефона пишу.

А что во 2 нужно сделать?

Я не до конца понял.

Mariagrigoryan1 21 сент. 2020 г., 12:06:17 | 5 - 9 классы

ДАны числа а и b?

ДАны числа а и b.

Составить программу для вычесления среднего арифметического значения чисел.

Vik10629003a 4 окт. 2020 г., 06:47:42 | 5 - 9 классы

Составить программу нахождения среднего арифметического и среднего геометрического модулей двух чисел (Pascal ABC)?

Составить программу нахождения среднего арифметического и среднего геометрического модулей двух чисел (Pascal ABC).

Malinovskaya1978 17 апр. 2020 г., 12:21:17 | 5 - 9 классы

1. составить программу и алгоритм находящую сумму цифр трехзначного числа 2?

1. составить программу и алгоритм находящую сумму цифр трехзначного числа 2.

Составить программу и алгоритм находящую все простые делители заданного числа.

Аннавип 2 сент. 2020 г., 15:09:44 | 5 - 9 классы

Составить алгоритм и программу нахождения площади заштрихованной области( а - сторона квадрата, r - радиус круга) Дано четырехзначнок число х?

Составить алгоритм и программу нахождения площади заштрихованной области( а - сторона квадрата, r - радиус круга) Дано четырехзначнок число х.

Составить алгоритм и программу, которая выводит цифры данного числа в обратном порядке.

Vvvvveronika 18 авг. 2020 г., 19:04:42 | 5 - 9 классы

Составить алгоритм :Даны два числа?

Составить алгоритм :

Даны два числа.

Найти среднее арифметическое кубов этих чисел.

19056 12 янв. 2020 г., 13:26:43 | 5 - 9 классы

Заданы значения x y z Составить программу которая находит среднее арифметическое и среднее геометрическое этих чисел?

Заданы значения x y z Составить программу которая находит среднее арифметическое и среднее геометрическое этих чисел.

Асенок12332 4 сент. 2020 г., 10:37:54 | 5 - 9 классы

Составить алгоритмы и программы дляСоставить алгоритмы и программы для заполнения : Массива А (30) по формуле A(i) = 10 * I + 2 * i2?

Составить алгоритмы и программы дляСоставить алгоритмы и программы для заполнения : Массива А (30) по формуле A(i) = 10 * I + 2 * i2.

Найти среднее арифметическое элементов < ; 50.

Распечатать массив в строку.

СОСТАВЬТЕ ПРОГРАММУ ПЛИЗ.

Надежжжжжж 13 дек. 2020 г., 19:28:04 | 5 - 9 классы

Составьте алгоритм для определения количества цифр в записи произвольного натурального числа (для программы Паскаль)?

Составьте алгоритм для определения количества цифр в записи произвольного натурального числа (для программы Паскаль).

Pashasid 19 сент. 2020 г., 13:54:29 | 5 - 9 классы

СОСТАВИТЬ ПРОГРАММУ Цифры данного трехзначного числа являются членами арифметической прогрессии?

СОСТАВИТЬ ПРОГРАММУ Цифры данного трехзначного числа являются членами арифметической прогрессии.

Yunus02 29 авг. 2020 г., 04:37:07 | 10 - 11 классы

Конструктор алгоритмов?

Конструктор алгоритмов.

Дано двузначное (трехзначное) число.

Написать программу определения : входит ли в него цифра 5?

На странице вопроса Помогите пожалуйсто? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.