Помогите пожалуйста?

Информатика | 10 - 11 классы

Помогите пожалуйста!

Что выводит на экран следующая программа?

Program P120 ; var i : ^ integer ; begin new (i) ; i ^ : = 1 ; new(i) ; i ^ : = 2 ; new(i) ; i ^ = 3 ; writeln (i ^ ) ; readln ; end.

Ответить на вопрос
Ответы (1)
Gunaymemmedova8 29 мар. 2020 г., 09:30:48

Выдает ошибку в строке :

new(i) ; i ^ = 3 ;

Если изменить как 1 и вторую строку, то бишь наnew(i) ; i ^ : = 3 ;

То выдаёт ответ - 3.

Valeriykot2016 8 мая 2020 г., 23:26:20 | 5 - 9 классы

Что делать?

Что делать?

Program n1 ; Type Test = class Private Var a : integer : = 10 ; Public Var b : integer : = 15 ; End ; Begin Var cl : Test : = new Test() ; Writeln(cl.

A) ; / / должно не выполняться но паскалю пофиг Writeln(cl.

B) / / выпонится End.

Polinka275 15 мая 2020 г., 04:26:59 | 5 - 9 классы

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число.

Program cisla ; var a : integer ; begin writeln('Введите число, ') ; readln(a) ; if a mod 2 = 0 then writeln('Число четное') ; else writeln('Число нечетное') ; readln end.

LolliThePop 30 нояб. 2020 г., 19:01:40 | 5 - 9 классы

Что выводит на экран следующая программа?

Что выводит на экран следующая программа?

Program : TA6

type : culoare = (galben, verde, albastru, violet)

begin :

writeln(pred ("z"))

writeln (succ("d"))

writeln(pred ( - 5))

writeln(ord (verde))

writeln (ord(violet))

end.

Sinfsh 3 дек. 2020 г., 15:01:04 | 5 - 9 классы

Перепишите программу на языке Паскаль, исправив ошибки : Program primer Var a, b : integer ; Begin ; ReadLn( a, b) ; s = a + b ; m : = a * b ; d : = a : b ; WriteLn(s) ; WriteLn(m) ; WriteLn(d) End?

Перепишите программу на языке Паскаль, исправив ошибки : Program primer Var a, b : integer ; Begin ; ReadLn( a, b) ; s = a + b ; m : = a * b ; d : = a : b ; WriteLn(s) ; WriteLn(m) ; WriteLn(d) End.

Nausiaru 18 мар. 2020 г., 23:19:31 | 5 - 9 классы

Program Test ; var A, B , C : integer ; begin readln (A, B) ; C : = (A + B) * (B - A) ; writeln (C) end?

Program Test ; var A, B , C : integer ; begin readln (A, B) ; C : = (A + B) * (B - A) ; writeln (C) end.

Помогите пожалуйста.

Объясните как вы делали.

Lyaschenko 29 мар. 2020 г., 06:07:37 | 5 - 9 классы

Какая задача решается по следующей программе?

Какая задача решается по следующей программе?

Program Test var A, B, C : integer ; begin readln ( A, B) ; C : (A + B) * (B - A) writeln(C) end.

Задача связана с программой паскаль.

14013 10 мая 2020 г., 01:22:45 | 10 - 11 классы

Объяснить, в чем заключается синтаксическая ошибка (или ошибки) в приведенной программе?

Объяснить, в чем заключается синтаксическая ошибка (или ошибки) в приведенной программе.

Написать тот вариант программы, который, по Вашему мнению, будет правильным.

Program My_Error ; Var X, Y, Сумма : Integer ; Begin WriteLn( Введите значение X) ; ReadLn(X) ; WriteLn( Введите значение Y) ; ReadLn(Y) ; Сумма = X + Y ; WriteLn(Сумма) End.

Ksusha1037 25 июн. 2020 г., 21:03:03 | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

Alinaebru 20 дек. 2020 г., 09:37:05 | 5 - 9 классы

Какая задача решается по следующей программе?

Какая задача решается по следующей программе?

Program Test ; var A, B , C : integer ; begin readln (A, B) ; C : = (A + B) * (B - A) ; writeln (C) end.

Какой результат будет получен, если в качестве исходных значений А и В ввести, соответственно, 7 и 8?

Gothic34 25 сент. 2020 г., 14:40:18 | 10 - 11 классы

Верна ли следующая программа?

Верна ли следующая программа?

Если да, то сколько операторов она содержит, если нет, то почему : var x, y : integer ; begin readln(y) ; ; x : = 0 ; if x> ; 0 then ; writeln(x, y) ; readln ; end.

Вы зашли на страницу вопроса Помогите пожалуйста?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.