Задание 1?

Информатика | 10 - 11 классы

Задание 1.

Создайте программу для вычисления значений выражений.

Исходные данные a, b, c задаются пользователем с клавиатуры.

X = 2a ^ 2 - b / 3c Y = sqrt(x + c ^ 2) + 4ab Какие исходные данные будут недопустимыми?

Проверьте, что произойдет при запуске программы с такими данными.

Добавьте в программу проверку исходных данных после их ввода.

Ответить на вопрос
Ответы (1)
Антoнина 16 янв. 2020 г., 22:06:11

Var a, b, c, x, y : real ;

begin Write('Введите a и b : ') ; Read(a, b) ; repeat Write('Введите c, не равное нулю : ') ; Read(c) until c< ; > ; 0 ; x : = 2 * sqr(a) - b / (3 * c) ; { Если Вы относитесь к людям, ненавидящим скобки и тех, кто решает Ваши задания, то в Вашем условии на 3а делится все выражение, и тогда предыдущая строка должна иметь вид x : = (2 * sqr(a) - b) / (3 * a) ; } if x> ; = 0 then begin y : = sqrt(x + sqr(c)) + 4 * a * b ; Writeln('x = ', x, ', y = ', y) end else Writeln('x = ', x, ', y вычислить нельзя, под корнем отрицательное значение')

end.

Тестовое решение :

Введите a и b : 3.

4 - 2.

18

Введите c, не равное нулю : 0

Введите c, не равное нулю : 5.

172

x = 23.

2605001288992, y = - 22.

5762191684909.

Корес 14 нояб. 2020 г., 08:41:48 | 1 - 4 классы

Что такое "исходные данные " задачи?

Что такое "исходные данные " задачи?

Викториэта 9 июл. 2020 г., 05:13:00 | 5 - 9 классы

Написать на языке Паскаль программу ввода четырёх целых чисел и вычисления их среднего арифметического?

Написать на языке Паскаль программу ввода четырёх целых чисел и вычисления их среднего арифметического.

Протестировать программу на различных исходных данных (включая вещественные числа) и доказать правильность её работы.

BearRozman 10 нояб. 2020 г., 21:58:39 | 10 - 11 классы

Написать программу, которая вычисляет сумму первых N четных положительных чисел?

Написать программу, которая вычисляет сумму первых N четных положительных чисел.

Исходные данные (N – количество чисел) вводятся с клавиатуры.

Результаты работы программы записываются в файл Out.

Txt.

Мали 29 мар. 2020 г., 06:40:14 | 5 - 9 классы

Помогите составить программу на языке паскаль абц :Вычислите площадь круга и длину окружности по исходным данным?

Помогите составить программу на языке паскаль абц :

Вычислите площадь круга и длину окружности по исходным данным.

Anna49145 8 авг. 2020 г., 15:08:53 | 10 - 11 классы

Написать код программы на PascalABC Составить алгоритм и программу для вычисления g и m?

Написать код программы на PascalABC Составить алгоритм и программу для вычисления g и m.

Исходные данные : a = 30° c = 13 a = - 18.

Муххаммед 11 июл. 2020 г., 07:06:39 | 10 - 11 классы

Даны 2 действительных числа?

Даны 2 действительных числа.

Возвести в квадрат те из них, значение которых неотрицательны.

Числа вводятся пользователям с клавиатуры.

Результат работы программы вводится на экран.

Shira260581 13 мар. 2020 г., 08:51:24 | 5 - 9 классы

Напиши программу которая вычисляет среднюю за неделю температуру воздуха исходные данные с клавиатуры?

Напиши программу которая вычисляет среднюю за неделю температуру воздуха исходные данные с клавиатуры.

Аннафанёнок 23 авг. 2020 г., 04:21:21 | 5 - 9 классы

92 Б?

92 Б!

Написать программу на ПАСКАЛЕ _ Вычислить значение функции и осуществить вывод исходных данных и результат вычисления.

Vikia 24 сент. 2020 г., 01:41:40 | 5 - 9 классы

(код программы на ЯП Паскаль) : Пройдет ли колобок с талией L в квадратное окно со стороной А?

(код программы на ЯП Паскаль) : Пройдет ли колобок с талией L в квадратное окно со стороной А.

Все исходные данные вводятся с клавиатуры.

Jesdasd 20 окт. 2020 г., 23:54:53 | 5 - 9 классы

Напишите программу, которая по исходному пятизначному числу находит сумму квадратов цифр данного числа Пример ввода 12345 Пример вывода 55 С + + ПРОГРАММА?

Напишите программу, которая по исходному пятизначному числу находит сумму квадратов цифр данного числа Пример ввода 12345 Пример вывода 55 С + + ПРОГРАММА.

Перед вами страница с вопросом Задание 1?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.