Нужно срочно, к 3 уроку?

Информатика | 10 - 11 классы

Нужно срочно, к 3 уроку.

Заранее спасибо) дан двумерный массив размером 5 * 6, заполненный целыми числами.

Сформировать одномерный массив, каждый элемент которого равен произведению четных положительных элементов соответствующего столбца.

Ответить на вопрос
Ответы (1)
SlavaVila 8 апр. 2020 г., 13:21:11

Program mass ;

uses crt ;

var mas : array [1.

5, 1.

6] of integer ; mas_od : array[1.

6] of integer ; i, j : integer ;

begin randomize ; for i : = 1 to 5 do for j : = 1 to 6 do mas[i, j] : = random(10) - 5 ; for i : = 1 to 5 do begin for j : = 1 to 6 do write(mas[i, j] : 4) ; writeln ; end ; writeln(' - - - - - - - - - - - - - - - - - - - - - - - - - - - - ') ; for i : = 1 to 5 do begin mas_od[i] : = 1 ; for j : = 1 to 6 do begin if((mas [i, j] mod 2 = 0) and (mas[i, j] > ; 0)) then mas_od[i] : = mas_od[i] * mas[i, j] ; end ; end ;

for i : = 1 to 6 do write(mas_od[i] : 4) ;

writeln ;

end.

Polinkaflyagina 16 нояб. 2020 г., 17:15:00 | 10 - 11 классы

Дан двумерный массив?

Дан двумерный массив.

Найдите сумму и количество элементов в каждом столбце положительных и лежащих выше главной диагонали.

Primd 15 февр. 2020 г., 08:34:32 | 5 - 9 классы

Дан массив, содержащий N элементов и заполненный случайными числами от - 10 до 9?

Дан массив, содержащий N элементов и заполненный случайными числами от - 10 до 9.

Сформировать новый массив из значений элементов, стоящих на четных местах.

Подсчитать количество отрицательных и положительных значений элементов в новом массиве.

Kakovsky3 14 июл. 2020 г., 06:27:07 | 10 - 11 классы

Дана матрица состоящая из 5 строк и 10 столбцов заполненная случайными числами в диапазоне от 0 до 29?

Дана матрица состоящая из 5 строк и 10 столбцов заполненная случайными числами в диапазоне от 0 до 29.

Сформировать одномерный массив sum(название массива) который состоит из сумм значений элементов каждого столбца матрицы!

Спасибо.

Jijilow 25 июн. 2020 г., 16:50:10 | 10 - 11 классы

Дан массив из двадцати элементов, заполненный целыми числами от - 15 до 45?

Дан массив из двадцати элементов, заполненный целыми числами от - 15 до 45.

Определить количество четных элементов массива.

Muselp 9 мар. 2020 г., 11:35:17 | 10 - 11 классы

Дан массив X(N, M)?

Дан массив X(N, M).

Найти произведение элементов тех столбцов массива, в которых все элементы положительные.

Из полученных значений сформировать одномерный массив.

Помогите пожалуйста!

PLEIX 7 февр. 2020 г., 05:27:54 | 5 - 9 классы

Дан двумерный массив?

Дан двумерный массив.

В каждой четной строке определить и вывести количество положительных элементов.

Duat 4 нояб. 2020 г., 18:27:37 | 10 - 11 классы

Даны три одномерных массива из целых чисел одинаковой длины?

Даны три одномерных массива из целых чисел одинаковой длины.

Сформировать четвертый массив, каждый элемент которого равен максимальному из соответсвующих элементов первых трех массивов.

Pinirob 14 дек. 2020 г., 08:01:44 | 10 - 11 классы

Сформировать одномерный массив из 10 целых элементов?

Сформировать одномерный массив из 10 целых элементов.

Найти сумму положительных и четных элементов массива.

Alinakim200796 10 апр. 2020 г., 23:49:31 | 10 - 11 классы

Дан двумерный массив A целого типа размером 5x5, заполненный случайными числами в диапазоне от 1 до 10?

Дан двумерный массив A целого типа размером 5x5, заполненный случайными числами в диапазоне от 1 до 10.

Замените значения всех элементов пятого столбца на число 5.

Зарание спасибо!

Seregaarhipov20 23 окт. 2020 г., 02:59:02 | 5 - 9 классы

Задан двумерный массив В из 4 - х строк и 5 - и столбцов?

Задан двумерный массив В из 4 - х строк и 5 - и столбцов.

Составить программу, которая организует одномерный массив, каждый элемент которого есть сумма элементов в столбце.

Вычислить произведение элементов полученного массива.

Перед вами страница с вопросом Нужно срочно, к 3 уроку?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.