Дана матрица состоящая из 5 строк и 10 столбцов заполненная случайными числами в диапазоне от 0 до 29?

Информатика | 10 - 11 классы

Дана матрица состоящая из 5 строк и 10 столбцов заполненная случайными числами в диапазоне от 0 до 29.

Сформировать одномерный массив sum(название массива) который состоит из сумм значений элементов каждого столбца матрицы!

Спасибо.

Ответить на вопрос
Ответы (1)
2733366 14 июл. 2020 г., 06:27:09

(я так понял масив(матрица) "состоящая из 5 строк и 10 столбцов заполненная случайными числами в диапазоне от 0 до 29" вводитса з клавиатуры) (я на Паскале на ошибки не проверял)

program dl9_aridrettnir ;

var a : array [1.

10, 1.

5] of inteher ;

sum : array [1.

10] of integer ;

i, q, j : integer ;

begin

writeln ('Vvedit masiv ot 0 do 29') ;

for i : = 1 to 10 do

begin

for q : = 1 to 5 do begin

readln (a[i, q]) ;

end ; end ;

for i : = 1 to 10 do

begin sum[i] : = 0 ;

for q : = 1 to 5 do begin

for j : = 1 to 10 do begin

sum[i] : = a[q, j] + sum[i] ;

end ; end ; end ;

readln

end.

Lera184567 21 февр. 2020 г., 13:53:50 | 10 - 11 классы

ТЕМА : ОБРАБОТКА ДВУМЕРНЫХ МАССИВОВ?

ТЕМА : ОБРАБОТКА ДВУМЕРНЫХ МАССИВОВ.

ПО ПАСКАЛЬ!

Задание : Дан двумерный массив А состоящий из 4 строк и 5 столбцов .

Найти, сколько положительных элементов содержит данная матрица в каждом столбце.

Olga5713 28 сент. 2020 г., 07:50:35 | 10 - 11 классы

Дана матрица размером 7Х7 элементов, случайным образом заполненная?

Дана матрица размером 7Х7 элементов, случайным образом заполненная.

Найти минимальное значение из элементов тех столбцов матрицы, среднее арифметическое которых больше 5 и меньше 15.

Anna19681 25 авг. 2020 г., 06:14:42 | 5 - 9 классы

Дана матрица С[Н, М]?

Дана матрица С[Н, М].

Сформировать массив В, элементами которого являются значения элементов тех строк исходного массива, сумма которых положительна.

Макспп 6 февр. 2020 г., 21:29:38 | 10 - 11 классы

Дана матрица размером 7Х7 элементов, случайным образом заполненная?

Дана матрица размером 7Х7 элементов, случайным образом заполненная.

Найти минимальное значение из элементов тех столбцов матрицы, среднее арифметическое которых больше 5 и меньше 15.

Программирование.

Любовь241крми 2 нояб. 2020 г., 04:10:00 | 10 - 11 классы

Помогите составить код и блок схему на языке C + + ?

Помогите составить код и блок схему на языке C + + .

Динамический двухмерный массив.

Получить матрицу размера n x m , заполненную случайными числами от 10 до 100.

Получить одномерный массив, состоящий из произведений элементов столбцов.

ЭмирбекМуратбек 1 дек. 2020 г., 13:20:07 | 10 - 11 классы

Дана действительная матрица размера 3х4?

Дана действительная матрица размера 3х4.

Найти сумму элементов последнего столбца даной матрицы.

Alyakosenko 7 апр. 2020 г., 11:37:45 | 10 - 11 классы

Дана матрица 8 на 5, заполненная случайными числами от 0 до 10?

Дана матрица 8 на 5, заполненная случайными числами от 0 до 10.

Нужно вывести на экран исходную матрицу и матрицу, в которой к третьему столбцу добавлен шестой.

Sofiyafrolova98 15 июл. 2020 г., 16:53:42 | 10 - 11 классы

Ввести матрицу?

Ввести матрицу.

Найти сумму четных элементов матрицы.

Если она отрицательна, то заменить элементы четных столбцов матрицы на 1, в ином случае нечетных столбцов на - 1.

Матрицу распечатать.

Seregaarhipov20 23 окт. 2020 г., 02:59:02 | 5 - 9 классы

Задан двумерный массив В из 4 - х строк и 5 - и столбцов?

Задан двумерный массив В из 4 - х строк и 5 - и столбцов.

Составить программу, которая организует одномерный массив, каждый элемент которого есть сумма элементов в столбце.

Вычислить произведение элементов полученного массива.

Магамед11 27 окт. 2020 г., 02:10:26 | 5 - 9 классы

Дана прямоугольная матрица?

Дана прямоугольная матрица.

Найти количество нулевых элементов каждого столбца матрицы и отсортировать столбцы по убыванию этих характеристик.

ПАСКАЛЬ.

Если вам необходимо получить ответ на вопрос Дана матрица состоящая из 5 строк и 10 столбцов заполненная случайными числами в диапазоне от 0 до 29?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.