Ввести с клавиатуры 2 числа в интервале от 0 до 999?

Информатика | 10 - 11 классы

Ввести с клавиатуры 2 числа в интервале от 0 до 999.

Вывести их на экран столбиком в виде, удобном для сложения или умножения.

То есть первый разряд первого числа под первым разрядом второго числа, второй разряд – под вторым и т.

Д.

Ответить на вопрос
Ответы (1)
Irinalevshina 29 февр. 2020 г., 08:21:02

Program chisla ;

uses crt ;

var a, b : integer ;

begin

Write('Введите два числа : ') ;

Read(a, b) ;

if (a> ; = 0) and (a< ; = 999) and (b> ; = 0) and (b< ; = 999) then

begin

if (a> ; = 100) and (a< ; = 999) then writeln(a) ;

if (b> ; = 100) and (b< ; = 999) then writeln(b) ;

if (a> ; = 10) and (a< ; = 99) then writeln(' ', a) ;

if (b> ; = 10) and (b< ; = 99) then writeln(' ', b) ;

if (a> ; = 0) and (a< ; = 9) then writeln(' ', ' ', a) ;

if (b> ; = 0) and (b< ; = 9) then writeln(' ', ' ', b) ;

end

else

Writeln('Нужно ввести числа от 0 до 999') ;

end.

Angal0 27 апр. 2020 г., 11:10:19 | 10 - 11 классы

Даны 2 числа в двоичном виде?

Даны 2 числа в двоичном виде.

В первом числе поменять местами старшую и младшую части числа.

Во втором - 1 - ый и 4 - ый разряды поменять местами с 3 - м и 7 - мым разрядами соответственно.

Результаты логически сложить и умножить на 4.

Rleisan 26 июн. 2020 г., 03:47:58 | 10 - 11 классы

Pascal?

Pascal.

Тема : Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа.

2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа.

Ася08 7 февр. 2020 г., 04:50:27 | 10 - 11 классы

Ввести с клавиатуры два числа?

Ввести с клавиатуры два числа.

Проверить, равно ли второе число нулю.

Если да, то вывести на экран фразу : «На ноль делить нельзя!

» Если нет, то найти их частное.

Matvey1070 11 февр. 2020 г., 04:59:40 | 10 - 11 классы

С клавиатуры вводятся 2 числа?

С клавиатуры вводятся 2 числа.

Если хотя бы одно из этих чисел является трёхзначным и кратным 3, вывести слово YES, иначе возвести первое число в квадрат, а из второго извлеч корень, вывести эти числа на экран.

Kate777123 17 янв. 2020 г., 14:58:16 | 5 - 9 классы

Даны два целых числа?

Даны два целых числа.

Программа должна вывести число 1, если первое число больше второго, число 2, если второе больше первого или число 0, если они равны.

Ввод 4, 5 Вывод 2.

Ofaliuta 12 июн. 2020 г., 17:36:07 | 5 - 9 классы

Ввести с клавиатуры число a?

Ввести с клавиатуры число a.

Если это число не больше, чем 18, то вывести на экран сообщение : "Число не больше 18.

VALYABELYAEVA 8 мар. 2020 г., 06:51:23 | 5 - 9 классы

1. Ввести два числа, если первое меньше второго, вывести первое, иначе вывести второе?

1. Ввести два числа, если первое меньше второго, вывести первое, иначе вывести второе.

2. Ввести число.

Если остаток от деления этого на два равен нулю, умножить число на 10.

Прошу оформить ответ в форме блок схемы и алгоритма - по русски.

Katya310797 7 янв. 2020 г., 02:51:50 | 10 - 11 классы

Предлагается некоторая операция над двумя произвольными трехзначными десятичными числами : 1) Записывается результат сложения старших разрядов этих чисел?

Предлагается некоторая операция над двумя произвольными трехзначными десятичными числами : 1) Записывается результат сложения старших разрядов этих чисел.

2) К нему дописывается результат сложения средних разрядов по такому правилу : если он меньше первой суммы, то полученное число приписывается к первому слева, иначе – справа.

3) Итоговое число получают приписыванием справа к числу, полученному после второго шага, сумму значений младших разрядов исходных чисел.

Какое из перечисленных чисел могло быть построено по этому правилу?

1) 141215 2) 121514 3) 141519 4) 112112.

Zharikoffmixa 16 июн. 2020 г., 01:33:30 | 5 - 9 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

Информатика, 10 класс, Паскаль 1)Написать программу.

Вводятся два двухзначных целых числа.

Подсчитать и вывести два числа : сумма десятков первого и второго числа и сумма единиц первого и второго числа.

2)Вводятся два двухзначных целых числа.

Подсчитать и вывести два числа : произведение десятков первого числа и единиц второго числа ; произведение единиц первого числа и десятков второго.

3)Вводятся два двухзначных целых числа.

Подсчитать и вывести два числа : произведение десятков первого числа и единиц второго числа ; сумма единиц первого числа и десятков второго числа.

AaaKro1344 27 апр. 2020 г., 07:41:09 | 10 - 11 классы

Введите с клавиатуры два целых нечетных числа (первое больше второго)?

Введите с клавиатуры два целых нечетных числа (первое больше второго).

Выведите на экран последовательность нечетных чисел, расположенных между этими числами (паскаль).

На этой странице сайта, в категории Информатика размещен ответ на вопрос Ввести с клавиатуры 2 числа в интервале от 0 до 999?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.