Введите с клавиатуры два целых нечетных числа (первое больше второго)?

Информатика | 10 - 11 классы

Введите с клавиатуры два целых нечетных числа (первое больше второго).

Выведите на экран последовательность нечетных чисел, расположенных между этими числами (паскаль).

Ответить на вопрос
Ответы (1)
Ксюняпй 27 апр. 2020 г., 07:41:15

Var a, b : integer ;

begin write('Введите нечетные a, b (a> ; b) ') ; readln(a, b) ; a : = a - 2 ; repeat if a mod 2 < ; > ; 0 then writeln(a) ; a : = a - 2 ; until a = b ;

end.

Тест №1

Введите нечетные a, b (a> ; b) - 89 - 99 - 91 - 93 - 95 - 97

Тест №2

Введите нечетные a, b (a> ; b) 99 89

97

95

93

91.

Daren 16 мая 2020 г., 05:08:13 | 10 - 11 классы

Составьте программу для решения следующей задачи?

Составьте программу для решения следующей задачи.

Введите с клавиатуры два числа : А и В.

Если числа не равны, то замените каждое из них большим и выведите результаты на экран.

Если они равны, то найдите и выведите удвоенную сумму этих чисел.

Solyanik1 9 нояб. 2020 г., 22:36:54 | 5 - 9 классы

Введите с клавиатуры два числа a и b ?

Введите с клавиатуры два числа a и b .

Если оба числа четные , то вычислите их сумки выведите результат на экран .

Если оба нечетные то найдите произведение этих чисел и выведите результат .

Иначе, увеличить все числа в пять раз и выведите результаты.

Решение, которое уже есть на сайте не писать.

Mihalcovich600 21 окт. 2020 г., 15:11:13 | 5 - 9 классы

Выведите на экран все нечетные числа от 31 до 1023?

Выведите на экран все нечетные числа от 31 до 1023.

Semkadenisds 22 апр. 2020 г., 23:16:49 | 10 - 11 классы

Составьте программу для решения следующей задачи?

Составьте программу для решения следующей задачи.

Введите с клавиатуры два числа : N и M.

Если оба числа больше 100, то замените каждое из них меньшим и выведите результаты на экран.

Если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты.

Иначе, найдите и выведите среднее арифметическое этих чисел.

Rleisan 26 июн. 2020 г., 03:47:58 | 10 - 11 классы

Pascal?

Pascal.

Тема : Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа.

2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа.

Kat1007 8 янв. 2020 г., 15:53:28 | 10 - 11 классы

Нужно написать программу?

Нужно написать программу.

Введите с клавиатуры 2 числа а и в, если числа не равны, то замените каждое из них на 0 и выведите результатом на экран.

Если они равны, то найдите и выведите удвоенную сумму этих чисел.

Milana0707bkru 29 июл. 2020 г., 01:49:16 | 10 - 11 классы

Введите с клавиатуры три числа : A, B и С?

Введите с клавиатуры три числа : A, B и С.

Если они не равны, то замените все числа наибольшим из них и выведите результаты на экран.

Иначе, найдите и выведите суммы квадратов этих чисел.

Аська03082001 11 окт. 2020 г., 19:51:08 | 1 - 4 классы

Введите с клавиатуры три числа если А> ; В> ; С> ; 0, то замените все числа их квадратами и выведите результаты на экран ?

Введите с клавиатуры три числа если А> ; В> ; С> ; 0, то замените все числа их квадратами и выведите результаты на экран .

Egorka1337228 14 окт. 2020 г., 15:51:39 | 1 - 4 классы

Введите с клавиатуры три числа если А> ; В> ; С> ; 0, то замените все числа их квадратами и выведите результаты на экран ?

Введите с клавиатуры три числа если А> ; В> ; С> ; 0, то замените все числа их квадратами и выведите результаты на экран .

Kriss959 20 окт. 2020 г., 01:52:04 | 10 - 11 классы

С клавиатуры вводится последовательность чисел до тех пор, пока не будет введено число 0?

С клавиатуры вводится последовательность чисел до тех пор, пока не будет введено число 0.

Требуется найти произведение нечетных чисел из введенной последовательности.

Решение с помощью while, подробно.

Вы зашли на страницу вопроса Введите с клавиатуры два целых нечетных числа (первое больше второго)?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.