Определить число единиц во введенном числе?

Информатика | 10 - 11 классы

Определить число единиц во введенном числе.

Паскаль АБС.

Ответить на вопрос
Ответы (1)
Ibraqimsaidov2 4 нояб. 2020 г., 23:54:33

Var s : string ; i, k : integer ;

begin Write('Введите произвольное число : ') ; Readln(s) ; k : = 0 ; for i : = 1 to length(s) do if s[i] = '1' then k : = k + 1 ; Writeln('Количество единиц в числе равно ', k) ;

end.

Тестовое решение :

Введите произвольное число : - 156153451.

4234111322

Количество единиц в числе равно 6.

Live96 12 февр. 2020 г., 23:57:43 | 10 - 11 классы

Напишите программу, которая считает сумму цифр введенного числа(паскаль)?

Напишите программу, которая считает сумму цифр введенного числа(паскаль).

Dracond 6 апр. 2020 г., 00:56:28 | 10 - 11 классы

Определить сумму цифр введенного числа a (a< ; 1000) в паскале, через for?

Определить сумму цифр введенного числа a (a< ; 1000) в паскале, через for.

5254 16 авг. 2020 г., 08:32:45 | 1 - 4 классы

Написать программу, которая число считанное с клавиатуры, увеличивает в два раза?

Написать программу, которая число считанное с клавиатуры, увеличивает в два раза.

Паскаль абс.

Mariaelenakam 6 мар. 2020 г., 07:14:20 | 5 - 9 классы

Напишите программу в паскале на определение максимального числа из двух введенных?

Напишите программу в паскале на определение максимального числа из двух введенных.

Harper2307 3 мая 2020 г., 15:21:01 | 5 - 9 классы

Напишите программу которая считает количество четных цифр введенного числа в паскале?

Напишите программу которая считает количество четных цифр введенного числа в паскале.

GigaSetUser 15 апр. 2020 г., 02:23:06 | 5 - 9 классы

Определить, является ли введенное число цифрой?

Определить, является ли введенное число цифрой?

Lizik2506 18 июл. 2020 г., 06:16:16 | 10 - 11 классы

Программирование на паскале : Определить знак числа x произвольно введенного с клавиатуры (x< ; > ; )?

Программирование на паскале : Определить знак числа x произвольно введенного с клавиатуры (x< ; > ; ).

Andrewcallcraft 14 окт. 2020 г., 08:22:42 | 5 - 9 классы

Помогите написать программу на паскале?

Помогите написать программу на паскале.

Надо чтобы введенное число оканчивалось на 7.

Викатарина 30 янв. 2020 г., 10:28:39 | 10 - 11 классы

Составить программу, печатающую все простые числа, не превосходящие данного числа?

Составить программу, печатающую все простые числа, не превосходящие данного числа.

Паскаль абс.

НастёнаNastua 16 дек. 2020 г., 07:43:07 | 10 - 11 классы

Определить минимум из 3 введенных чисел?

Определить минимум из 3 введенных чисел.

Если минимум отрицательное число, то найти сумму трех чисел, а иначе найти их произведение

В паскале.

На этой странице находится вопрос Определить число единиц во введенном числе?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.