Даны три числа x, y и z?

Информатика | 5 - 9 классы

Даны три числа x, y и z.

Найти : количество и сумму четных чисел, делящихся на 3.

Написать, на языке Паскаль.

Ответить на вопрос
Ответы (1)
Nicechizhova 7 мар. 2020 г., 12:08:41

Удивляюсь, как она у меня заработала)) хаха

program example ;

var x, y, z, a, b, c, i, k, l : integer ;

begin

writeln ('Введите три числа') ;

write ('x = ') ; readln (x) ;

write ('y = ') ; readln (y) ;

write ('z = ') ; readln (z) ;

if ((x mod 3) or (x mod 2)) = 0 then i : = x else i : = 0 ; if i< ; > ; 0 then a : = 1 ; if ((y mod 3) or (y mod 2)) = 0 then k : = y else k : = 0 ; if k< ; > ; 0 then b : = 1 ;

if ((z mod 3) or (z mod 2)) = 0 then l : = z else l : = 0 ; if l< ; > ; 0 then c : = 1 ;

writeln ('Количество четных чисел, делящихся на три, равно ', a + b + c) ; writeln ('Сумма четных чисел, делящихся на три, равна ', i + k + l) ;

end.

МасиМУШка 23 сент. 2020 г., 02:31:10 | 5 - 9 классы

Дано 4 числа найти сумму чисел, извлечь количество сотен, если четное, то найти среднее этих чисел, а , если нет, то произведение?

Дано 4 числа найти сумму чисел, извлечь количество сотен, если четное, то найти среднее этих чисел, а , если нет, то произведение.

Myrick 10 авг. 2020 г., 07:02:32 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найти сумму цифр числа.

(Написать программу на языке Паскаль).

Aleks690 14 февр. 2020 г., 15:54:05 | 5 - 9 классы

МНОГО БАЛЛОВ?

МНОГО БАЛЛОВ.

Написать на языке Паскаль данную задачу.

Желательно, с пояснениями.

Дано целое 3 - хзначное число.

Определить, является ли сумма его цифр четной.

Dашкаru5 2 нояб. 2020 г., 01:44:44 | 5 - 9 классы

Даны три числа x, y и z?

Даны три числа x, y и z.

Найти : Количество и сумму четных чисел, больших данного z.

Mur4ik313 23 июн. 2020 г., 08:38:00 | 5 - 9 классы

Дано натуральное число : а)получить все его делители б)найти сумму его делителей в)найти сумму его четных делителей г)определить количество его нечетных делителей е)определить количество его делителей?

Дано натуральное число : а)получить все его делители б)найти сумму его делителей в)найти сумму его четных делителей г)определить количество его нечетных делителей е)определить количество его делителей.

Сколько из них четных?

Ж)найти количество его делителей, больших d" На ТУРБО ПАСКАЛЕ СРОЧНО!

Мамочка11 18 апр. 2020 г., 04:56:08 | 5 - 9 классы

Найти сумму и произведение, количество четных чисел на промежутке[10 до 50]?

Найти сумму и произведение, количество четных чисел на промежутке[10 до 50].

В паскале надо бы программку составить очень надо.

Viltoria 14 мар. 2020 г., 02:51:25 | 5 - 9 классы

Дано все двузначные числа?

Дано все двузначные числа.

Найти количество и сумму кратных 5 (Язык Паскаль).

Яжеэтоя 20 апр. 2020 г., 11:20:19 | 5 - 9 классы

Найти сумму чисел, делящихся на 5 в промежутке от 60 до 80 в паскале?

Найти сумму чисел, делящихся на 5 в промежутке от 60 до 80 в паскале.

Артемида99 9 февр. 2020 г., 03:37:41 | 5 - 9 классы

Найти сумму чисел от 1 до N, делящихся на 5 и меньших а?

Найти сумму чисел от 1 до N, делящихся на 5 и меньших а.

Паскаль.

Kseniay150285 27 февр. 2020 г., 16:59:55 | 5 - 9 классы

Дано четырехразрядное натуральное число, если оно четное, то найти сумму разрядов, если нет - сумму квадратов?

Дано четырехразрядное натуральное число, если оно четное, то найти сумму разрядов, если нет - сумму квадратов.

(кумир или паскаль написать программу полностью).

На этой странице сайта размещен вопрос Даны три числа x, y и z? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.