ПОМОГИТЕ ПОЖАЛУЙСТА СРОЧНО Найдите произведение цифр заданного четырехзначного числа?

Информатика | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТА СРОЧНО Найдите произведение цифр заданного четырехзначного числа.

Сделать программу на Паскаль.

Ответить на вопрос
Ответы (1)
Тимур74 19 дек. 2020 г., 07:20:16

С помощью цикла while :

var a, s, x, n : integer ;

begin writeln('Введите число : ') ; read(n) ; a : = 1 ; x : = 1000 ; while x < ; > ; 0 do begin s : = (n div x) mod 10 ; a : = a * s ; x : = trunc(x / 10) ; end ; writeln('Результат : ', a) ;

end.

C помощью цикла repeat :

var a, s, x, n : integer ;

begin writeln('Введите число : ') ; read(n) ; a : = 1 ; x : = 1000 ; repeat s : = (n div x) mod 10 ; a : = a * s ; x : = trunc(x / 10) ; until x < ; 1 ; writeln('Результат : ', a) ;

end.

Раид 26 мар. 2020 г., 18:49:42 | 10 - 11 классы

Напишите программу, которая вводит четырехзначное число и вырезает из него вторую цифру(на языке паскаль)?

Напишите программу, которая вводит четырехзначное число и вырезает из него вторую цифру(на языке паскаль).

Vedma12 13 февр. 2020 г., 05:20:31 | 5 - 9 классы

Помогите, пожалуйста, составить программу в паскале?

Помогите, пожалуйста, составить программу в паскале!

Дано четырехзначное число заменить в нем наибольшую цифру нулем.

Cordelia 14 окт. 2020 г., 20:22:46 | 5 - 9 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

Паскаль

дано четырехзначное число, заменить нулем максимальную цифру.

Azzar26 14 февр. 2020 г., 14:56:07 | 10 - 11 классы

Найдите произведение трёх чисел вводимых с клавиатуры при условии , что они больше заданного числа ( найти по программе паскаль )?

Найдите произведение трёх чисел вводимых с клавиатуры при условии , что они больше заданного числа ( найти по программе паскаль ).

Chernysheva308 2 дек. 2020 г., 19:07:23 | 5 - 9 классы

Имеются три числа?

Имеются три числа.

Вычислите их произведение.

Информатика 9 класс - нужно сделать с программой паскаль!

Пожалуйста!

Оч срочно!

Dano4kA96 29 сент. 2020 г., 05:33:06 | 10 - 11 классы

Помогите пожалуйста составить программу паскаль и объясните ее дано четырехзначное число, получить новое поменяв местами первую и последнюю цифру?

Помогите пожалуйста составить программу паскаль и объясните ее дано четырехзначное число, получить новое поменяв местами первую и последнюю цифру.

Ola3331 5 нояб. 2020 г., 20:23:08 | 10 - 11 классы

PASALнаписать программу вычисляющую произведение второй и четвертой цифр четырехзначного числа?

PASAL

написать программу вычисляющую произведение второй и четвертой цифр четырехзначного числа.

Настя17092001 6 апр. 2020 г., 02:58:44 | 5 - 9 классы

СРОЧНОООО?

СРОЧНОООО!

ПОМОГИТЕ ПОЖАЛУЙСТА НАПИСАТЬ ПРОГРАММУ НА ПАСКАЛЕ!

Дано четырехзначное число.

Определить кратно ли четырем произведение его цифр.

Alina30001 11 июн. 2020 г., 10:10:43 | 10 - 11 классы

Дано целое четырехзначное число?

Дано целое четырехзначное число.

Если число четное, найти произведение его цифр, иначе перевернуть число, записав его цифры в обратном порядке.

Написать программу в Паскале.

Dysik19 30 дек. 2020 г., 09:39:33 | 5 - 9 классы

Задано двузначное число?

Задано двузначное число.

Составьте программу на языке Паскаль, с помощью которой определите, произведение квадратов цифр этого числа.

На этой странице сайта, в категории Информатика размещен ответ на вопрос ПОМОГИТЕ ПОЖАЛУЙСТА СРОЧНО Найдите произведение цифр заданного четырехзначного числа?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.