Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел?

Информатика | 10 - 11 классы

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел.

Получите новый масив, каждый элемент которого равен среднему арифметическому соответствующего элемента исходного массива и введенного с клавиатуры числа А.

В полученном массиве найдите максимальный элемент среди элементов с нечетными номерами.

Выведите на экран исходные и полученные результаты.

Ответить на вопрос
Ответы (1)
Субурбан 30 июл. 2020 г., 15:25:17

Uses crt ;

const n = 15 ;

var a : array[1.

N] of real ;

max : real ;

i, c : integer ;

begin

randomize ;

readln(c) ;

max : = - 50 ;

for i : = 1 to n do

begin

a[i] : = random(100) - 50 ;

write(a[i] : 4) ;

end ;

writeln ;

writeln ;

for i : = 1 to n do

begin

a[i] : = (c + a[i]) / 2 ;

write(a[i] : 4) ;

end ;

writeln ;

writeln ;

for i : = 1 to n do

begin

if (i mod 2< ; > ; 0) then

begin

if a[i]> ; max then max : = a[i] ;

end ;

end ;

write(max) ;

end.

Vermolenkova 1 нояб. 2020 г., 17:16:38 | 5 - 9 классы

Задача в Pascal ABC?

Задача в Pascal ABC.

Задайте массив из 10 элементов с помощью датчика случайных чисел.

Замените элементы массива, которые больше введенного с клавиатуры числа N.

Выведите на экран исходный и полученный массив.

Пожалуйста.

Jeneasuper96 2 апр. 2020 г., 20:28:56 | 10 - 11 классы

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел?

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел.

Получите новый массив, каждый элемент которого равен удвоенному соответствующему элементу исходного массива .

В полученном массиве найдите максимальный элемент среди элементов, номера которых кратны трем.

Выведите на экран исходные и полученные результаты.

Майн1 15 апр. 2020 г., 00:00:47 | 10 - 11 классы

Задайте массив из 10 элементов с помощью датчиков случайных чисел?

Задайте массив из 10 элементов с помощью датчиков случайных чисел.

Выведите на экран исходный массив и те элементы, которые больше 25.

Satusa 22 февр. 2020 г., 01:25:13 | 10 - 11 классы

Сформулируйте массив содержащий 15 элементов, с помощью датчика случайных чисел?

Сформулируйте массив содержащий 15 элементов, с помощью датчика случайных чисел.

Получите новый массив, каждый элемент которого равен квадрату соответствующего элемента исходного массива.

В полученном массиве определите насколько максимальный элемент исходного массива отличается от минимального элемента нового массива.

Выведите на экран исходные и полученные результаты.

Dianchik112 1 нояб. 2020 г., 23:34:11 | 10 - 11 классы

Задайте массив из 10 элементов с помощью датчика случайных чисел?

Задайте массив из 10 элементов с помощью датчика случайных чисел.

Замените все отрицательные элементы на наименьший положительный.

Выведите на экран исходный и полученный массив.

Haruzheva2010 22 мая 2020 г., 05:08:48 | 5 - 9 классы

Задайте массив из 10 элементов с помощью датчика случайных чисел?

Задайте массив из 10 элементов с помощью датчика случайных чисел.

Выведите на экран исходный массив и и номера тех элементов, которые расположены между наибольшим и наименьшим элементами.

Lubap1980 29 дек. 2020 г., 17:28:31 | 10 - 11 классы

Задайте массив из 10 элементов с помощью датчика случайных чисел ?

Задайте массив из 10 элементов с помощью датчика случайных чисел .

Поменяйте знаки всем четным элементам массива на протиположные .

Выведите на экран исходный и полученный массивы.

LapshovaMasha 11 мая 2020 г., 20:44:59 | 10 - 11 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

1. Сформируйте и выведите на экран массив из девяти элементов.

Каждые три последовательных элемента которого составлены по следующему правилу : 1 - й равен случайному трехзначному числу, деленному на 2 ; 2 - й равен текущему индексу, уменьшенному в 10 раз ; 3 - й равен сумме двух предыдущих элементов ; 2.

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел.

Получите новый массив, каждый элемент которого равен сумме соответствующего исходного элемента и его индекса исходного массива.

В полученном массиве удвойте элементы, которые меньше заданного с клавиатуры числа А, и найдите их сумму.

Выведите на экран исходные и полученные результаты.

Idfjkhgjfiiii 17 мар. 2020 г., 03:25:39 | 5 - 9 классы

Сформируйте массив a[i, j] с помощью датчика случайных чисел?

Сформируйте массив a[i, j] с помощью датчика случайных чисел.

Увеличить каждый элемент массива в 3 раза и если элемент массива отрицательный.

Массив выведите на экран в виде таблицы.

Камиль57 7 авг. 2020 г., 03:37:31 | 5 - 9 классы

СРОЧНООООО задайте массив из 10 элементов с помощью датчика случайных чисел?

СРОЧНООООО задайте массив из 10 элементов с помощью датчика случайных чисел.

Найдите сумму индексов элементов, которые больше среднего арифметического.

Выведите на экран исходный массив и полученную сумму.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.