Сформируйте массив a[i, j] с помощью датчика случайных чисел?

Информатика | 5 - 9 классы

Сформируйте массив a[i, j] с помощью датчика случайных чисел.

Увеличить каждый элемент массива в 3 раза и если элемент массива отрицательный.

Массив выведите на экран в виде таблицы.

Ответить на вопрос
Ответы (1)
Efimik1 17 мар. 2020 г., 03:25:44

"Увеличить каждый элемент массива в 3 раза и если элемент массива отрицательный.

"

Увеличить каждый элемент массива в 3 раза, если элемент массива отрицательный.

Может так?

Если так, то вот код.

Var l : Array[1.

10, 1.

10] of Integer ; i, j, n, m : Integer ;

begin

Writeln('Vvedite razmer matrisi : ') ;

Readln(n, m) ;

writeln('Isxodnaya matrisa : ') ;

for i : = 1 to n do

begin for j : = 1 to m do begin l[i, j] : = Random(51) - 25 ; Write(l[i, j] : 4) ; end ; writeln

end ;

writeln('Izmenennaya matrisa : ') ;

for i : = 1 to n do

begin for j : = 1 to m do begin if l[i, j]< ; 0 then l[i, j] : = l[i, j] * 3 ; write(l[i, j] : 4) ; end ; writeln

end ;

end.

Pigalevacat 11 февр. 2020 г., 21:12:00 | 5 - 9 классы

Массив из 40 случайных чисел, каждое из которых находится в диапазоне от - 30 до 30 :А) выведите на экран количество и индексы отрицательных элементов массива?

Массив из 40 случайных чисел, каждое из которых находится в диапазоне от - 30 до 30 :

А) выведите на экран количество и индексы отрицательных элементов массива.

Б) выведите на экран количество, индексы и значения элементов массива, кратных шести.

Дополнительно :

Выведите на экран максимальный элемент массива и его индекс.

Выведите на экран количество элементов массива, равных 7.

Marymenyailova 30 июл. 2020 г., 15:25:16 | 10 - 11 классы

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел?

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел.

Получите новый масив, каждый элемент которого равен среднему арифметическому соответствующего элемента исходного массива и введенного с клавиатуры числа А.

В полученном массиве найдите максимальный элемент среди элементов с нечетными номерами.

Выведите на экран исходные и полученные результаты.

Vermolenkova 1 нояб. 2020 г., 17:16:38 | 5 - 9 классы

Задача в Pascal ABC?

Задача в Pascal ABC.

Задайте массив из 10 элементов с помощью датчика случайных чисел.

Замените элементы массива, которые больше введенного с клавиатуры числа N.

Выведите на экран исходный и полученный массив.

Пожалуйста.

Katya1343 1 мая 2020 г., 10:22:52 | 10 - 11 классы

Сформировать с помощью датчика случайных чисел массива A[1?

Сформировать с помощью датчика случайных чисел массива A[1.

3, 1.

6], элементы которого находятся в промежутке от - 60 до 60.

Найти сумму элементов массива.

Вывести на экран массив в виде таблицы и сумму элементов массива.

Jeneasuper96 2 апр. 2020 г., 20:28:56 | 10 - 11 классы

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел?

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел.

Получите новый массив, каждый элемент которого равен удвоенному соответствующему элементу исходного массива .

В полученном массиве найдите максимальный элемент среди элементов, номера которых кратны трем.

Выведите на экран исходные и полученные результаты.

Майн1 15 апр. 2020 г., 00:00:47 | 10 - 11 классы

Задайте массив из 10 элементов с помощью датчиков случайных чисел?

Задайте массив из 10 элементов с помощью датчиков случайных чисел.

Выведите на экран исходный массив и те элементы, которые больше 25.

Satusa 22 февр. 2020 г., 01:25:13 | 10 - 11 классы

Сформулируйте массив содержащий 15 элементов, с помощью датчика случайных чисел?

Сформулируйте массив содержащий 15 элементов, с помощью датчика случайных чисел.

Получите новый массив, каждый элемент которого равен квадрату соответствующего элемента исходного массива.

В полученном массиве определите насколько максимальный элемент исходного массива отличается от минимального элемента нового массива.

Выведите на экран исходные и полученные результаты.

Dianchik112 1 нояб. 2020 г., 23:34:11 | 10 - 11 классы

Задайте массив из 10 элементов с помощью датчика случайных чисел?

Задайте массив из 10 элементов с помощью датчика случайных чисел.

Замените все отрицательные элементы на наименьший положительный.

Выведите на экран исходный и полученный массив.

Рони2000 15 апр. 2020 г., 05:12:24 | 10 - 11 классы

Помогите пожалуйстаЗадать двумерный массив А (7, 7) с помощью датчика случайных чисел и вывести его на экран в виде таблицы?

Помогите пожалуйста

Задать двумерный массив А (7, 7) с помощью датчика случайных чисел и вывести его на экран в виде таблицы.

Затем удвоить все его элементы и снова вывести на экран.

Оформите вывод массива в виде процедуры.

Lubap1980 29 дек. 2020 г., 17:28:31 | 10 - 11 классы

Задайте массив из 10 элементов с помощью датчика случайных чисел ?

Задайте массив из 10 элементов с помощью датчика случайных чисел .

Поменяйте знаки всем четным элементам массива на протиположные .

Выведите на экран исходный и полученный массивы.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Сформируйте массив a[i, j] с помощью датчика случайных чисел?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.