Найти максимальный по модулю элемент массива, массив состоит из n вещественных чисел ?

Информатика | 10 - 11 классы

Найти максимальный по модулю элемент массива, массив состоит из n вещественных чисел .

Помогите пожалуйста)).

Ответить на вопрос
Ответы (1)
Motvei 23 авг. 2020 г., 19:47:36

Uses crt ;

var a : array[1.

99] of real ;

i, j, n : integer ;

max : real ;

begin

write('Введите n : ') ;

readln(n) ;

writeln('Исходный массив : ') ;

for i : = 1 to n do begin a[i] : = random(99 - ( - 99) + 1) - 99 ; write(a[i] : 5) ; end ;

writeln ;

max : = - 5 ;

for i : = 1 to n do begin if abs(a[i])> ; max then begin max : = abs(a[i]) ; j : = i ; end ; end ;

writeln('Максимальное по модулю число равно ', a[j]) ;

end.

Здесь элементы массива - случайные числа от - 99 до 99.

В ответе выписывается само число, а не его модуль.

Если нужен именно модуль, то меняем предпоследнюю строку наwriteln('Максимальное по модулю число равно ', max) ;

Abdusalamova99 8 апр. 2020 г., 20:11:35 | 10 - 11 классы

Составить программу на языке Паскаль : 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0?

Составить программу на языке Паскаль : 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0.

2)В массиве М из 10 целых чисел найти количество элементов равных 3.

3)В массиве из 8 целых найти номер массива с наибольшим значением.

4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента.

5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Vanoli4 11 февр. 2020 г., 07:27:15 | 10 - 11 классы

Написать программу на С + + или паскаль?

Написать программу на С + + или паскаль.

Помогите пожалуйста!

В одномерном массиве, состоящем из n вещественных элементов, вычислить : - максимальный элемент массива ; - сумма элементов массива, расположенных до последнего положительного элемента .

Сжать массив, удалив из него все элементы, модуль которых находится в интервале (a.

B). Освободившийся в конце массива элементы заполнить нулями.

Rogovajulia201 3 янв. 2020 г., 04:15:07 | 10 - 11 классы

Ввести массив F(n) вещественных чисел?

Ввести массив F(n) вещественных чисел.

Если последний элемент массива положительный, то найти max среди элементов массива и заменить его значений последний элемент массива.

Массив распечатать.

Иначе – дать сообщение «Массив остался без изменений».

Qleb 12 июн. 2020 г., 21:57:19 | 5 - 9 классы

Дан массив состоящий из 30 элементов?

Дан массив состоящий из 30 элементов.

Найти в массиве максимальный элемент, вывести его значение и номер на экран.

Отрицательный элемент массива заменить на равные по модулю положительные элементы.

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Yanev77 2 июл. 2020 г., 20:10:46 | 10 - 11 классы

Найти максимальный по модулю элемент массива X(N) и поставить его первым?

Найти максимальный по модулю элемент массива X(N) и поставить его первым.

(одномерные массивы) пожалуйста если можно!

Megaalinamail 21 авг. 2020 г., 13:14:46 | 5 - 9 классы

Дан одномерный массив чисел?

Дан одномерный массив чисел.

Hайти количество элементов массива, превосходящих по модулю заданное число А, изменить знак максимального элемента на противоположный, найти количество элементов массива, кратных 5.

Aylovat40 16 окт. 2020 г., 08:55:54 | 10 - 11 классы

Дан одномерный массив из 12 чисел?

Дан одномерный массив из 12 чисел.

Элементами массива являются целые числа.

Найти максимальный элемент указанного массива.

Dmae 5 сент. 2020 г., 11:03:43 | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТА?

ПОМОГИТЕ ПОЖАЛУЙСТА!

СРОЧНО!

Задан линейный массив состоящий из n целых чисел.

Массив вводят с клавиатуры.

Найти максимальный элемент массива и его индексный номер.

Найдите количество массива равный 4.

Найти сумму элементов массива.

213rfe 2 сент. 2020 г., 15:06:18 | 5 - 9 классы

Решить в с + +задан массив Z(n) целых чисел?

Решить в с + +

задан массив Z(n) целых чисел.

Найти максимальный элемент массива и если это простое число - удалить все элементы равные максимальному значению.

Определить среднее арифметическое положительных элементов массива после удаления.

Упорядочить массив по убыванию модулей.

Если вам необходимо получить ответ на вопрос Найти максимальный по модулю элемент массива, массив состоит из n вещественных чисел ?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.