Ввести массив F(n) вещественных чисел?

Информатика | 10 - 11 классы

Ввести массив F(n) вещественных чисел.

Если последний элемент массива положительный, то найти max среди элементов массива и заменить его значений последний элемент массива.

Массив распечатать.

Иначе – дать сообщение «Массив остался без изменений».

Ответить на вопрос
Ответы (1)
ХоЗяЙкА13 3 янв. 2020 г., 04:15:10

Program Zadacha ;

Const n = 5 ;

Var a : Array[1.

N] Of Real ;

i, j : Integer ;

Begin

WriteLn('Введите ', n, ' чисел через пробел') ;

For i : = 1 To n DoRead(a[i]) ;

If a[n] > ; = 0 ThenBeginj : = 1 ;

For i : = 1 To n Do

If a[i] > ; a[j] Then

j : = i ; a[n] : = a[j] ;

For i : = 1 To n Do

Write(a[i], ' ') ;

End

Else

WriteLn('Массив остался без изменений') ;

ReadLn ;

End.

Lerunchik2001 18 янв. 2020 г., 18:22:07 | 10 - 11 классы

Дан целочисленный массив из 10 целых чисел?

Дан целочисленный массив из 10 целых чисел.

Преобразуйте его, прибавив к нечетным числам значение последнего элемента.

Последний элемент массива оставьте без изменений.

(В Паскале).

Vanoli4 11 февр. 2020 г., 07:27:15 | 10 - 11 классы

Написать программу на С + + или паскаль?

Написать программу на С + + или паскаль.

Помогите пожалуйста!

В одномерном массиве, состоящем из n вещественных элементов, вычислить : - максимальный элемент массива ; - сумма элементов массива, расположенных до последнего положительного элемента .

Сжать массив, удалив из него все элементы, модуль которых находится в интервале (a.

B). Освободившийся в конце массива элементы заполнить нулями.

Spacesrucom86 5 янв. 2020 г., 04:01:20 | 10 - 11 классы

Дан одномерный массив A, состоящий из N элементов, N – заданное натуральное число?

Дан одномерный массив A, состоящий из N элементов, N – заданное натуральное число.

Если элементы массива составляют строго монотонную последовательность, то все положительные элементы массива заменить единицей, иначе оставить массив без изменения.

Plombirka10 17 нояб. 2020 г., 18:38:13 | 10 - 11 классы

Ввести массив A(n) ?

Ввести массив A(n) .

Если в массиве не менее двух отрицательных элементов , то уменьшить отрицательные элементы массива на 2 , иначе найти номер первого минимального элемента массива.

Настя2005 3 янв. 2020 г., 06:37:14 | 5 - 9 классы

Дан одномерный массив, состоящий из вещественных элементов?

Дан одномерный массив, состоящий из вещественных элементов.

Найти сумму элементов массива, расположенных до последнего положительного элемента.

Qleb 12 июн. 2020 г., 21:57:19 | 5 - 9 классы

Дан массив состоящий из 30 элементов?

Дан массив состоящий из 30 элементов.

Найти в массиве максимальный элемент, вывести его значение и номер на экран.

Отрицательный элемент массива заменить на равные по модулю положительные элементы.

Grooooyl 2 сент. 2020 г., 04:57:55 | 10 - 11 классы

Задан массив из 10 целых чисел?

Задан массив из 10 целых чисел.

Замените все положительные элементы данного массива его максимальным элементом.

Kristina1009 9 дек. 2020 г., 11:37:10 | 5 - 9 классы

Задан массив из 7 целых чисел?

Задан массив из 7 целых чисел.

Заменить все положительные элементы данного массива на его максимальный элемент.

Дюймовочкa123 4 мая 2020 г., 21:39:21 | 10 - 11 классы

ВВЕСТИ МАССИВ А(n) ЦЕЛЫХ ЧИСЕЛ?

ВВЕСТИ МАССИВ А(n) ЦЕЛЫХ ЧИСЕЛ.

НАЙТИ MAX СРЕДИ ЭЛЕМЕНТОВ МАССИВА.

ЗАМЕНИТЬ ПЕРВЫЙ И ПОСЛЕДНИЙ ЭЛЕМЕНТЫ УДВОЕННЫМ ЗНАЧЕНИЕМ MAX.

Нася20001 31 дек. 2020 г., 18:18:27 | 5 - 9 классы

Ввести массив из 7 элементов?

Ввести массив из 7 элементов.

Подсчитать произведение положительных элементов массива.

На этой странице сайта вы найдете ответы на вопрос Ввести массив F(n) вещественных чисел?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.