Вычислить на эвм значения функции заданной в таблице?

Информатика | 10 - 11 классы

Вычислить на эвм значения функции заданной в таблице.

Программу составить таким образом, чтобы вычислялось многократное значение функции при изменении аргумента в указанном диапазоне и с заданным шагом.

Организовать вывод значения аргумента и вычисленного значения функции в виде таблицы.

Ответить на вопрос
Ответы (1)
Flor 27 мая 2020 г., 00:14:25

Const a = - 0.

5 ; b = 2 ; h = 0.

15 ; x1 = 0 ; x2 = 3 ;

var x, y : real ;

begin writeln('ТАБЛИЦА ФУНКЦИИ Y(X)') ; writeln(' X Y') ; x : = x1 ; repeat if x < ; 1 then y : = 1 else if x < ; = 2 then y : = a * sqr(x) * ln(x) else y : = exp(a * x) * cos(b * x) ; writeln(x : 4 : 2, y : 12 : 7) ; x : = x + h until x > ; x2 + 0.

0000001 {добавка к х2 для компенсации погрешности представления h в ЭВМ}

end.

Тестовое решение :

ТАБЛИЦА ФУНКЦИИ Y(X)

X Y

0.

00 1.

0000000

0.

15 1.

0000000

0.

30 1.

0000000

0.

45 1.

0000000

0.

60 1.

0000000

0.

75 1.

0000000

0.

90 1.

0000000

1.

05 - 0.

0268956

1.

20 - 0.

1312715

1.

35 - 0.

2734703

1.

50 - 0.

4561482

1.

65 - 0.

6816804

1.

80 - 0.

9522144

1.

95 - 1.

2697106

2.

10 - 0.

1715608

2.

25 - 0.

0684354

2.

40 0.

0263542

2.

55 0.

1056187

2.

70 0.

1645379

2.

85 0.

2007555

3.

00 0.

2142429.

Margo1972 7 янв. 2020 г., 13:43:56 | 10 - 11 классы

Составить программу вычисления значений функции F(x) на отрезке [а ; b] с шагом h?

Составить программу вычисления значений функции F(x) на отрезке [а ; b] с шагом h.

Результат представить в виде таблицы, первый столбец которой — значения аргумента, второй — соответствующие значения функции : F(X) = 1 / 2 sin x / 4 + 1.

Kinggg 30 нояб. 2020 г., 04:44:38 | 10 - 11 классы

Написать программу, которая по введенному значению аргумента вычисляет значение функции, заданной в виде графика?

Написать программу, которая по введенному значению аргумента вычисляет значение функции, заданной в виде графика.

Rahimbaevaalina 23 нояб. 2020 г., 10:13:33 | 10 - 11 классы

Используя метод нисходящего проектирования, разработать схему алгоритма и составить программу вычисления функции при заданных значениях аргументов?

Используя метод нисходящего проектирования, разработать схему алгоритма и составить программу вычисления функции при заданных значениях аргументов.

(язык pascal).

Loveeclat5 1 февр. 2020 г., 22:40:52 | 10 - 11 классы

Составить программу для вычисления значения функции F(x) = x * cos(1 / x) + 2 на отрезке [a, b] с шагом h?

Составить программу для вычисления значения функции F(x) = x * cos(1 / x) + 2 на отрезке [a, b] с шагом h.

Результаты представить в виде таблицы (1 - ый столбец - значения аргумента, 2 - ой - значение функции).

Aroonlistru 1 июн. 2020 г., 09:35:11 | 10 - 11 классы

Составить программу для вычисления значений функции F(x) на отрезке [а, b] с шагом h(через цикл while )?

Составить программу для вычисления значений функции F(x) на отрезке [а, b] с шагом h(через цикл while ).

Результат представить в виде таблицы, первый столбец которой — значения аргумента, второй — соответствующие значения функции.

F(x) = 2tg(x / 2) + 1.

Djulyaarz 30 нояб. 2020 г., 15:58:28 | 10 - 11 классы

Вычислить значение функции y = x ^ 3 - x ^ 2 + 2sqrt(x) на отрезке[ - 2 ; 2] с заданным шагом изменения аргумента dx = 0, 25?

Вычислить значение функции y = x ^ 3 - x ^ 2 + 2sqrt(x) на отрезке[ - 2 ; 2] с заданным шагом изменения аргумента dx = 0, 25.

Результат оформить в виде таблицы.

Bahtinur3 31 мая 2020 г., 20:49:45 | 10 - 11 классы

Написать программу, которая по введенному значению аргумента вычисляет значение функции, заданной в виде графика?

Написать программу, которая по введенному значению аргумента вычисляет значение функции, заданной в виде графика.

Параметр R вводится с клавиатуры.

Полишечка456 11 июл. 2020 г., 13:51:01 | 5 - 9 классы

Написать программу в бейсике которая выводит табличное значение функции y = / x / + 2 диапазон изменения аргумента от - 4до4 приращение аргумента - 0, 5 / / - модуль?

Написать программу в бейсике которая выводит табличное значение функции y = / x / + 2 диапазон изменения аргумента от - 4до4 приращение аргумента - 0, 5 / / - модуль.

Firuzabagbanov 6 сент. 2020 г., 02:05:39 | 5 - 9 классы

Написать программу (язык программирования - паскаль), которая выводит таблицу значений функции y = |x - 2| + |x + 1|?

Написать программу (язык программирования - паскаль), которая выводит таблицу значений функции y = |x - 2| + |x + 1|.

Диапазон изменения аргумента от - 4 до 4, шаг приращения аргумента - 0, 5.

Sashaivacshuk135 27 дек. 2020 г., 06:22:58 | 10 - 11 классы

Написать программу вычисления значений функций в заданных точках?

Написать программу вычисления значений функций в заданных точках.

Если вам необходимо получить ответ на вопрос Вычислить на эвм значения функции заданной в таблице?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.