Используя операции div и mod решите следующую задачу : Требуется найти разность между трехзначным числом и числом, составленным из тех же цифр, но взятых в обратном порядке?

Информатика | 5 - 9 классы

Используя операции div и mod решите следующую задачу : Требуется найти разность между трехзначным числом и числом, составленным из тех же цифр, но взятых в обратном порядке.

Ответить на вопрос
Ответы (1)
Kucherenkoa82 1 авг. 2020 г., 02:56:46

Var a, b : integer ;

begin readln(a) ; b : = (a mod 10) * 100 + (a mod 100 div 10) * 10 + (a div 100) ; writeln(a, ' - ', b, ' = ', a - b) ;

end.

Anna202025 9 авг. 2020 г., 08:32:25 | 5 - 9 классы

Нужно написать программу для нахождения суммы цифр любого трехзначного числа, вводимого с клавиатуры во время работы программы)) как это сделать с помощью mod или div без цикла?

Нужно написать программу для нахождения суммы цифр любого трехзначного числа, вводимого с клавиатуры во время работы программы)) как это сделать с помощью mod или div без цикла?

Tltgorod 27 мар. 2020 г., 12:10:50 | 5 - 9 классы

По заданному трехзначному числу вывести на экран число состоящее из этих цифр, но в обратном порядке Задача в паскале Помогите с решением?

По заданному трехзначному числу вывести на экран число состоящее из этих цифр, но в обратном порядке Задача в паскале Помогите с решением.

Marmarina83 12 авг. 2020 г., 09:54:20 | 5 - 9 классы

Turbo Pascal Человек ввел трехзначное число, при помощи функций div и mod найти их сумму?

Turbo Pascal Человек ввел трехзначное число, при помощи функций div и mod найти их сумму.

Kry0182000 10 февр. 2020 г., 19:53:01 | 10 - 11 классы

Напишите программу на языке Паскаль для решения следующей задачи : Для любого трехзначного вводимого числа найти сумму первой и последней цифры?

Напишите программу на языке Паскаль для решения следующей задачи : Для любого трехзначного вводимого числа найти сумму первой и последней цифры.

(Подсказка.

Используйти тип данных integer и операции div и mod).

Perehoghina01 16 июн. 2020 г., 00:48:43 | 10 - 11 классы

Получить случайное трехзначное число и вывести через запятую все его отдельные цифры?

Получить случайное трехзначное число и вывести через запятую все его отдельные цифры.

Сделать для программы Паскаль!

Без mod и div.

Dima12345678987 22 июл. 2020 г., 03:33:39 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Используя операцию деления нацело, надо вывести первую цифру данного числа (cотни).

Ксюша2100 27 февр. 2020 г., 00:34:48 | 10 - 11 классы

Дано целое двухзначное число?

Дано целое двухзначное число.

Используя операции div и mod, найти произведение его цифр.

Для облегчения поиска решения имейте в виду, что для двузначного числа первая цифра дается выражением d1 : = x div 10 ; а вторая выражением d2 : = x mod 10 ;

Ааабббвввгоггг 15 нояб. 2020 г., 05:50:38 | 5 - 9 классы

Распишите, пожалуйста, подробно?

Распишите, пожалуйста, подробно.

Что именно записать Задача 1.

Используя операции div и mod, найти сумму цифр случайного трехзначного числа.

На экран должно быть выведено само число и сумма цифр этого числа.

Задача 2.

Получить четырехзначное число, полученное из случайного двузначного числа, приписыванием цифры единиц в качестве цифры тысяч, а цифры десятков – в качестве цифры сотен.

(например, из числа 32 получится число 2332).

Emilythompson 26 янв. 2020 г., 05:13:15 | 5 - 9 классы

Определить 3 - ю цифру в записи 6 - значного натурального числа?

Определить 3 - ю цифру в записи 6 - значного натурального числа.

Для нахождения 3 цифры надо "отрезать" от числа последние 3 и первые 2 цифры Составить программу , применяя операции div и mod.

Помогите пожалуйста.

Sukhomlinovaga 28 дек. 2020 г., 23:58:53 | 5 - 9 классы

Используя операторов div и mod, составить алгоритм нахождения суммы и произведения цифр двузначного числа?

Используя операторов div и mod, составить алгоритм нахождения суммы и произведения цифр двузначного числа.

Помогите срочно.

Вопрос Используя операции div и mod решите следующую задачу : Требуется найти разность между трехзначным числом и числом, составленным из тех же цифр, но взятых в обратном порядке?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.