Используя операторов div и mod, составить алгоритм нахождения суммы и произведения цифр двузначного числа?

Информатика | 5 - 9 классы

Используя операторов div и mod, составить алгоритм нахождения суммы и произведения цифр двузначного числа.

Помогите срочно.

Ответить на вопрос
Ответы (1)
Sensei121 28 дек. 2020 г., 23:58:55

Var N, f, s : byte ;

begin write('N = ') ; readln(N) ; f : = N div 10 ; s : = N mod 10 ; writeln('Сумма цифр : ', f + s) ; writeln('Произведение цифр : ', f * s) ;

end.

Anna202025 9 авг. 2020 г., 08:32:25 | 5 - 9 классы

Нужно написать программу для нахождения суммы цифр любого трехзначного числа, вводимого с клавиатуры во время работы программы)) как это сделать с помощью mod или div без цикла?

Нужно написать программу для нахождения суммы цифр любого трехзначного числа, вводимого с клавиатуры во время работы программы)) как это сделать с помощью mod или div без цикла?

Lerokk2000 26 дек. 2020 г., 10:03:18 | 5 - 9 классы

Напишите программу для нахождения произведения цифр двузначного числа?

Напишите программу для нахождения произведения цифр двузначного числа.

Buzkop 17 авг. 2020 г., 18:09:12 | 5 - 9 классы

Оператор mod(a, b) – находит остаток от деления целого числа a на целое число b, например : mod(25, 4) = 1?

Оператор mod(a, b) – находит остаток от деления целого числа a на целое число b, например : mod(25, 4) = 1.

Оператор div(a, b) – находит целую часть от деления целого числа a на целое число b, например : div(25, 4) = 6.

Чему будет равно значение выражения : mod(23, 10) * 10 + div(23, 10)?

Tati888 4 нояб. 2020 г., 10:55:12 | 5 - 9 классы

Составить алгоритм нахождения суммы цифр числа?

Составить алгоритм нахождения суммы цифр числа.

Напишите на С + +.

Imtmawr 8 мар. 2020 г., 01:31:44 | 5 - 9 классы

Решение задач в паскале с помощью div и mod 8 класс?

Решение задач в паскале с помощью div и mod 8 класс.

Дано четырехзначное число .

Нужно вычислить квадрат суммы всех цифр.

Помогите пожалуйста!

Настя1111111ч 20 авг. 2020 г., 20:23:36 | 10 - 11 классы

Задачи на циклический алгоритм Microsoft Visual Studio C#В каких двузначных числах удвоенная сумма цифр равна их произведению?

Задачи на циклический алгоритм Microsoft Visual Studio C#В каких двузначных числах удвоенная сумма цифр равна их произведению?

Ксюша2100 27 февр. 2020 г., 00:34:48 | 10 - 11 классы

Дано целое двухзначное число?

Дано целое двухзначное число.

Используя операции div и mod, найти произведение его цифр.

Для облегчения поиска решения имейте в виду, что для двузначного числа первая цифра дается выражением d1 : = x div 10 ; а вторая выражением d2 : = x mod 10 ;

Ааабббвввгоггг 15 нояб. 2020 г., 05:50:38 | 5 - 9 классы

Распишите, пожалуйста, подробно?

Распишите, пожалуйста, подробно.

Что именно записать Задача 1.

Используя операции div и mod, найти сумму цифр случайного трехзначного числа.

На экран должно быть выведено само число и сумма цифр этого числа.

Задача 2.

Получить четырехзначное число, полученное из случайного двузначного числа, приписыванием цифры единиц в качестве цифры тысяч, а цифры десятков – в качестве цифры сотен.

(например, из числа 32 получится число 2332).

Emilythompson 26 янв. 2020 г., 05:13:15 | 5 - 9 классы

Определить 3 - ю цифру в записи 6 - значного натурального числа?

Определить 3 - ю цифру в записи 6 - значного натурального числа.

Для нахождения 3 цифры надо "отрезать" от числа последние 3 и первые 2 цифры Составить программу , применяя операции div и mod.

Помогите пожалуйста.

Игорьятебялюблю 25 сент. 2020 г., 15:21:03 | 5 - 9 классы

Составьте алгоритм нахождения суммы цифр двухзначного числа?

Составьте алгоритм нахождения суммы цифр двухзначного числа.

На этой странице находится вопрос Используя операторов div и mod, составить алгоритм нахождения суммы и произведения цифр двузначного числа?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.