В двухмерном массиве в строках хранится информация об оценках каждого из 20 учеников класса по тому или иному предмету (в первой строке – информация об оценках первого ученика, во второй – второго и т?

Информатика | 5 - 9 классы

В двухмерном массиве в строках хранится информация об оценках каждого из 20 учеников класса по тому или иному предмету (в первой строке – информация об оценках первого ученика, во второй – второго и т.

Д. ).

Общее число предметов равно 10.

Определить среднюю оценку по классу в целом.

Помогите составить программку : 3.

Ответить на вопрос
Ответы (1)
Sadina1 30 дек. 2020 г., 00:26:40

Program Task ;

Const pupils = 20 ; subjects = 10 ;

Var marks : Array[1.

Pupils, 1.

Subjects] of Integer ; marks_average : Array[1.

Pupils] of Real ; i, j : Integer ; all_marks_average : Real ;

Begin For i : = 1 To pupils Do Begin WriteLn('Введите через пробел оценки ученика №', i) ; For j : = 1 To subjects Do Read(marks[i, j]) ; End ; For i : = 1 To pupils Do Begin For j : = 1 To subjects Do marks_average[i] : = marks_average[i] + marks[i, j] ; marks_average[i] : = marks_average[i] / subjects ; End ; For i : = 1 To pupils Do all_marks_average : = all_marks_average + marks_average[i] ; all_marks_average : = all_marks_average / pupils ; WriteLn('Результат : ', all_marks_average : 2 : 2) ;

ReadLn ;

End.

Hgkugjkkl 29 февр. 2020 г., 22:34:17 | 10 - 11 классы

DamikbaltabarvJos?

DamikbaltabarvJos.

Помогите решить задачу на QbasikВ классе были проведены 2 контрольные работы .

Ученики получили соответствующие оценки .

Учитель решил их наказать и сказал что за четверть будет выставлена средняя арифметическая оценка с округлением в меньшую сторону.

Определить максимальную оценку за четверть и номер ученика получившего эту оценку.

Вы получите 20 баллов.

Slavyan2002 25 окт. 2020 г., 19:26:27 | 10 - 11 классы

Создайте массив случайным образом, содержащий оценки десяти учеников за выполнение трёх контрольных работ (по три оценки для каждого)?

Создайте массив случайным образом, содержащий оценки десяти учеников за выполнение трёх контрольных работ (по три оценки для каждого).

Выведите на экран средний балл каждого ученика.

Подсчитайте число учеников : * выполнивших первую работу на "5" * выполнивших хотя бы одну работу на "5" * выполнивших все работы на "5" * выполнивших вторую работу на "4" или "5" * не получивших ни одной оценки "5" * выполнивших первую работу на "3", вторую - на "4" и третью - на "5".

Zeys1975 31 янв. 2020 г., 13:21:52 | 5 - 9 классы

Известны оценки по физике каждого ученика двух классов?

Известны оценки по физике каждого ученика двух классов.

Определить среднюю оценку в каждом классе.

Кол - во учащихся в классе - не более 25.

Kcuxа2013 20 июл. 2020 г., 10:10:04 | 10 - 11 классы

В массиве состоящим из 30 целых чисел вводят оценки 10 учениов , Нужно вывести на экран оценки в виде таблицы : в первом столбце номер ученика, во втором его оценки?

В массиве состоящим из 30 целых чисел вводят оценки 10 учениов , Нужно вывести на экран оценки в виде таблицы : в первом столбце номер ученика, во втором его оценки.

Написать программу паскаль.

Дилина 25 нояб. 2020 г., 16:43:21 | 5 - 9 классы

Помогите?

Помогите!

Паскаль.

Заранее спасибо))) паскаль.

1)известны оценки по информатике каждого из 20 учеников класса.

В начале списка перечислены все пятерки, затем все остальные оценки.

Сколько учеников имеют по информатике оценку пять?

Условный оператор не использовать.

Vasilkowavika 4 сент. 2020 г., 00:17:32 | 10 - 11 классы

Надо составить массив 2х2, что бы самому надо было вводить в него числа?

Надо составить массив 2х2, что бы самому надо было вводить в него числа.

Потом он должен считать первую и вторую строки массива(отдельно) и определить какая из строк больше.

Иринка5602665 6 июл. 2020 г., 00:27:10 | 5 - 9 классы

N учащихся получили оценки за контрольную работу?

N учащихся получили оценки за контрольную работу.

Ввести оценку каждого ученика, найти средний балл, кол - во неудовлетворительных оценок.

Спорт11 20 окт. 2020 г., 06:21:07 | 5 - 9 классы

Помогите?

Помогите!

Программирование циклических структур : 1.

Известны оценки по информатике каждого ученика в классе.

Определите средний балл.

Masha131 29 апр. 2020 г., 18:57:42 | 5 - 9 классы

Python Известны оценки по алгебре каждого ученика класса?

Python Известны оценки по алгебре каждого ученика класса.

Определить среднюю оценку.

Dogwgggggggggg 23 окт. 2020 г., 14:22:52 | 10 - 11 классы

На соревнованиях выступление спортсмена оценивают 5 экспертов, каждый из них выставляет оценку в баллах (целое число)?

На соревнованиях выступление спортсмена оценивают 5 экспертов, каждый из них выставляет оценку в баллах (целое число).

Для получения итоговой оценки лучшая и худшая из оценок экспертов отбрасываются, а для оставшихся трёх находится среднее арифметическое.

Напишите программу, которая принимает 5 оценок экспертов и возвращает итоговую оценку спортсмена.

Используйте функцию для вычисления итоговой оценки.

Входные данные

Входная строка содержит 5 неотрицательных целых чисел, разделённых пробелами.

Выходные данные

Программа должна вывести в первой строке отброшенные оценки экспертов (минимальную, затем максимальную), разделив их пробелами.

Во второй строке выводится одно вещественное число : итоговая оценка с двумя знаками в дробной части.

Примеры

входные данные

1 2 3 4 5

выходные данные

1 5

3.

00.

Вопрос В двухмерном массиве в строках хранится информация об оценках каждого из 20 учеников класса по тому или иному предмету (в первой строке – информация об оценках первого ученика, во второй – второго и т?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.