Дано трехзначное число?

Информатика | 5 - 9 классы

Дано трехзначное число.

Определить, какая из его цифр

больше :

а) первая или последняя ;

б) первая или вторая ;

в) вторая или последняя.

РЕШИТЬ на Visual Studio.

Ответить на вопрос
Ответы (1)
Equinoob 2 авг. 2020 г., 19:37:17

Program Digit ;

Var a, a1, a2, a3 : Integer ;

Label Start ;

Begin

Start :

WriteLn('Введите трехзначное число') ;

ReadLn(a) ;

If (a < ; 100) Or (a > ; 999) Then

Begin

WriteLn('Вы ввели не трехзначное число') ;

Goto Start ;

End ;

a1 : = a div 100 ;

a2 : = (a - a1 * 100) div 10 ;

a3 : = a - a1 * 100 - a2 * 10 ;

If a1 > ; a3 ThenWriteLn('Первая цифра больше последней')

Else

Writeln('Последняя цифра больше первой') ;

If a1 > ; a2 Then

WriteLn('Первая цифра больше второй')

Else

Writeln('Вторая цифра больше первой') ;

If a2 > ; a3 Then

WriteLn('Вторая цифра больше последней')

Else

Writeln('Последняя цифра больше второй') ;

ReadLn ;

End.

Yuliav82 24 окт. 2020 г., 19:30:35 | 5 - 9 классы

Дано трёхзначное число?

Дано трёхзначное число.

Определить, какая из его цифр больше : а)первая или последняя б)первая или вторая в) вторая или последняя решить с помощью microsoft visual c# заранее спасибо).

Nadyakotelniko1 18 июн. 2020 г., 11:27:42 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найти среднеарифмитическое его цифр и прибавить произведение первой и последней цифры.

Prisakargalina 5 июн. 2020 г., 01:13:11 | 10 - 11 классы

Паскаль?

Паскаль.

1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево.

2) Дано трехзначное число.

В нем зачеркнули последнюю справа цифру и приписали ее в начале.

Найти полученное число.

3) Дано трехзначное число.

Найти число, полученное при перестановке первой и второй цифр заданного числа.

ШколаШкола 18 авг. 2020 г., 20:46:45 | 10 - 11 классы

1. ) Дано трехзначное число?

1. ) Дано трехзначное число.

Определить, какая из его цифр больше : a.

Первая или вторая ; b.

Вторая или последняя.

Warfacezadrot 6 окт. 2020 г., 01:56:10 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить, какое из его цифр больше : первая или последняя.

Mysterium 25 июл. 2020 г., 15:46:22 | 10 - 11 классы

1. Дано трехзначное число?

1. Дано трехзначное число.

Написать программу (Pascal), которая «переставляет» первую цифру числа на самое последнее место.

Titan55557 24 июн. 2020 г., 01:32:35 | 5 - 9 классы

Дано пятизначное натуральное число?

Дано пятизначное натуральное число.

Определить его первую и последнюю цифры.

Mary2001S 14 сент. 2020 г., 02:04:00 | 1 - 4 классы

Дано трехзначное число?

Дано трехзначное число.

Найти сумму кубов первой и второй его цифр.

Zaika198577 9 сент. 2020 г., 02:52:59 | 10 - 11 классы

Помогите создать программку через Visual studio C + + Дано трехзначное число?

Помогите создать программку через Visual studio C + + Дано трехзначное число.

Определить, какая из его цифр больше : а) первая или последняя ; б) первая или вторая ; в) вторая или последняя.

Alinplwww16 16 сент. 2020 г., 17:12:24 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найти число, полученное при перестановке первой и последней

цифр заданного числа.

Pascal.

На этой странице находится ответ на вопрос Дано трехзначное число?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.