Всем Привет?

Информатика | 10 - 11 классы

Всем Привет!

1. В текстовом файле хранятся квадратные целочисленные матрицы порядка n.

Преобразовать файл, удалив из каждой матрицы элементы побочной диагонали.

Ответить на вопрос
Ответы (1)
AnyaNikolaeva 16 июн. 2020 г., 20:45:37

Const n = 3 ;

type M = array[1.

3, 1.

3] of integer ;

var i, j : integer ; f : Text ; a, b : M ; s : string ;

begin Assign(f, 'input.

Dat') ; Reset(f) ; writeln('Считываемые данные') ; for i : = 1 to n do begin for j : = 1 to n do begin read(f, a[i, j]) ; write(a[i, j] : 4) end ; writeln end ; writeln ; for i : = 1 to n do begin for j : = 1 to n do begin read(f, b[i, j]) ; write(b[i, j] : 4) end ; writeln end ; Close(f) ; Rewrite(f) ; for i : = 1 to n do for j : = 1 to n do if j < ; > ; n + 1 - i then write(f, a[i, j], ' ') ; writeln(f) ; for i : = 1 to n do for j : = 1 to n do if j < ; > ; n + 1 - i then write(f, b[i, j], ' ') ; writeln(f) ; Close(f) ; Reset(f) ; writeln('Данные, перезаписанные в файл') ; while not eof(f) do begin readln(f, s) ; writeln(s) end ; Close(f) ; writeln

end.

Тестовое решение :

Считываемые данные 2 3 7 4 3 1 8 9 6 14 3 12 5 - 2 8 6 0 13

Данные, перезаписанные в файл

2 3 4 1 9 6

14 3 5 8 0 13.

Snezhana250603 28 нояб. 2020 г., 02:59:38 | 5 - 9 классы

23. Дана действительная квадратная матрица порядка n?

23. Дана действительная квадратная матрица порядка n.

Выяснить, верно ли, что наибольшее из значений элементов главной диагонали больше, чем наименьшее из значений элементов побочной диагонали.

Kiryashonok1 1 июл. 2020 г., 00:45:12 | 10 - 11 классы

Дана целочисленная квадратная матрица?

Дана целочисленная квадратная матрица.

Найти число строк, сумма элементов которых равна сумме элементов главной диагонали данной матрицы.

Нужна на языке си.

Yarima 12 окт. 2020 г., 14:59:23 | 10 - 11 классы

Дана целочисленная квадратная матрица найти сумму элементов, стоящих выше главной диагонали на языке Turbo Pascal?

Дана целочисленная квадратная матрица найти сумму элементов, стоящих выше главной диагонали на языке Turbo Pascal.

Dima1210 19 мар. 2020 г., 23:23:16 | 10 - 11 классы

Помогите люди))?

Помогите люди)).

Дана квадратная целочисленная матрица размера 4х4.

Заменить нулями элементы матрицы, лежащие на главной диагонали.

В bordland paskal .

Задача на двумерный массив.

ПуФФысТиК19 23 окт. 2020 г., 11:48:40 | 10 - 11 классы

Дана целочисленная матрица 5 на 5 ?

Дана целочисленная матрица 5 на 5 .

Определить положительные элементы на побочной диагонали.

(В Паскале).

Zajchikova1986 2 апр. 2020 г., 15:05:57 | 10 - 11 классы

Дана квадратная матрица порядка N?

Дана квадратная матрица порядка N.

Найти произведение элементов побочных диагонали квадратной матрицы.

Angelinaaleksan 7 мая 2020 г., 22:38:13 | 10 - 11 классы

Дана вещественная квадратная матрица А порядка n?

Дана вещественная квадратная матрица А порядка n.

Найти среднее арифметическое среди положительных элементов матрицы, находящихся на главной и побочной диагоналях.

Выдать сообщение, если таких элементов нет.

Лиза231001 14 окт. 2020 г., 12:10:52 | 10 - 11 классы

Дана целочисленная матрица 5 на 5?

Дана целочисленная матрица 5 на 5.

Определить положительные элементы на побочной диагонали.

(Паскаль).

KarinaAksenova 16 мар. 2020 г., 23:26:59 | 10 - 11 классы

Написать программу на С + + ?

Написать программу на С + + .

Дана целочисленная квадратная матрица произвольной размерности.

Сформировать одномерный массив, в который поместить элементы двумерной матрицы, находящиеся над побочной диагонали ; упорядочить их по возрастанию и найти их среднее арифметическое.

Babinababina 5 февр. 2020 г., 02:02:02 | 10 - 11 классы

4. Дана целочисленная матрица А(N, N)?

4. Дана целочисленная матрица А(N, N).

Определите, будет ли сумма всех элементов, расположенных ниже вспомогательной (побочной) диагонали при делении на два четным числом.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Всем Привет?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.