Даны n чисел?

Информатика | 10 - 11 классы

Даны n чисел.

Найдите произведение максимального и минимального из них.

Ответить на вопрос
Ответы (1)
Sasha2002saske 23 мая 2020 г., 23:41:51

Uses crt ;

var x, i, n, max, min : integer ;

begin readln(n) ; read(x) ; max : = x ; min : = x ; for i : = 1 to n - 1 do begin readln(x) ; if min > ; x then min : = x ; if max < ; x then max : = x ; end ; writeln(min, ' ', max) ;

end.

Anasteyshen 20 нояб. 2020 г., 22:04:17 | 5 - 9 классы

Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел?

Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел.

Kondra 24 янв. 2020 г., 07:40:31 | 10 - 11 классы

В одномерном целочисленном массиве определить среднее арифмитическое максимального и минимального чисел?

В одномерном целочисленном массиве определить среднее арифмитическое максимального и минимального чисел.

Mehanik8283 15 мар. 2020 г., 22:04:01 | 10 - 11 классы

Дан одномерный массив из n целых чисел?

Дан одномерный массив из n целых чисел.

Составить программу нахождения максимального и минимального элементов.

Татьяна821 22 окт. 2020 г., 01:31:31 | 10 - 11 классы

Дана последовательность чисел?

Дана последовательность чисел.

Найти минимальное и максимальное число и вычислить их среднее арифметическое.

KR2002 25 янв. 2020 г., 18:51:06 | 5 - 9 классы

Дан массив состоящий из 10 целых чисел, заданных случайным образом из промежутка [5?

Дан массив состоящий из 10 целых чисел, заданных случайным образом из промежутка [5.

25] найти минимальное и максимальное значения, их сумму.

Maksimabdulin 1 мар. 2020 г., 04:23:08 | 10 - 11 классы

Написать код программы для решения следующей задачи : Дано 5 чисел?

Написать код программы для решения следующей задачи : Дано 5 чисел.

Посчитать произведение максимального и минимального чисел для данного подмножества.

Результат вывести на экран.

Язык программирования C + +.

Mmmppp401 10 янв. 2020 г., 11:36:11 | 10 - 11 классы

Дано 100 вещественных чисел?

Дано 100 вещественных чисел.

Вычислить разность между максимальным и минимальным из них.

На ПАСКАЛЕ.

Verfil53 13 февр. 2020 г., 05:20:42 | 5 - 9 классы

Дан массив?

Дан массив.

Определить : индекс минимального и индекс максимального элементов.

Luxor1 17 дек. 2020 г., 01:12:22 | 10 - 11 классы

Даны 5 целых чисел?

Даны 5 целых чисел.

Посчитайте минимально возможную и максимально возможные

суммы выбрав ровно 4 числа из заданных изначально с + +.

Oklubkova 10 дек. 2020 г., 09:26:25 | 5 - 9 классы

Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел?

Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел.

Входные данные

Входная строка содержит 5 целых чисел, разделённых пробелами.

Выходные данные

В первой строке нужно вывести минимальное из введённых чисел, во второй строке – максимальное.

Примеры

входные данные

1 2 3 4 5

выходные данные

1

5

На паскале.

Вопрос Даны n чисел?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.