Определите, какими будут значения переменных p и d после выполнения операторов : p : = true ; d : = 1 ; k : = 70 ; case 2 * k div 10 of 3, 2, 7, 5 : d : = k ; 1 : ; 4, 8 : begin p : = true ; if p then?

Информатика | 10 - 11 классы

Определите, какими будут значения переменных p и d после выполнения операторов : p : = true ; d : = 1 ; k : = 70 ; case 2 * k div 10 of 3, 2, 7, 5 : d : = k ; 1 : ; 4, 8 : begin p : = true ; if p then d : = 3 end ; 9, 6 : begin if not p then d : = 2 end end ; В ответ введите сначала значение переменной p, а потом через пробел значение переменной d.

Ответить на вопрос
Ответы (1)
Umka28 16 мар. 2020 г., 08:56:02

В примере значение 2k div 10 = 14 при k = 70

поэтомуни p ни k не меняются в case и равны первоначальным

Ответ true 1.

Svimpul03 13 нояб. 2020 г., 12:47:01 | 5 - 9 классы

Найдите ошибку пожалуйста Program percentage ; uses crt ; var a, b, c, d : real ; begin writeln('Здравствуйте, вас приветствует программа для нахождения процентов в заданиях ОГЭ?

Найдите ошибку пожалуйста Program percentage ; uses crt ; var a, b, c, d : real ; begin writeln('Здравствуйте, вас приветствует программа для нахождения процентов в заданиях ОГЭ.

Искомую переменную обозначтье (0).

') ; write('Введите переменную a - ') ; read(a) ; write('Введите переменную b - ') ; read(b) ; write('Введите переменную c - ') ; read(c) ; write('Введите переменную d - ') ; read(d) ; writeln ; if a = 0 then begin a : = c * b / d ; writeln(' Ответ : ', a) ; end ; if b = 0 then begin b : = a * d / c ; writeln(' Ответ : ', b) ; end ; if c = 0 then ; begin c : = a * d / b ; writeln(' Ответ : ', c) ; end ; if d = 0 then begin d : = c * b / a ; writeln(' Ответ : ', d) ; end ; writeln('Спасибо за использование программы!

') ; end.

Йчуметнлщдшщгапм5689 22 авг. 2020 г., 00:02:41 | 5 - 9 классы

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END?

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END.

LHlera 4 окт. 2020 г., 21:50:45 | 5 - 9 классы

Помогите, пожалуйста, с заданием по Паскалю?

Помогите, пожалуйста, с заданием по Паскалю.

Каким будет значение переменной А после выполнения операторов.

А : = 3 ; If А < ; 4 then begin Inc (A, 2) ; End.

Рио34 25 дек. 2020 г., 04:12:49 | 10 - 11 классы

1. Сколько раз будут выполнены инструкции между begin и end?

1. Сколько раз будут выполнены инструкции между begin и end?

K : = 5 ;

for i : = k to k + 1 do begin … end ;

2 раза ; 5 раз ; 6 раз ; 1 раз 2.

Чему будет равно значение переменной x после выполнения операторов?

X : = 0 ;

for i : = - 5 to 5 do begin n : = i * i ; x : = x + n ; end ;

x = 0 x = 54 x = 25 x = 55.

Mashamax1 30 авг. 2020 г., 07:57:01 | 5 - 9 классы

Какое значение примет переменная y после выполнения фрагмента программы?

Какое значение примет переменная y после выполнения фрагмента программы?

Y : = 1 ; while y< ; 100 do Begin y : = y * 2 ; end ;

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

2209sergey2002 3 июн. 2020 г., 17:28:53 | 5 - 9 классы

Какое значение переменной A будет выведено на экран оператором writeIn(A) в результате выполнения следующей программы?

Какое значение переменной A будет выведено на экран оператором writeIn(A) в результате выполнения следующей программы?

Var A, k : = 0 ; while A< ; = 27 do begin if k mod 2 = 0 then A : = A + k ; k : = k + 1 ; end ; writeIn(A) ; End.

Ksusha1037 25 июн. 2020 г., 21:03:03 | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

Viktoriecka 19 июл. 2020 г., 14:57:51 | 5 - 9 классы

1. определите значение переменной а после выполнения фрагмента программы : а = 10 if a< ; 5 then a = a + 12 else a = a - 7 2?

1. определите значение переменной а после выполнения фрагмента программы : а = 10 if a< ; 5 then a = a + 12 else a = a - 7 2.

Какое число будет выведено на экран в результвте выполнения этого цикла i = 6 write(9) while i = 5 do begin write (i) i = i + 1 end 3.

Чему будет равно значение целой переменной а после выполнения этого фрагмента программы a = 2 for i = 0 to 3 do begin a = a + i end С объяснением, пожалуйста!

200512345098765 5 мар. 2020 г., 18:39:18 | 10 - 11 классы

Какое значение примет переменная F после выполнения следующих операторов : i : = 1 ; F : = 2 ; while i< ; 6 do begin i : = i + 1 ; F : = F * i end ?

Какое значение примет переменная F после выполнения следующих операторов : i : = 1 ; F : = 2 ; while i< ; 6 do begin i : = i + 1 ; F : = F * i end ;

На этой странице вы найдете ответ на вопрос Определите, какими будут значения переменных p и d после выполнения операторов : p : = true ; d : = 1 ; k : = 70 ; case 2 * k div 10 of 3, 2, 7, 5 : d : = k ; 1 : ; 4, 8 : begin p : = true ; if p then?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.