Вводя числа с клавиатуры без ограничения их количества(конец ввода число 0), найдите сумму положительны хи произведение отрицательных чисел?

Информатика | 5 - 9 классы

Вводя числа с клавиатуры без ограничения их количества(конец ввода число 0), найдите сумму положительны хи произведение отрицательных чисел.

Написать в программе E6 и E7 в ABC паскале.

Это оператор варианта.

Нужно срочно решить.

Ответить на вопрос
Ответы (1)
Lagyna2005 31 окт. 2020 г., 09:22:38

Var a, s_p, s_o : integer ;

begin s_o : = 1 ; s_p : = 0 ; repeat readln(a) ; if(a < ; 0) then s_o : = s_o * a else s_p : = s_p + a ; until(a = 0) ; writeln('Произведение отр.

: ', s_o) ; writeln('Сумма пол.

: ', s_p) ;

end.

13anna05 21 окт. 2020 г., 00:43:19 | 5 - 9 классы

Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных чисел и ищет их сумму?

Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных чисел и ищет их сумму.

Число N вводится с клавиатуры.

Lindasayfutdin1 17 окт. 2020 г., 00:46:28 | 5 - 9 классы

Программа в Паскале нужна, пожалуйста?

Программа в Паскале нужна, пожалуйста!

Даю 60 баллов!

С клавиатуры вводится последовательность из N чисел, положительных и отрицательных.

Какая сумма чисел по модулю больше, положительных или отрицательных?

Vibornova 16 мар. 2020 г., 18:39:46 | 5 - 9 классы

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры?

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры.

Димке 10 окт. 2020 г., 03:51:27 | 10 - 11 классы

Написать программу : c клавиатуры последовательно вводятся числа, пока не введут 0?

Написать программу : c клавиатуры последовательно вводятся числа, пока не введут 0.

Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.

Гордон11111 4 авг. 2020 г., 18:14:55 | 5 - 9 классы

Написать программу Пользователь вводит 5 целых чисел, программа находит сумму всех отрицательных и произведение всех положительных чисел?

Написать программу Пользователь вводит 5 целых чисел, программа находит сумму всех отрицательных и произведение всех положительных чисел.

Ksenijaksusha 20 окт. 2020 г., 22:51:03 | 10 - 11 классы

Помогите написать программу в с + + ?

Помогите написать программу в с + + .

Используя оператор if нужно написать программу , где пользователь вводит число , а программа отображает одно из трех сообщений : число является четным , положительным .

Или число является нечетным , положительным.

Или отрицательным.

Аня1210 5 июн. 2020 г., 08:29:44 | 5 - 9 классы

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом?

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом.

Вутшы 11 окт. 2020 г., 21:05:16 | 5 - 9 классы

Написать программу для Pascal?

Написать программу для Pascal.

Вычислите сумму положительных и кол - во отрицательных чисел на отрезке, концы которого вводятся с клавиатуры.

Kenzzo 24 нояб. 2020 г., 17:16:23 | 5 - 9 классы

Написать программу которая считает количество цифр в числе и их сумму?

Написать программу которая считает количество цифр в числе и их сумму.

Паскаль.

Число вводится с клавиатуры.

MSara 27 дек. 2020 г., 20:10:38 | 10 - 11 классы

Помогите написать программуС клавиатуры вводится 2 числаотпределите их сумму и произведение?

Помогите написать программу

С клавиатуры вводится 2 числа

отпределите их сумму и произведение.

Вы перешли к вопросу Вводя числа с клавиатуры без ограничения их количества(конец ввода число 0), найдите сумму положительны хи произведение отрицательных чисел?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.