Программисты Паскалев и Питонов играют в числа?

Информатика | 5 - 9 классы

Программисты Паскалев и Питонов играют в числа.

Паскалев задумывает два целых числа и сообщает Питонову их сумму и разность (из первого задуманного числа вычитается второе).

Помогите Питонову найти задуманные числа по известным значениям их суммы и разности.

Пожалуста, очень нужна программа на Паскале.

Ответить на вопрос
Ответы (1)
Katpescko 24 янв. 2020 г., 14:13:00

{1 - й вариант}

var

x, y, i, j : integer ;

begin

writeln('Введите разность задуманных чисел : ') ;

read(x) ;

writeln('Введите сумму задуманных чисел : ') ;

read(y) ;

writeln('Задуманные числа : ', (y + x) / 2, ' и ', (y - x) / 2) ;

end.

{2 - й вариант}

var

x, y, i, j : integer ;

begin

writeln('Введите разность задуманных чисел : ') ;

read(x) ;

writeln('Введите сумму задуманных чисел : ') ;

read(y) ;

for i : = 1 to 1000 do

begin for j : = 1 to 1000 do if j - i = x then if j + i = y then writeln('Задуманные числа : ', j, ' и ', i) ; end ;

end.

Kruzea280674 26 мая 2020 г., 05:53:27 | 10 - 11 классы

Даны два действительных числа x и y?

Даны два действительных числа x и y.

Вычислить их сумму, разность, произведение и частное.

Напишите программу в паскаль.

Lieto1995 25 авг. 2020 г., 16:42:04 | 5 - 9 классы

Найти сумму целого числа больше 5 в Паскале?

Найти сумму целого числа больше 5 в Паскале.

Помогите пожалуйста!

Заранее спасибо)).

Myrick 10 авг. 2020 г., 07:02:32 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найти сумму цифр числа.

(Написать программу на языке Паскаль).

Kate2005 9 мар. 2020 г., 03:13:55 | 5 - 9 классы

Напишите программу в паскале, что бы Найти сумму членов арифметической прогрессии, если известны первый член, знаменатель и число членов прогрессии?

Напишите программу в паскале, что бы Найти сумму членов арифметической прогрессии, если известны первый член, знаменатель и число членов прогрессии.

CamKo 22 мар. 2020 г., 10:05:22 | 5 - 9 классы

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа?

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа!

Зомбуля 23 дек. 2020 г., 23:05:33 | 10 - 11 классы

Паскаль?

Паскаль!

Дана сумма и разность двух чисел.

Определить эти числа.

Dimanikishin572 30 июн. 2020 г., 17:52:45 | 5 - 9 классы

Написать программу в паскале Даны два ненулевых числа?

Написать программу в паскале Даны два ненулевых числа.

Найти их сумму, разность, произведение и частное.

Milckamilana20 9 апр. 2020 г., 22:29:50 | 5 - 9 классы

Ввести три числа найти их разность и среднее арифметическое?

Ввести три числа найти их разность и среднее арифметическое.

( написать программу в паскаль).

Котубийца 1 авг. 2020 г., 08:24:58 | 5 - 9 классы

Задача по информатике?

Задача по информатике.

Найти сумму цифр данного целого числа.

Программа.

Паскаль.

Dilyara111111 25 окт. 2020 г., 16:35:34 | 10 - 11 классы

Дано трехзначное натуральное число?

Дано трехзначное натуральное число.

Найти разность между заданным числом и суммой его цифр.

Написать рограмму в паскале

ПОЖАЛУЙСТА до завтра нужно.

Вы открыли страницу вопроса Программисты Паскалев и Питонов играют в числа?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.