Найти произведение всех элементов двумерного массива, больших заданного числа?

Информатика | 10 - 11 классы

Найти произведение всех элементов двумерного массива, больших заданного числа.

Ответить на вопрос
Ответы (1)
Supercatsirot 2 июн. 2020 г., 01:32:04

Язык какой?

Паскаль

type massive = array[1.

10, 1.

10] of integer ;

var m : massive ;

pr : real ;

digit : integer ;

i, k : byte ;

flag : boolean ;

begin

for i : = 1 to 10 do

for k : = 1 to 10 do

readln(m[i, k]) ; / / заполнение массива

writeln('Введите границу : ') ;

readln(digit) ;

pr : = 1 ;

flag : = false ;

for i : = 1 to 10 do

for k : = 1 to 10 do

if m[i, k]> ; digit then

begin

pr : = pr * m[i, k] ; / / все, что больше заданного перемножаем

flag : = true ;

end ;

if flag = false then writeln('Чисел больше заданного нет.

')

else writeln('Общее произведение : ', pr : 1 : 0) ;

END.

BadiWorld1 3 февр. 2020 г., 16:37:10 | 10 - 11 классы

Найти наименьший элемент в двумерном массива?

Найти наименьший элемент в двумерном массива?

Marsovin 7 февр. 2020 г., 08:25:25 | 10 - 11 классы

Паскаль, составьте программу для двумерного массива : Найти произведение отрицательных элементов указанной строки двумерного массива размером 4 * 5 целых чисел?

Паскаль, составьте программу для двумерного массива : Найти произведение отрицательных элементов указанной строки двумерного массива размером 4 * 5 целых чисел.

Alina2003435 13 янв. 2020 г., 22:04:39 | 5 - 9 классы

Как в двумерном массиве найти среднее арифметическое однозначных элементов?

Как в двумерном массиве найти среднее арифметическое однозначных элементов.

Lyuba1606 30 апр. 2020 г., 15:12:53 | 10 - 11 классы

Дан двумерный массив размерности 10х10?

Дан двумерный массив размерности 10х10.

Заполнить его случайными числами на отрезке [ - 25, 25].

В каждой строке массива найти количество элементов, больших заданного числа H.

Результат получить в виде одномерного массива.

Вывести исходный массив и полученный результат на печать.

Kateprincess 17 февр. 2020 г., 13:34:20 | 5 - 9 классы

1. Нахождение наибольшего элемента главной диагонали?

1. Нахождение наибольшего элемента главной диагонали.

(Паскаль, двумерные массивы ) 2.

Нахождение наименьших элементов в столбцах массива.

(Паскаль, двумерные массивы ).

Ciklomen151 2 июл. 2020 г., 22:39:18 | 10 - 11 классы

Заполнить двумерный массив N * N числами с клавиатуры и найти сумму элементов массива нечётных столбцов?

Заполнить двумерный массив N * N числами с клавиатуры и найти сумму элементов массива нечётных столбцов.

TATATATAS 1 июл. 2020 г., 05:45:42 | 10 - 11 классы

Заданы два двумерных целочислительных массива ?

Заданы два двумерных целочислительных массива .

Найти максимальный элемент в первом массиве и если он положительный чётный уменьшить его величину все положительные четные элементы второго массива .

Таблица программа блок схемах.

Помогите пожалуйста!

Linochk552 1 окт. 2020 г., 20:41:06 | 5 - 9 классы

Найти наибольшее значение элементов двумерного массива паскаль?

Найти наибольшее значение элементов двумерного массива паскаль.

Annst5inabald 14 дек. 2020 г., 23:08:46 | 10 - 11 классы

Помогите с информатикой 60 баллов?

Помогите с информатикой 60 баллов.

Двумерный массив.

Паскаль.

1) Дан двумерный массив размерностью 5 на 7.

Найти максимальный элемент массива.

2) Дан двумерный массив размерностью 5 на 7.

Найти произведение четных элементов.

2002ru 19 сент. 2020 г., 12:17:56 | 10 - 11 классы

В двумерном массиве 10х15 найти разность между максимальным и минимальным элементами массива, заданными случайным образом на интервале [ - 50 ; 50])))) Пожалуйста?

В двумерном массиве 10х15 найти разность между максимальным и минимальным элементами массива, заданными случайным образом на интервале [ - 50 ; 50])))) Пожалуйста!

))).

На этой странице сайта размещен вопрос Найти произведение всех элементов двумерного массива, больших заданного числа? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.