Помогите пожалуйста создать программу на паскале?

Информатика | 10 - 11 классы

Помогите пожалуйста создать программу на паскале.

Надо вывести на экран матрицу 5 на 5 с числами в диапазоне от - 8 до 15.

Заменить максимальный элемент каждой строки на противоположный, на минимальный.

Ответить на вопрос
Ответы (1)
Pulikboets 24 дек. 2020 г., 03:48:10

Const n = 5 ;

var a : array[1.

N, 1.

N] of integer ; i, j, m, nmax, nmin, jmax, jmin : integer ;

begin Randomize ; writeln('Исходный массив') ; for i : = 1 to n do begin nmax : = - 100 ; nmin : = 100 ; for j : = 1 to n do begin a[i, j] : = Random(24) - 8 ; if nmax < ; a[i, j] then begin nmax : = a[i, j] ; jmax : = j end ; if nmin > ; a[i, j] then begin nmin : = a[i, j] ; jmin : = j end ; write(a[i, j] : 4) end ; writeln ; a[i, jmax] : = nmin ; a[i, jmin] : = nmax end ; writeln(#13#10, 'Результирующий массив') ; for i : = 1 to n do begin for j : = 1 to n do write(a[i, j] : 4) ; writeln end

end.

Тестовое решение :

Исходный массив - 4 8 3 7 5 - 7 - 7 1 8 0 14 0 0 1 - 1 14 7 - 5 - 1 14 7 6 1 - 6 14

Результирующий массив 8 - 4 3 7 5 8 - 7 1 - 7 0 - 1 0 0 1 14 - 5 7 14 - 1 14 7 6 1 14 - 6.

Menthe 20 авг. 2020 г., 15:28:38 | 5 - 9 классы

Помогите, пожайлуста, составить программу на паскале?

Помогите, пожайлуста, составить программу на паскале.

Вывести на экран все простые числа в диапазоне от 2 до N.

Adilkami 27 февр. 2020 г., 07:19:50 | 10 - 11 классы

Вывести на экран элементы, расположеные перед первым минимальным ?

Вывести на экран элементы, расположеные перед первым минимальным .

Массив, паскаль.

Vikik123 2 апр. 2020 г., 08:19:27 | 10 - 11 классы

Напишите программу поиска минимального и максимального элементов матрицы?

Напишите программу поиска минимального и максимального элементов матрицы.

Программа должна менять максимальный и минимальный элементы между собой и выводить на экран исходную и преобразованную матрицы (Турбо Паскаль).

Alsunya91 17 июн. 2020 г., 06:45:17 | 10 - 11 классы

Помогите написать программу в pascal'e?

Помогите написать программу в pascal'e.

Если матрица квадратная, то поменять местами минимальный и максимальный элементы побочной диагонали.

В противном случае - заменить элементы четных строк нулями.

Kiborg37 21 апр. 2020 г., 07:15:44 | 10 - 11 классы

Заполнить массив случайными числами (положительными и отрицательными) из произвольного диапазона?

Заполнить массив случайными числами (положительными и отрицательными) из произвольного диапазона.

Вывести созданный массив на экран, расположив элементы в одну строку через пробелы.

Посчитать общее количество элементов, кратных 3 и нечетных элементов и вывести на экран.

GRIBOBAS 13 янв. 2020 г., 13:37:22 | 10 - 11 классы

ПРОГРАММА ПАСКАЛЬ?

ПРОГРАММА ПАСКАЛЬ!

УМОЛЯЮ ПОМОГИТЕ, ВСЕ ОЧЕНЬ ПЛОХО!

Напишите программу, которая заполняет квадратную матрицу случайными числами в интервале от 10 до 90 и находит максимальный и минимальный элементы в матрице.

9043645754 13 мар. 2020 г., 13:26:30 | 10 - 11 классы

Помогите решить задачу на Паскаль : "Напишите программу вычисления суммы минимальных элементов строк заданной матрицы?

Помогите решить задачу на Паскаль : "Напишите программу вычисления суммы минимальных элементов строк заданной матрицы.

".

Angelina2016a 26 авг. 2020 г., 04:14:27 | 10 - 11 классы

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран?

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран.

На паскале.

СветЛана9910 3 мая 2020 г., 09:11:59 | 10 - 11 классы

Заполнить массив случайными числами (положительными и отрицательными) из произвольного диапазона?

Заполнить массив случайными числами (положительными и отрицательными) из произвольного диапазона.

Вывести созданный массив на экран, расположив элементы в одну строку через пробелы.

Заменить все отрицательные элементы квадратом соответствующего индекса.

Vasyapupkin201 2 июл. 2020 г., 19:43:53 | 5 - 9 классы

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран?

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран.

Язык Паскаль.

На этой странице сайта размещен вопрос Помогите пожалуйста создать программу на паскале? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.