Помогите решить в паскале1) Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 6?

Информатика | 10 - 11 классы

Помогите решить в паскале

1) Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 6.

2) Введено 3 - значное число.

Вывести число в зеркальном отображении.

3)Введенное 4 - значное число изменить так, чтобы 1 - 3 и 2 - 4 цифры поменялись местами.

Ответить на вопрос
Ответы (1)
Tan6 29 апр. 2020 г., 04:29:37

Program task1 ;

var a : integer ;

begin randomize ; a : = 0 ; while (a < ; > ; 5) and (a < ; > ; 6) do a : = random(7) ; writeln(a) ;

end.

Program task2 ;

var Digit, i : integer ; DigitStr : string ;

begin readln(Digit) ; str(Digit, DigitStr) ; for i : = length(DigitStr) downto 1 do write(DigitStr[i]) ;

end.

Program task3 ;

var Digit : integer ; NewDigit, DigitStr : string ;

begin readln(Digit) ; str(Digit, DigitStr) ; NewDigit : = DigitStr[3] + DigitStr[4] + DigitStr[1] + DigitStr[2] ; writeln(NewDigit) ;

end.

KateykinaKatya 7 февр. 2020 г., 01:25:44 | 5 - 9 классы

Ввести 3 - х значное число , вывести сумму его цифр ( паскаль)?

Ввести 3 - х значное число , вывести сумму его цифр ( паскаль).

Rlazurnaya 20 нояб. 2020 г., 04:44:18 | 5 - 9 классы

I В паскале с помощью генератора случайных чисел получить двузначное число и1) найти и вывести сумму его цифр2) сформировать число, в котором поменяются разряды (допустим будет число 13, нужно сделать?

I В паскале с помощью генератора случайных чисел получить двузначное число и

1) найти и вывести сумму его цифр

2) сформировать число, в котором поменяются разряды (допустим будет число 13, нужно сделать, что бы было 31 и т.

П. )

II В паскале с помощью генератора случайных чисел получить трехзначное число и определить, является ли оно полимером (например 121 - является, 123 - нет).

Dashamahanyok 24 мар. 2020 г., 20:02:32 | 10 - 11 классы

Дано 4 значное число, поменять местами первую и последнюю цифру?

Дано 4 значное число, поменять местами первую и последнюю цифру.

Программирование, составить в Паскале.

Dilnaz2013 17 мая 2020 г., 08:55:24 | 10 - 11 классы

Написать в Турбо Паскале программу : Задано 3 - х значное число X?

Написать в Турбо Паскале программу : Задано 3 - х значное число X.

Найти разность между этим числом и числом, записанным теми же цифрами, но в другом порядке.

(Видимо в обратном порядке?

).

Лерик22 22 апр. 2020 г., 08:40:45 | 5 - 9 классы

Составить программу заполнения массива из 7 элементов числами от 1 до 30 с помощью генератора случайных чисел и вывести значения его элементов в строку через запятую?

Составить программу заполнения массива из 7 элементов числами от 1 до 30 с помощью генератора случайных чисел и вывести значения его элементов в строку через запятую.

KatyaMirono02 18 апр. 2020 г., 13:22:54 | 5 - 9 классы

Напишите программу на паскаль Заполните массив случайными числами в интервале [0, 5]?

Напишите программу на паскаль Заполните массив случайными числами в интервале [0, 5].

Введите число X и найдите все значения равные x.

Perehoghina01 16 июн. 2020 г., 00:48:43 | 10 - 11 классы

Получить случайное трехзначное число и вывести через запятую все его отдельные цифры?

Получить случайное трехзначное число и вывести через запятую все его отдельные цифры.

Сделать для программы Паскаль!

Без mod и div.

Аленький 16 сент. 2020 г., 03:07:40 | 10 - 11 классы

Помогите, пожалуйста, написать программы на Паскале?

Помогите, пожалуйста, написать программы на Паскале.

Задачи : 1.

Сгенерировать случайное число, вывести на экран это число, а также сумму и произведение его цифр.

2. Вводятся целые числа до первого числа, которое меньше двух.

Определить, сколько простых чисел было введено.

Seda27 1 окт. 2020 г., 03:01:02 | 5 - 9 классы

3 значное число нужно сложить числа в этом числе паскаль?

3 значное число нужно сложить числа в этом числе паскаль.

Настюха16478637 31 окт. 2020 г., 05:25:32 | 5 - 9 классы

Запишите на языке Паскаль программу, которая для двухзначного случайного числа определяет произведение его цифр?

Запишите на языке Паскаль программу, которая для двухзначного случайного числа определяет произведение его цифр.

На странице вопроса Помогите решить в паскале1) Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 6? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.