Напишите класс который принимает с клавиатуры целое число и выводит на экран его квадрат но только в случае, если введенное число отрицательно?

Информатика | 10 - 11 классы

Напишите класс который принимает с клавиатуры целое число и выводит на экран его квадрат но только в случае, если введенное число отрицательно.

В противном случае на экран выводится сообщение ошибка.

Ответить на вопрос
Ответы (1)
Alinadimitrenko 27 мар. 2020 г., 08:49:34

Var a : integer ;

begin

readln(a) ;

if (a< ; 0) then a : = sqr(a) ;

writeln(a) else writeln('Error') ;

end.

Vakrtahdudjdfk 6 мая 2020 г., 14:25:55 | 5 - 9 классы

Составьте программу, которая определяет, является ли введенное целое число нечетным, и выводит на экран соответствующее сообщение : "Да" либо "Нет"?

Составьте программу, которая определяет, является ли введенное целое число нечетным, и выводит на экран соответствующее сообщение : "Да" либо "Нет".

Регина20052005 9 мая 2020 г., 06:07:29 | 10 - 11 классы

Объясните как делать : составить программу которая сравнивает два числа введенные с клавиатуры и выводит на экран большее ?

Объясните как делать : составить программу которая сравнивает два числа введенные с клавиатуры и выводит на экран большее .

Ксения550 19 мар. 2020 г., 23:43:22 | 5 - 9 классы

Составьте программу , которая возводит в квадрат введенное целое число, если оно отрицательное , и выводит на экран результат?

Составьте программу , которая возводит в квадрат введенное целое число, если оно отрицательное , и выводит на экран результат.

Olko4096 1 окт. 2020 г., 05:19:29 | 5 - 9 классы

Составьте программу, которая выводит на экран число сотен в заданном числе, если оно трёхзначное, а в противном случае сообщает : "число не трёхзначное" ?

Составьте программу, которая выводит на экран число сотен в заданном числе, если оно трёхзначное, а в противном случае сообщает : "число не трёхзначное" .

WAVEWAVE 24 июл. 2020 г., 07:17:31 | 5 - 9 классы

Написать программу которая в ответ на введенное с клавиатуры число выводит на экран сообщение о том положительное это число или отрицательное ( использовать оперытор if?

Написать программу которая в ответ на введенное с клавиатуры число выводит на экран сообщение о том положительное это число или отрицательное ( использовать оперытор if.

Then.

Else).

Kutkinal 5 окт. 2020 г., 05:47:11 | 10 - 11 классы

Даю 20 балов 2?

Даю 20 балов 2.

Напишите класс, который принимает с клавиатуры 12 целых чисел и выводит на экран, сколько из них были больше, чем первое число.

Temzen 17 сент. 2020 г., 01:29:43 | 5 - 9 классы

Срставьте программу, которая возводит в квадрат введенное целое число, если оно отрицательное, и выводит на экран результат?

Срставьте программу, которая возводит в квадрат введенное целое число, если оно отрицательное, и выводит на экран результат.

Kalerija 31 мая 2020 г., 10:44:10 | 1 - 4 классы

Дано целое число?

Дано целое число.

Напишите программу, которая выводит на экран последнюю букву данного числа, потом вводит её в квадрат и выводит на экран монитора результат.

Please131 10 мая 2020 г., 01:59:56 | 5 - 9 классы

Составьте программу, которая определяет, является ли введенное целое число нечетным, и выводит на экран соответствующее сообщение : 《Да》 либо 《Нет》?

Составьте программу, которая определяет, является ли введенное целое число нечетным, и выводит на экран соответствующее сообщение : 《Да》 либо 《Нет》.

Marinaivanova13 15 дек. 2020 г., 19:07:28 | 5 - 9 классы

Дано целое число ?

Дано целое число .

Напишите прогу .

, которя выводит на экран последнюю цифру данного числа , затем возводит ее в квадрат и выводит на экран монитора результат.

На этой странице находится ответ на вопрос Напишите класс который принимает с клавиатуры целое число и выводит на экран его квадрат но только в случае, если введенное число отрицательно?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.