Автоморфные числа?

Информатика | 5 - 9 классы

Автоморфные числа.

Натуральное число называется автоморфным, если оно равно последним цифрам его квадрата.

Например : 25 ^ 2 = 625.

Напишите программу, которая вводит натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.

Ответить на вопрос
Ответы (1)
DirksenM13 13 июн. 2020 г., 17:37:17

Var n, i, m : longint ; s1, s2 : string ; l1 : integer ;

begin Write('Введите натуральное число : ') ; Readln(n) ; Writeln('Автоморфные числа : ') ; for i : = 1 to n do begin m : = sqr(i) ; Str(i, s1) ; l1 : = Length(s1) ; Str(m, s2) ; if s1 = Copy(s2, Length(s2) - l1 + 1, l1) then Writeln(i) end

end.

Тестовое решение :

Введите натуральное число : 10000

Автоморфные числа :

1

5

6

25

76

376

625

9376.

Гулден99 14 окт. 2020 г., 02:04:08 | 10 - 11 классы

1 Определить, является ли число автоморфным, то есть квадрат этого числа заканчивается этим же числом, например, числа 6 и 25, т?

1 Определить, является ли число автоморфным, то есть квадрат этого числа заканчивается этим же числом, например, числа 6 и 25, т.

К. их квадратами являются числа 36 и 625.

2 Составьте программу, проверяющую, является ли число палиндромом (например, число 12421 - палиндром).

3 Среди чисел из интервала от А до В найти все простые.

Elizavetashishe 6 апр. 2020 г., 08:15:42 | 5 - 9 классы

Напишите программу, которая вводит натуральное число N и выводит на экран N псевдослучайных чисел?

Напишите программу, которая вводит натуральное число N и выводит на экран N псевдослучайных чисел.

Saveleva 31 янв. 2020 г., 21:01:55 | 10 - 11 классы

Помогите решить две задачи срочно надо, завтра урок ?

Помогите решить две задачи срочно надо, завтра урок !

1)Напишите программу, которая вводит четырёхзначное натуральное число и переставляет его первую и последнюю цифры, например, из числа 1234 должно получится число 4231.

2)Напишите программу, которая вводит четырёхзначное натуральное число и "вырезает" из него вторую цифру с начала, например, из числа 1234 должно получиться число 134.

Kalerija 31 мая 2020 г., 10:44:10 | 1 - 4 классы

Дано целое число?

Дано целое число.

Напишите программу, которая выводит на экран последнюю букву данного числа, потом вводит её в квадрат и выводит на экран монитора результат.

XDante 23 апр. 2020 г., 21:06:58 | 10 - 11 классы

Напишите программу, которая вводит натуральные числа а иб и выводит сумму квадратов натуральных чисел в диапазоне от а до б?

Напишите программу, которая вводит натуральные числа а иб и выводит сумму квадратов натуральных чисел в диапазоне от а до б.

Pashqa777 17 февр. 2020 г., 07:52:00 | 5 - 9 классы

1) напишите программу которое вводит натуральное число"n" и находит сумму всех натуральных чисел от 1 до n (цикл пока)?

1) напишите программу которое вводит натуральное число"n" и находит сумму всех натуральных чисел от 1 до n (цикл пока).

2)напишите программу которое вводит натуральное число "n" и выводит первые "n" четных натуральных чисел.

3)напишите программу которая вводит натуральные числа "a и b" и выводит квадраты натуральных чисел в диапазоне от "a до b".

Помогите пожалуйста , а то не понимаю))).

Ulyanaaleksandr 27 мар. 2020 г., 20:17:06 | 10 - 11 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

Уровень A.

Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата.

Например, 252 = 625.

Напишите программу, которая получает натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.

Пример : Введите N : 1000 1 * 1 = 1 5 * 5 = 25 6 * 6 = 36 25 * 25 = 625 76 * 76 = 5776.

AlisCooper 28 нояб. 2020 г., 10:49:01 | 10 - 11 классы

Дано натуральное число N, составить программу, котоая выводит на экран все натуральные числа, квадрат которых не больше чем N?

Дано натуральное число N, составить программу, котоая выводит на экран все натуральные числа, квадрат которых не больше чем N.

Slava026 3 дек. 2020 г., 17:25:24 | 10 - 11 классы

Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата?

Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата.

Например, 25² = 625.

Напишите программу, которая получает натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.

Jamilya456 27 дек. 2020 г., 04:26:34 | 10 - 11 классы

Натуральное число называется автоморфным , если оно равно последним цифрам своего квадрата?

Натуральное число называется автоморфным , если оно равно последним цифрам своего квадрата.

Например, 25 ^ 2 = 625 .

Напишите программу, которая находит все автоморфные числа на отрезке [ a , b ] .

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все автоморфные числа на отрезке [ a , b ] , разделив их пробелами.

Если таких чисел нет, программа должна вывести число - 1.

Примеры

входные данные

20 100

выходные данные

25 76

На паскале, через циклы, пожалуйста.

На странице вопроса Автоморфные числа? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.