Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата?

Информатика | 10 - 11 классы

Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата.

Например, 25² = 625.

Напишите программу, которая получает натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.

Ответить на вопрос
Ответы (1)
Natashakasha1 3 дек. 2020 г., 17:25:26

Program n1 ;

function au(n : longint) : boolean ;

var m : longint ;

f : boolean ;

begin

m : = n * n ;

f : = true ;

while (n>0) and f do

begin

if (n mod 10)(m mod 10) then f : = false

else begin

n : = n div 10 ;

m : = m div 10 ;

end ;

end ;

au : = f ;

end ;

var i, n : longint ;

begin

readln(n) ;

for i : = 1 to n do if au(i) then write(i, ' ') ;

end.

Krema76 13 июн. 2020 г., 17:37:11 | 5 - 9 классы

Автоморфные числа?

Автоморфные числа.

Натуральное число называется автоморфным, если оно равно последним цифрам его квадрата.

Например : 25 ^ 2 = 625.

Напишите программу, которая вводит натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.

Elizavetashishe 6 апр. 2020 г., 08:15:42 | 5 - 9 классы

Напишите программу, которая вводит натуральное число N и выводит на экран N псевдослучайных чисел?

Напишите программу, которая вводит натуральное число N и выводит на экран N псевдослучайных чисел.

Kalerija 31 мая 2020 г., 10:44:10 | 1 - 4 классы

Дано целое число?

Дано целое число.

Напишите программу, которая выводит на экран последнюю букву данного числа, потом вводит её в квадрат и выводит на экран монитора результат.

XDante 23 апр. 2020 г., 21:06:58 | 10 - 11 классы

Напишите программу, которая вводит натуральные числа а иб и выводит сумму квадратов натуральных чисел в диапазоне от а до б?

Напишите программу, которая вводит натуральные числа а иб и выводит сумму квадратов натуральных чисел в диапазоне от а до б.

Edemidenko5 2 мар. 2020 г., 00:17:29 | 5 - 9 классы

Напишите программу, которая получает два целых числа A и B и выводит квадраты всех натуральных чисел в интервале от A до B?

Напишите программу, которая получает два целых числа A и B и выводит квадраты всех натуральных чисел в интервале от A до B.

Ulyanaaleksandr 27 мар. 2020 г., 20:17:06 | 10 - 11 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

Уровень A.

Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата.

Например, 252 = 625.

Напишите программу, которая получает натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.

Пример : Введите N : 1000 1 * 1 = 1 5 * 5 = 25 6 * 6 = 36 25 * 25 = 625 76 * 76 = 5776.

AlisCooper 28 нояб. 2020 г., 10:49:01 | 10 - 11 классы

Дано натуральное число N, составить программу, котоая выводит на экран все натуральные числа, квадрат которых не больше чем N?

Дано натуральное число N, составить программу, котоая выводит на экран все натуральные числа, квадрат которых не больше чем N.

Blue13fox 12 окт. 2020 г., 18:02:49 | 10 - 11 классы

Дано натуральное число N?

Дано натуральное число N.

Составьте программу, которая выводит все числа от 1 по N, у которых последняя цифра кратная 3.

Lidokain 19 окт. 2020 г., 04:14:14 | 10 - 11 классы

Дано натуральное число N?

Дано натуральное число N.

Составьте программу, которая выводит все числа от 1 по N, у которых последняя цифра кратная 3.

Jamilya456 27 дек. 2020 г., 04:26:34 | 10 - 11 классы

Натуральное число называется автоморфным , если оно равно последним цифрам своего квадрата?

Натуральное число называется автоморфным , если оно равно последним цифрам своего квадрата.

Например, 25 ^ 2 = 625 .

Напишите программу, которая находит все автоморфные числа на отрезке [ a , b ] .

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все автоморфные числа на отрезке [ a , b ] , разделив их пробелами.

Если таких чисел нет, программа должна вывести число - 1.

Примеры

входные данные

20 100

выходные данные

25 76

На паскале, через циклы, пожалуйста.

Вы находитесь на странице вопроса Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.