Решение задач с использованием операторов цикла?

Информатика | 10 - 11 классы

Решение задач с использованием операторов цикла.

Начав тренировки, лыжник в первый день пробежал 10 км.

Каждый следующий день он увеличивал пробeг на 10% от пробега предыдущего дня.

Определить на какой день он пробежит больше 20 км ;

Ответить на вопрос
Ответы (2)
Кошечкамяумяумяу 12 мар. 2024 г., 02:11:06

Ответ : var s : real ; k : integer ; / / описание переменных

begin

s : = 10 ; / / пробег в 1 - й день

k : = 1 ;

while s< ; 20 do / / пока пробег < ; 20 км begin k : = k + 1 ; / / добавляем один день s : = s * 1.

1 ; / / увеличиваем пробег на 10% end ;

writeln('s = ', s, ' k = ', k) ; / / выводим на экран результаты

end.

Результат :

s = 21.

4358881 k = 9.

Travasave 12 мар. 2024 г., 02:11:09

#include < ; iostream> ;

using namespace std ;

int main(){

int cnt = 2 ;

double k = 10 ;

while(k < ; = 20){

k * = 1.

1 ;

cnt + + ;

}

cout < ; < ; cnt ;

}.

89235609398 24 февр. 2024 г., 07:41:34 | 5 - 9 классы

ПОМОГИТЕ?

ПОМОГИТЕ!

1) Определите , сколько раз будет выполняться тело следующего оператора цикла :

k : = 0 ;

for i : = 1 to k + 4 do

k : = k + 2 ;

2) Напишите программу вычисления суммы натуральных чисел : S = 1 + 2 + 3 + .

+ N. .

Павел310 31 янв. 2024 г., 02:08:00 | студенческий

СРОЧНО?

СРОЧНО!

ЗАДАЧА В ЭКСЕЛЕ!

Годовой доход семьи из четырех человек составляет в среднем 150000 денежных единиц.

Основные затраты состоят из : коммунальные услуги — 13700 (ден.

Ед. ) ; плата за телефон — 9600 (ден.

Ед. ) ; питание — 64000 (ден.

Ед. ) ; плата за детские учреждения — 5800 (ден.

Ед. ).

Остальная сумма тратится, исходя из нужд и потребностей семьи.

Требуется : 1.

Представить данные в виде таблицы ; 2.

Рассчитать : A.

Среднемесячный доход семьи ; B.

Сумму основных затрат ; C.

Оставшуюся сумму ; D.

Долю каждой строки расходов (в процентах) от общей суммы.

Рассчитать все те же показатели в долларах, для докризисной ситуации, считая курс равным 50 р.

За доллар, и в послекризисный период, исходя из того, что курс можно изменить несколько раз в течение дня, а результаты расчета должны выполниться автоматически.

Aaa32 14 апр. 2024 г., 06:18:51 | 5 - 9 классы

В каком цикле, тело цикла будет выполняться до тех пор пока условие будет истинным Верного ответа нет Цикл с предусловием Цикл с параметром Цикл с постусловием Цикл с ветвлением ​?

В каком цикле, тело цикла будет выполняться до тех пор пока условие будет истинным Верного ответа нет Цикл с предусловием Цикл с параметром Цикл с постусловием Цикл с ветвлением ​.

A1EX11 4 янв. 2024 г., 09:34:15 | 5 - 9 классы

За день машина проезжает n километров?

За день машина проезжает n километров.

Сколько дней нужно, что проехать маршрут длиной m километров.

Входные данные : программа получает на вход n и m(целые, положительные).

Выходные данные : выведите ответ на задачу.

ОБЯЗАТЕЛЬНО НА С + +.

Qwer3fwrfwgwr 7 мар. 2024 г., 00:59:43 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

ДАЮ 60 БАЛЛОВ

намалюйте на комп'ютері бажаний подарунок на день святого Миколая своїй родині, чи онкохворій дитині.

Mihailova99Eleonora 28 мар. 2024 г., 12:09:12 | студенческий

В какой конструкции цикла не требуется использование составного оператора (begin…end ; ) при написании программы на языке Паскаль?

В какой конструкции цикла не требуется использование составного оператора (begin…end ; ) при написании программы на языке Паскаль?

Repeat until

for to do

for downto do

while.

Dedalcsoxz11g 31 мар. 2024 г., 03:01:46 | 1 - 4 классы

Начав тренировки, лыжник в первый день пробежал 10 км?

Начав тренировки, лыжник в первый день пробежал 10 км.

Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня.

Определить какой суммарный путь он пробежал за первые 7 дней тренировок.

Написать программу в Pascal.

Elenadeg2010 21 янв. 2024 г., 00:46:57 | студенческий

1. Які види циклів підтримуються в мові Python, і як вони відрізняються?

1. Які види циклів підтримуються в мові Python, і як вони відрізняються?

2. Як можна вийти з циклу раніше за допомогою оператора break у мові Python?

3. Як можна пропустити один або декілька кроків у циклі за допомогою оператора continue у мові Python?

4. Як можна використовувати цикли для ітерації по рядках або спискам даних в мові Python?

5. Як можна використовувати вкладені цикли у мові Python для обробки складніших структур даних, таких як двовимірні масиви?

Monstaa 14 февр. 2024 г., 22:29:22 | 5 - 9 классы

99 баллов, Напишите пожалуйста программу в Паскаль abc ,Медведь, впадая в зимнюю спячку, весил 200 кг?

99 баллов, Напишите пожалуйста программу в Паскаль abc ,

Медведь, впадая в зимнюю спячку, весил 200 кг.

Каждый день во время сна он худеет на 1700г.

Через сколько дней медведь проснется, если условием для выхода из зимней спячки является снижение веса на 50% от первоначального?

Использовать цикл While.

Dadialim 31 мар. 2024 г., 06:43:32 | 10 - 11 классы

Даю 35 баллов ?

Даю 35 баллов .

Помогите решить задачи с циклом.

На этой странице сайта вы найдете ответы на вопрос Решение задач с использованием операторов цикла?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.