Напишите функцию, которая вычисляет наименьший общий делитель двух чисел (НОД)(в Pascal)?

Информатика | студенческий

Напишите функцию, которая вычисляет наименьший общий делитель двух чисел (НОД)

(в Pascal).

Ответить на вопрос
Ответы (1)
12ТаПтЫшКа 12 апр. 2024 г., 18:27:35

Ответ :

var   ;   ; k, l, n : integer ;

function nod (var a, b : integer) : integer ;   ;   ; var c : integer ;   ;   ; begin   ;   ;   ;   ; repeat   ;   ;   ;   ;   ;   ; if a > ; b then   ;   ;   ;   ;   ;   ;   ;   ; a : = a mod b   ;   ;   ;   ;   ;   ; else   ;   ;   ;   ;   ;   ;   ;   ; b : = b mod a ;   ;   ;   ;   ; until (a = 0) or (b = 0) ;   ;   ;   ;   ; nod : = a + b ;   ;   ; end ;

begin   ;   ; writeln ('Введите два числа : ') ;   ;   ; readln (k, l) ;   ;   ; n : = nod (k, l) ;   ;   ; writeln ('НОД = ', n) ;

readln

end.

Объяснение :

Omertys 17 мар. 2024 г., 03:27:25 | студенческий

Пожалуйста помогитеНапишите программу, которая запрашивает двацелых числа x и y, после чего вычисляет и выводитзначение x в степени y на пайтоне?

Пожалуйста помогите

Напишите программу, которая запрашивает два

целых числа x и y, после чего вычисляет и выводит

значение x в степени y на пайтоне.

Dagirovauma 8 апр. 2024 г., 20:43:38 | 5 - 9 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные

Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел

ЯЗЫК - PASCAL

35 баллов.

Saduakasov04 18 янв. 2024 г., 23:01:23 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

Напишите программу которая получает с клавиатуры 2 целых числа и вычисляет их произведение, используя только операции сложения.

Пробить через repeat(постусловие) pascal abc очень прошу.

IZDom 17 февр. 2024 г., 17:20:03 | 5 - 9 классы

Python 3?

Python 3.

Написать код с помощью функции, которая принимает неопределённое количество аргументов - чисел.

Если количество чисел нечётное, то функция возвращает их сумму, если чётное - их произведение.

Mamedovaseda17 12 янв. 2024 г., 10:33:07 | 5 - 9 классы

Найти наибольший делитель натурального чисел 12 18?

Найти наибольший делитель натурального чисел 12 18.

Akchurinalina 16 февр. 2024 г., 13:17:34 | 5 - 9 классы

Напишите программу, которая вычисляет площадь и периметр квадрата со стороной равной 3 см (ПАСКАЛЬ) ЧТО БЫ БЫЛО ПРАВИЛЬНО?

Напишите программу, которая вычисляет площадь и периметр квадрата со стороной равной 3 см (ПАСКАЛЬ) ЧТО БЫ БЫЛО ПРАВИЛЬНО!

Как надо!

Maha1 29 янв. 2024 г., 03:35:51 | 5 - 9 классы

Составить программу, которая считывает 6 чисел, и выводит сумму неположительных чисел?

Составить программу, которая считывает 6 чисел, и выводит сумму неположительных чисел.

Pascal.

Viharm 31 мар. 2024 г., 00:25:36 | студенческий

Даны конкретные x, у числа?

Даны конкретные x, у числа.

Составь программу, вычисляющую значение функции, где fn = x² + |x + y| ; помогите пожалуйста .

Грелюшка 8 мар. 2024 г., 16:05:30 | 5 - 9 классы

Составьте программу, которая вычисляет произведение чисел от 5 до n?

Составьте программу, которая вычисляет произведение чисел от 5 до n.

N вводится с клавиатуры.

2)Даны натуральные числа от 10 до 500.

Напечатать те из них, которые делятся на 3, но не делятся на 5.

3)Напечатать те из двузначных чисел которые делятся на 4, но не делятся на 6.

Scorpiola2007 8 апр. 2024 г., 10:48:10 | 1 - 4 классы

Написать программу, которая решает уравнение ax + b = 0 относительно x для любых чисел a и b, введёных с клавиатуры?

Написать программу, которая решает уравнение ax + b = 0 относительно x для любых чисел a и b, введёных с клавиатуры.

Язык Pascal ABC.

Вы открыли страницу вопроса Напишите функцию, которая вычисляет наименьший общий делитель двух чисел (НОД)(в Pascal)?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся студенческий. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.