3. Найти среднее арифметическое элементов массива из 10 элементов и записать его на место максимального элемента?

Информатика | 10 - 11 классы

3. Найти среднее арифметическое элементов массива из 10 элементов и записать его на место максимального элемента.

(Паскаль).

Ответить на вопрос
Ответы (2)
Diesdies 4 апр. 2024 г., 23:50:18

Begin   ; var n : = 10 ;   ; var s : = 0 ;   ; var arr : = ArrRandomReal(n, 0, 100) ;   ; arr.

Println ;   ; Writeln(arr.

Sum / n) ;   ; arr[arr.

IndexMax] : = arr.

Sum / n ;   ; arr.

Println ;

End.

Vvvvvvv2017 4 апр. 2024 г., 23:50:25

Begin   ; var a : = ArrRandomReal(10, - 99, 99) ;   ; a.

Println ;   ; a[a.

IndexMax] : = a.

Average ;   ; a.

Println ;

end.

На PascalABC.

NET.

Саша1322 25 мар. 2024 г., 22:31:52 | 10 - 11 классы

Составить программу на Паскале, которая в двумерном массиве определяет максимальный элемент в каждой строке и записывает его в одномерный массив?

Составить программу на Паскале, которая в двумерном массиве определяет максимальный элемент в каждой строке и записывает его в одномерный массив.

Для определения максимального элемента в строке использовать function , а для ввода и вывода массивов - procedure.

Dagirovauma 8 апр. 2024 г., 20:43:38 | 5 - 9 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные

Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел

ЯЗЫК - PASCAL

35 баллов.

Анжелика268 18 февр. 2024 г., 07:10:49 | 5 - 9 классы

Дан одномерный массив B из 20 целых чисел(числа вводятся по формуле (i + 2 * (i - 1)), вывестина экран массив в строку через пробел, найти ивывести максимальный элемент массива?

Дан одномерный массив B из 20 целых чисел

(числа вводятся по формуле (i + 2 * (i - 1)), вывести

на экран массив в строку через пробел, найти и

вывести максимальный элемент массива.

Kuzminama2017 13 мар. 2024 г., 20:10:10 | 10 - 11 классы

СРОЧНО?

СРОЧНО!

Какой элемент массива будет найден в результате выполнения программного кода?

Максимальный элемент массива

среднее значение элементов массива

минимальный элемент массива.

Annatitova12345 3 апр. 2024 г., 09:43:12 | 5 - 9 классы

Дан массив из N элементов?

Дан массив из N элементов.

Найти и вывести элементы этого массива, принадлежащие диапазону от А до В (А и В ввести с клавиатуры).

Язык программирования pascal.

F39821 16 янв. 2024 г., 00:26:34 | 5 - 9 классы

ДАН ЦЕЛОЧИСЛЕННЫЙ МАССИВ ИЗ 30 ЭЛЕМЕНТОВ ?

ДАН ЦЕЛОЧИСЛЕННЫЙ МАССИВ ИЗ 30 ЭЛЕМЕНТОВ .

ЭЛЕМЕНТЫ МАССИВА МОГУТ ПРИНИМАТЬ ЗНАЧЕНИЯ ОТ - 1000 ДО 1000.

ОПИШИТЕ НА РУССКОМ ИЛИ НА 1 ИЗ ЯЗЫКОВ ПРОГРАММИРОВАНИЯ АЛГОРИТМ , КОТ ПОЗВОЛЯЕТ ПОДСЧИТАТЬ И ВЫВЕСТИ СРЕДНЕЕ АРИФМЕТИЧЕСКОЕ ТЕХ ЭЛЕМЕНТОВ МАССИВА , КОТ ПО СВОЕМУ ЗНАЧЕНИЮ МЕНЬШЕ ПОСЛЕДН ЭЛЕМЕНТА ЭТОГО МАССИВА .

ГАРАНТИРУЕТСЯ , ЧТО В ИСХОДНОМ МАССИВЕ ЕСТЬ ХОТЯ БЫ 1 ТАКОЙ ЭЛЕМЕНТ .

SStellaStar 2 янв. 2024 г., 20:57:25 | 5 - 9 классы

Программа C + + / Тема функцииТреугольник задан координатами его вершин?

Программа C + + / Тема функции

Треугольник задан координатами его вершин.

Определить вид треугольника (равнобедренный, расвносторонний, прямоугольный или обычный).

Длину стороны определять с помощью функции.

Описать функции ввода с клавиатуры элементов одномерного массива и нахождения суммы элементов массива, предшествующих первому отрицательному элементу.

Если среди элементов массива нет отрицательных, то про¬суммировать все элементы.

Ibragimgasimov2 18 февр. 2024 г., 07:23:32 | 5 - 9 классы

Определите, сколько элементов массива А[1?

Определите, сколько элементов массива А[1.

8] не превышают заданного числа 10.

​.

Именительный11 29 мар. 2024 г., 11:35:07 | 5 - 9 классы

Даны два массива целых чисел a и b, каждый их которых не содержитповторяющихся элементов?

Даны два массива целых чисел a и b, каждый их которых не содержит

повторяющихся элементов.

Исходная информация записана в файле.

Построить объединение массивов a и b.

C + +.

Bbggggghh 2 апр. 2024 г., 00:41:00 | 5 - 9 классы

Вычислить среднее арифметическое значение положительных элементов массива А[12] , при том что Ai - действительные числа?

Вычислить среднее арифметическое значение положительных элементов массива А[12] , при том что Ai - действительные числа.

На этой странице сайта вы найдете ответы на вопрос 3. Найти среднее арифметическое элементов массива из 10 элементов и записать его на место максимального элемента?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.