Вычислить среднее арифметическое значение положительных элементов массива А[12] , при том что Ai - действительные числа?

Информатика | 5 - 9 классы

Вычислить среднее арифметическое значение положительных элементов массива А[12] , при том что Ai - действительные числа.

Ответить на вопрос
Ответы (2)
Fadboy 2 апр. 2024 г., 00:41:04

Var A : array [1.

12] of real ;

var ai, sum : real ;

var i, count : integer ;

begin   ;   ; for i : = 1 to 12 do begin   ;   ;   ;   ; read(ai) ;   ;   ;   ;   ; A[i] : = ai ;   ;   ; end ;   ;   ; sum : = 0 ;   ;   ; count : = 0 ;   ;   ; for i : = to 12 do begin   ;   ;   ;   ; if A[i] > ; 0 then begin   ;   ;   ;   ;   ;   ; sum : = sum + A[i] ;   ;   ;   ;   ;   ;   ; count : = count + 1   ;   ;   ;   ; end   ;   ; end ;   ;   ; writeln(sum / count)

end.

Илона2007 2 апр. 2024 г., 00:41:08

= = = = = PascalABC.

NET = = = = =

begin   ; ReadSeqReal(12).

Where(p - > ; p > ; 0).

DefaultIfEmpty.

Average.

Print ;

end.

Sharkovka05 1 февр. 2024 г., 22:51:40 | студенческий

Программа на С + +Не сталкивался и с этимПросьба большая помочьСоздать целочисленный массив типа short int размером n?

Программа на С + +

Не сталкивался и с этим

Просьба большая помочь

Создать целочисленный массив типа short int размером n.

Элементы массива инициализируются по следующему алгоритму :

1) число А вводится с консоли ;

2) используя битовые операции, сделать в нем так, чтобы 11 бит был заменён значением 5 - го бита, а остальные сохранили свои значения.

3) присвоить преобразованное число А текшему элементу массива.

Инициализированный массив вывести на печать и найти в нём элементы, у которых старшая четвёрка бит имеет все единицы.

Dmitrievvanya 4 мар. 2024 г., 04:10:55 | 10 - 11 классы

ПОМОГИТЕ СДЕЛАТЬ В ПИТОНЕ?

ПОМОГИТЕ СДЕЛАТЬ В ПИТОНЕ!

Дано неотрицательное число N - количество элементов массива (N< ; = 100)

Заполнить массив из N элементов первыми натуральными трехзначными числами, произведение цифр которых есть трехзначное число.

Arsen200212 14 апр. 2024 г., 23:16:08 | студенческий

Программа для нахождения количество положительных нечётных элементов целочисленного массива B[1?

Программа для нахождения количество положительных нечётных элементов целочисленного массива B[1.

50]. Помогите пожалуйста.

ДашаВова 30 янв. 2024 г., 05:19:22 | 5 - 9 классы

Даны три числа a, b, с?

Даны три числа a, b, с.

Найти их среднее арифметическое(сумму чисел разделить на их количество).

С клавиатуры вводится число a, количество килобайт.

Переведите это число в байты, биты и мегабайты и выведите значения на экран.

​.

Dagirovauma 8 апр. 2024 г., 20:43:38 | 5 - 9 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные

Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел

ЯЗЫК - PASCAL

35 баллов.

Baulinakristina706 8 апр. 2024 г., 05:30:23 | 10 - 11 классы

Массив размерности N задается случайным образом ?

Массив размерности N задается случайным образом .

Вычислите элементы массива которые стоят на четнвх местах , например A[2] = .

A[4] = .

Kuzminama2017 13 мар. 2024 г., 20:10:10 | 10 - 11 классы

СРОЧНО?

СРОЧНО!

Какой элемент массива будет найден в результате выполнения программного кода?

Максимальный элемент массива

среднее значение элементов массива

минимальный элемент массива.

F39821 16 янв. 2024 г., 00:26:34 | 5 - 9 классы

ДАН ЦЕЛОЧИСЛЕННЫЙ МАССИВ ИЗ 30 ЭЛЕМЕНТОВ ?

ДАН ЦЕЛОЧИСЛЕННЫЙ МАССИВ ИЗ 30 ЭЛЕМЕНТОВ .

ЭЛЕМЕНТЫ МАССИВА МОГУТ ПРИНИМАТЬ ЗНАЧЕНИЯ ОТ - 1000 ДО 1000.

ОПИШИТЕ НА РУССКОМ ИЛИ НА 1 ИЗ ЯЗЫКОВ ПРОГРАММИРОВАНИЯ АЛГОРИТМ , КОТ ПОЗВОЛЯЕТ ПОДСЧИТАТЬ И ВЫВЕСТИ СРЕДНЕЕ АРИФМЕТИЧЕСКОЕ ТЕХ ЭЛЕМЕНТОВ МАССИВА , КОТ ПО СВОЕМУ ЗНАЧЕНИЮ МЕНЬШЕ ПОСЛЕДН ЭЛЕМЕНТА ЭТОГО МАССИВА .

ГАРАНТИРУЕТСЯ , ЧТО В ИСХОДНОМ МАССИВЕ ЕСТЬ ХОТЯ БЫ 1 ТАКОЙ ЭЛЕМЕНТ .

SStellaStar 2 янв. 2024 г., 20:57:25 | 5 - 9 классы

Программа C + + / Тема функцииТреугольник задан координатами его вершин?

Программа C + + / Тема функции

Треугольник задан координатами его вершин.

Определить вид треугольника (равнобедренный, расвносторонний, прямоугольный или обычный).

Длину стороны определять с помощью функции.

Описать функции ввода с клавиатуры элементов одномерного массива и нахождения суммы элементов массива, предшествующих первому отрицательному элементу.

Если среди элементов массива нет отрицательных, то про¬суммировать все элементы.

Ibragimgasimov2 18 февр. 2024 г., 07:23:32 | 5 - 9 классы

Определите, сколько элементов массива А[1?

Определите, сколько элементов массива А[1.

8] не превышают заданного числа 10.

​.

На этой странице находится вопрос Вычислить среднее арифметическое значение положительных элементов массива А[12] , при том что Ai - действительные числа?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.