Помогите :Практическая работа №3?

Информатика | студенческий

Помогите :

Практическая работа №3.

Ветвления

Уровень A.

Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них.

Пример :

Введите два числа : 1 5

Наименьшее число 1

Наибольшее число 5

Уровень B.

Напишите программу, которая получает с клавиатуры четыре целых числа и находит наибольшее из них.

Пример :

Введите четыре числа : 1 2 5 3

Наибольшее число 5

Уровень C.

Напишите программу, которая получает с клавиатуры возрасты трёх человек (Антона, Бориса и Виктора) и определяет, кто из них старше.

Пример :

Возраст Антона : 15

Возраст Бориса : 17

Возраст Виктора : 16

Ответ : Борис старше всех.

Пример :

Возраст Антона : 17

Возраст Бориса : 17

Возраст Виктора : 16

Ответ : Антон и Борис старше Виктора.

На языке паскаль.

Ответить на вопрос
Ответы (1)
Davidos2006 7 янв. 2024 г., 02:54:54

Program p1 ;

var a, b : integer ;

begin

writeln ('Введите 2 числа') ;

readln (a, b) ;

if a = b then writeln ('Числа одинаковые')

else if a> ; b then

begin writeln ('Наибольшее число ', a) ;

writeln ('Наименьшее число ', b) ;

end

else begin writeln ('Наибольшее число ', b) ;

writeln ('Наиментшее число 10 ', a) ;

end ;

end.

Program p2 ;

var a, b, c, d : integer ;

begin

writeln ('Введите 4 числа') ;

readln (a, b, c, d) ;

if a< ; b then a : = b ;

if c< ; d then c : = d ;

if a< ; c then a : = c ;

writeln ('Наибольшее число ', a) ;

end.

Program p3 ;

var a, b, v : integer ;

begin

writeln ('Введите возрасты людей : ') ;

write ('Антона - ') ;

readln (a) ;

write ('Бориса - ') ;

readln (b) ;

write ('Виктора - ') ;

readln (v) ;

if (a = b) and (a = v) then writeln ('Все люди одного возраста') ;

if (a = b) and (a> ; v) then writeln ('Антон и Борис старше Виктора') ;

if (a = b) and (a< ; v) then writeln ('Виктор старше всех')

else if (v> ; a) and (v> ; b) then writeln ('Виктор старше всех') ;

if (b = v) and (b> ; a) then writeln ('Борис и Виктор старше Антона') ;

if (b = v) and (b< ; a) then writeln ('Антон старше всех')

else if (a> ; v) and (a> ; b) then writeln ('Антон старше всех') ;

if (a = v) and (a> ; b) then writeln ('Антон и Виктор старше Бориса') ;

if (a = v) and (a< ; b) then writeln ('Борис старше всех')

else if (b> ; v) and (b> ; a) then writeln ('Борис старше всех') ;

end.

Rumaw88 26 февр. 2024 г., 04:23:33 | 5 - 9 классы

В школьном первенстве по настольному теннису в полуфинал вышли четыре спортсмена : Антон, Борис, Василий и Глеб?

В школьном первенстве по настольному теннису в полуфинал вышли четыре спортсмена : Антон, Борис, Василий и Глеб.

Собравшаяся перед телевизором семья высказала предположения относительно результатов соревнований.

Вот эти мнения :

Мама : Первым будет Антон, а третьим – Глеб.

Папа : Вторым будет Василий, а четвертым – Глеб .

Сын : Антон займет первое место, а Борис будет третьим.

Когда награждали победителей, оказалось, что каждый из членов семьи оказался прав только в одном из своих утверждений.

Найдите распределение мест, если известно, что не было разделения мест между участниками.

В ответе перечислите подряд без пробелов первые буквы имен участников в порядке занятых ими мест.

Omertys 17 мар. 2024 г., 03:27:25 | студенческий

Пожалуйста помогитеНапишите программу, которая запрашивает двацелых числа x и y, после чего вычисляет и выводитзначение x в степени y на пайтоне?

Пожалуйста помогите

Напишите программу, которая запрашивает два

целых числа x и y, после чего вычисляет и выводит

значение x в степени y на пайтоне.

EvdokiomovaUna 16 янв. 2024 г., 19:45:36 | 5 - 9 классы

Дана часть программы?

Дана часть программы.

Определите число, которое выведет программа на экран.

ДдддАааа 2 февр. 2024 г., 01:57:06 | студенческий

Написать программу, которая проверяет, делится ли на 3 число введенная с клавиатуры?

Написать программу, которая проверяет, делится ли на 3 число введенная с клавиатуры.

Если да то, выполните деление, если нет, то выведите на экран сообщение что нельзя поделит без остатка.

Помогите пж!

Saduakasov04 18 янв. 2024 г., 23:01:23 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

Напишите программу которая получает с клавиатуры 2 целых числа и вычисляет их произведение, используя только операции сложения.

Пробить через repeat(постусловие) pascal abc очень прошу.

Namiesfhikova 14 февр. 2024 г., 10:22:51 | студенческий

Идёт ввод натуральных чисел?

Идёт ввод натуральных чисел.

Если было введено не натуральное число, то команда останавливается и в выводе появляется наибольшее четное число из ранее введенных либо если не было введено ни одного натурального числа, то в выводе должна быть надпись "Чётных чисел нет" или что - то похожее

программа python

с помощью цикла while.

Помогите593 25 февр. 2024 г., 00:32:30 | 5 - 9 классы

Напишите наибольшее целое число x, для которого истинно высказывание : НЕ (X> ; 32)?

Напишите наибольшее целое число x, для которого истинно высказывание : НЕ (X> ; 32).

Милана632 14 мар. 2024 г., 23:48:12 | 5 - 9 классы

Разработать подпрограмму, которая в качестве аргумента получает целое число и проверяет, является ли оно простым?

Разработать подпрограмму, которая в качестве аргумента получает целое число и проверяет, является ли оно простым.

Используя подпрограмму вывести на экран все простые числа из промежутка целых чисел, определенного пользователем.

Pascal ABC.

Nsysoeva29 30 янв. 2024 г., 21:04:14 | 5 - 9 классы

С клавиатуры вводится последовательность натуральных чисел, оканчивающихся числом 0?

С клавиатуры вводится последовательность натуральных чисел, оканчивающихся числом 0.

Количество чисел в последовательности неизвестно.

Программа должна вывести на экран четные числа из этой последовательности, которые не меньше 50.

Dfg2003 14 февр. 2024 г., 14:37:40 | 5 - 9 классы

Составьте программу которая позволяет ввести с клавиатуры две строки и определяет равны ли эти строки между собой, если не равны выводит эти строки в алфавитном порядке​?

Составьте программу которая позволяет ввести с клавиатуры две строки и определяет равны ли эти строки между собой, если не равны выводит эти строки в алфавитном порядке​.

На этой странице вы найдете ответ на вопрос Помогите :Практическая работа №3?. Вопрос соответствует категории Информатика и уровню подготовки учащихся студенческий классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.