Напишите три программы одномерного массива, тремя способами : с вводом через клавиатуры, через формулу, рандомом?

Информатика | 5 - 9 классы

Напишите три программы одномерного массива, тремя способами : с вводом через клавиатуры, через формулу, рандомом.

Помогите пожалуйста кто шарит в этой теме, я дилетант.

Ответить на вопрос
Ответы (1)
Оксик47 19 дек. 2023 г., 00:38:51

Ответ :

program arr1 ; / / ввод с клавиатуры

var   ; i : Integer ;   ; a : array [1.

10] of integer ;

begin   ; for i : = 1 to 10 do begin   ;   ; Write ('Введите ', i , 'число : ') ;   ;   ; ReadLn (a [i]) ;   ; end ;   ; for i : = 1 to 10 do   ;   ; Write (a [i], ' ') ;   ; ReadLn ;

end.

Program arr1 ;   ; / / ввод по формуле (I   ; * 2) можно поменять на другую

var   ; i : Integer ;   ; a : array [1.

10] of integer ;

begin   ; Randomize ;   ; for i : = 1 to 10 do   ;   ; a [i] : = i * 2 ;   ; for i : = 1 to 10 do   ;   ; Write (a [i], ' ') ;   ; ReadLn ;

end.

Program arr1 ;   ; / / ввод рандомом - это то что на скриншоте экрана, только добавлено   ; Randomize ;   ; чтобы числа были не всегда одинаковые

var   ; i : Integer ;   ; a : array [1.

10] of integer ;

begin   ; Randomize ;   ; for i : = 1 to 10 do   ;   ; a [i] : = Random (50) ;   ; for i : = 1 to 10 do   ;   ; Write (a [i], ' ') ;   ; ReadLn ;

end.

Объяснение :

Андрей1245 11 нояб. 2023 г., 03:56:49 | 5 - 9 классы

Помогите написать программу по информатике?

Помогите написать программу по информатике.

Напишите программу которая выдает произведения только четных целых чисел.

Маша1803 4 дек. 2023 г., 14:22:12 | 10 - 11 классы

Написать программу на PythonПользователь вводит строку и один символ?

Написать программу на Python

Пользователь вводит строку и один символ.

Напишите программу для расчета количества ввода символа в строку.

В случае, если вводимый символ является буквой, прописные и строчные буквы различаются.

________________________________________

Вхідні дані :

Poirot shook his head energetically.

He was now arranging his moustache with exquisite care.

W

Вихідні дані :

3.

Haily 17 окт. 2023 г., 01:44:59 | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТА СРОЧНО?

ПОМОГИТЕ ПОЖАЛУЙСТА СРОЧНО!

1. Создайте программу которая вычисляет произведение трёх чисел 2, 4, 6 (в программе Python)

2.

Создайте программу которая возводит во Пятую степень число : 5

​.

Melenchuk2016 3 нояб. 2023 г., 06:41:42 | 10 - 11 классы

Дан вещественный массив, состоящий из 7 элементов?

Дан вещественный массив, состоящий из 7 элементов.

Найти произведение этих элементов (одномерные массивы, 10 класс).

Swan426y 20 нояб. 2023 г., 17:05:40 | 10 - 11 классы

Напишите программу?

Напишите программу.

Дано натуральное число.

Найти сумму его цифр, кратных 7.

Ева461 25 нояб. 2023 г., 06:29:37 | 5 - 9 классы

Здравствуйте?

Здравствуйте!

Помогите пожалуйста решить 2 задачу с Паскалем.

(я просто вообще не шарю в этом, а писать всё равно нада хех)

Вопрос :

Напишите процедуру, в которой определяется сумма четных цифр числа N.

Процедуру включите в программу, в которой пользователь вводит N, запускается процедура и программа печатает ответ.

​.

Диана20074 7 дек. 2023 г., 03:15:55 | 5 - 9 классы

Напишите программу по заданной х и у, Определите принадлежит ли точка заштрихованной области?

Напишите программу по заданной х и у, Определите принадлежит ли точка заштрихованной области.

Гык1 3 дек. 2023 г., 23:27:16 | 10 - 11 классы

Составьте программу вычисления значения выражения ( с клавиатуры вводятся произвольные целые значения х и у и выводится на экран соответствующее значение выражения) :3х + 7у - 13Программу назовите : E?

Составьте программу вычисления значения выражения ( с клавиатуры вводятся произвольные целые значения х и у и выводится на экран соответствующее значение выражения) :

3х + 7у - 13

Программу назовите : Examplе

CРОЧНО 25 БАЛЛОВ!

Deidara2 20 дек. 2023 г., 22:07:10 | 10 - 11 классы

Напишите программу решения квадратного уравнения?

Напишите программу решения квадратного уравнения.

Дано a b c коэффициенты, найти корни.

Обязательно через C + + !

Даю 10 баллов, сделайте хорошо пожалуйста.

Мари2843 23 дек. 2023 г., 02:08:13 | 5 - 9 классы

Нужна помощь с задачами с сортировкой массива?

Нужна помощь с задачами с сортировкой массива.

На этой странице находится вопрос Напишите три программы одномерного массива, тремя способами : с вводом через клавиатуры, через формулу, рандомом?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.