3. Трамвайный билет имеет шестизначный номер?

Информатика | 5 - 9 классы

3. Трамвайный билет имеет шестизначный номер.

Выяснить, является ли билет "счастливым".

Билет назовем "счастливым", если сумма первых трех цифр равна сумме последних трех цифр.

Примечание.

Так как шестизначное число больше 32767(тип Integer), необходимо номер билета определит как тип Longint( до 10 знаков).

Ответить на вопрос
Ответы (1)
Leraz2001 26 мар. 2024 г., 10:37:57

Program HappyTicket ;

var ticket : Longint ; { номер трамвайного квитка } firstSum, lastSum : Integer ; { суми перших та останніх трьох цифр }

begin { Введення номера трамвайного квитка з клавіатури } Write('Введіть номер трамвайного квитка : ') ; ReadLn(ticket) ; { Обчислення сум перших та останніх трьох цифр номера } firstSum : = (ticket div 100000) + ((ticket div 10000) mod 10) + ((ticket div 1000) mod 10) ; lastSum : = ((ticket div 100) mod 10) + ((ticket div 10) mod 10) + (ticket mod 10) ; { Перевірка, чи є номер трамвайного квитка "щасливим" } if firstSum = lastSum then WriteLn('Це щасливий квиток!

') else WriteLn('Це не щасливий квиток.

') ;

end.

Katy1998 6 янв. 2024 г., 00:58:31 | 1 - 4 классы

Помогите разгадать последний ресурс, самый нижний?

Помогите разгадать последний ресурс, самый нижний.

Азамат11111 11 янв. 2024 г., 16:24:13 | студенческий

Сгенерируйте список из 10 случайных чисел от 10 до 20 и выведите его в строчку?

Сгенерируйте список из 10 случайных чисел от 10 до 20 и выведите его в строчку.

Напишите программу, которая переставит местами первый и последний элемент в списке (изменит текущий список!

) и выведет его в строчку.

​.

Тсотсь 1 февр. 2024 г., 19:26:17 | 5 - 9 классы

Является ли покраска стен примером действия с информацией?

Является ли покраска стен примером действия с информацией?

Назовите примеры действий, которые не относятся к действиям с иформацией.

MuKCeP 15 февр. 2024 г., 18:31:55 | 5 - 9 классы

Сколько байт необходимо для кодирования слова : ИНФОРМАТИЗАЦИЯ?

Сколько байт необходимо для кодирования слова : ИНФОРМАТИЗАЦИЯ.

YanockaKisil 25 февр. 2024 г., 05:08:26 | 5 - 9 классы

Задание №1?

Задание №1.

Напишите программу, которая находит сумму цифр чисел между k и р.

Какую ошибку вы допу - стили при выполнении задания?

Про - верьте работу операторов, расположен - ных в теле цикла, путем трассировки.

​.

Rak2003Masha 26 февр. 2024 г., 00:48:25 | 5 - 9 классы

Определи, является ли данный граф взвешенным?

Определи, является ли данный граф взвешенным.

Возможные ответы 1)Нет, не является взвешенным графом

2)Да, является взвешенным графом

Определи и запиши вес ребра (если определить невозможно, то поставь 0)

gf (Место для ответа).

Jiiicu 2 мар. 2024 г., 04:01:01 | 5 - 9 классы

Задание 5?

Задание 5.

Рассмотрите следующее высказывание : «Ежегодный праздник «Наурыз».

Определите подходящую блок - схему.

Определите тип алгоритма.

Елизаветахорошая 4 мар. 2024 г., 11:31:19 | 5 - 9 классы

Решите столбиком информатика 8 класс 17 номер?

Решите столбиком информатика 8 класс 17 номер.

Elitakarimova 4 мар. 2024 г., 15:23:32 | 5 - 9 классы

ПИТАННЯ : 1 За якою характеристикою класифікують операційні системи?

ПИТАННЯ : 1 За якою характеристикою класифікують операційні системи?

А)Тип пристроїв, для яких вони призначені, б)виробники, в)надійність, г)тип інтерфейсу ​.

Kristin90 16 мар. 2024 г., 16:26:15 | 5 - 9 классы

Срочно пожалуйста?

Срочно пожалуйста!

Складіть таблиці істинності логічних виразів зі змінними логічного типу а i b

a) a or a and b

в)a or b or not b​​.

На странице вопроса 3. Трамвайный билет имеет шестизначный номер? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.