Для целого числа к от 1 до 99 напечатать фразу "мне k лет", учитывая при этом, что при некоторых значениях k слово "лет"надо заменить на слово год или года?

Информатика | 5 - 9 классы

Для целого числа к от 1 до 99 напечатать фразу "мне k лет", учитывая при этом, что при некоторых значениях k слово "лет"надо заменить на слово год или года.

Например, 11 лет, 22 года, 51 год.

ПАСКАЛЬ, ПОЖАЛУЙСТА.

Ответить на вопрос
Ответы (1)
KirillVortac 15 янв. 2022 г., 13:03:24

Var

let : array [1.

63] of Integer = (5 , 6, 7, 8, 9, 10, 11, 12, 13, 14, 15 , 16 , 17 , 18, 19 , 20, 25, 26, 27, 28, 29, 30, 35, 36, 37, 38, 39, 40, 45, 46, 47, 48, 49, 50, 55, 56, 57, 58, 59, 60, 65, 66, 67, 68, 69, 70, 75, 76, 77, 78, 79, 80, 85, 86, 87, 88, 89, 90, 95, 96, 97, 98, 99) ;

gad : array [1.

9] of Integer = (1, 21, 31, 41, 51, 61, 71 , 81 , 91) ;

goda : array[1.

27] of Integer = (2, 3, 4, 22, 23, 24, 32, 33, 34, 42, 43, 44, 52, 53, 54, 62, 63, 64, 72, 73, 74, 82, 83, 84, 92, 93, 94) ;

k : Integer ;

begin

for k : = 1 to 99 do

begin

if k = let then

begin

writeln('Мне', k, 'лет') ;

end ;

if k = gad then

begin

writeln('Мне', k, 'год') ;

end ;

if k = goda then

begin

writeln('Мне', k, 'Года') ;

end ;

end ;

end.

Petrova10 22 янв. 2022 г., 23:25:55 | 10 - 11 классы

Как назвали пользователей UNIX, созданную в 1990 году?

Как назвали пользователей UNIX, созданную в 1990 году?

Egorgordiy 25 янв. 2022 г., 16:40:59 | 5 - 9 классы

В 1985 году в городе было 45000 человек?

В 1985 году в городе было 45000 человек.

Ежегодный прирост составлял 3%.

Сколько жителей было бы в городе в 2017 году?

Nastya0342 14 янв. 2022 г., 11:54:43 | 5 - 9 классы

Можно ли было использовать на всех ЭВМ программы, написанные для ЭВМ до 1950 года?

Можно ли было использовать на всех ЭВМ программы, написанные для ЭВМ до 1950 года?

Ученик11151 11 февр. 2022 г., 15:34:26 | 5 - 9 классы

Как будет древнеегипетскими иероглифамм год 2003?

Как будет древнеегипетскими иероглифамм год 2003.

Anyaa18 31 мар. 2022 г., 08:26:53 | 10 - 11 классы

Пират положил в сундук некоторое количество золотых монет?

Пират положил в сундук некоторое количество золотых монет.

На второй год он вынул из сундука сколько - то монет.

Начиная с третьего года, он добавлял столько монет , сколько было в сундуке два года назад.

Требуется написать программу, которая определит, сколько монет было в сундуке в первый и во второй год , в сундуке будет 5, 2, 7, 9, , 16, 25 .

Монет.

Формат входного файла :

Входной файл INPUT.

TXT содержит числа Х (3.

Khamitovedik 13 мар. 2022 г., 21:50:32 | 5 - 9 классы

В классе 24 ученика, в среднем каждый ученик набирает по 160 символов в минуту?

В классе 24 ученика, в среднем каждый ученик набирает по 160 символов в минуту.

За сколько лет все ученики без остановки и перерывов заполнят жесткий диск размером 1 Тбайт (1 год = 365 дней)?

Буква закодирована из таблицы в 256 символов.

Варианты :

~2, 1 год

~68 лет

~545 лет.

Bazalaika2 18 апр. 2022 г., 02:28:18 | студенческий

Вычислить число и месяц в невисокосном году по номеру дня(информатика , написать программу )?

Вычислить число и месяц в невисокосном году по номеру дня(информатика , написать программу ).

Баука1987 1 янв. 2022 г., 13:09:09 | 5 - 9 классы

Задача "Животное года"Пользователь вводит номер года (больше 1996 года)?

Задача "Животное года"

Пользователь вводит номер года (больше 1996 года).

Необходимо определить животное, под знаком которого пройдет год, если 1996 год – год Крысы.

Цикл повторения распределения животных равен 12 лет (крыса, бык, тигр, кролик, дракон, змея, лошадь, коза, обезьяна, петух, собака свинья).

На языке программирования Python.

Saika2002 19 мар. 2022 г., 12:44:33 | 10 - 11 классы

Поїзд їхав t1 год зі швидкістю v1 км / год, t2 год зі швидкістю v2 км / год і t3 год зі швидкістю v3 км / год ?

Поїзд їхав t1 год зі швидкістю v1 км / год, t2 год зі швидкістю v2 км / год і t3 год зі швидкістю v3 км / год .

Визначити пройдені шляхи з різною швидкістю і повний шлях.

Абдул14 15 февр. 2022 г., 04:09:54 | 10 - 11 классы

Дима решил посчитать, сколько у него наград за N лет?

Дима решил посчитать, сколько у него наград за N лет.

У него награды разложены по годам и известно их количество.

Формат ввода :

N – количество лет (N.

Вы зашли на страницу вопроса Для целого числа к от 1 до 99 напечатать фразу "мне k лет", учитывая при этом, что при некоторых значениях k слово "лет"надо заменить на слово год или года?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.