Составить блок - схему для программы упорядочивания элементов массива в QBasic?

Информатика | 10 - 11 классы

Составить блок - схему для программы упорядочивания элементов массива в QBasic.

RANDOMIZE TIMER

CLS

INPUT "n = ", n

DIM a(n)

FOR i = 1 TO n PRINT "a" ; INPUT " : ", a(i)

NEXT

FOR i = 1 TO n - 1 min = a(i) : k = i FOR y = i TO n IF a(y) < min THEN min = a(y) : k = y NEXT SWAP a(k), a(i)

NEXT

FOR i = 1 TO n PRINT a(i) ;

NEXT.

Ответить на вопрос
Ответы (1)
НастяКруть 6 мая 2022 г., 10:18:59

Я не совсем понял, зачем тебе тут randomize timer, но не суть.

Сделал все в точности по коду.

Npirmamatov 9 янв. 2022 г., 03:07:32 | 5 - 9 классы

Определите, что будет напечатано в результате работы следующей программы?

Определите, что будет напечатано в результате работы следующей программы.

Текст программы приведен на трех языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач цел s, k s : = 0 нц для k от 5 до 12 s : = s + 7 кц вывод s

кон DIM s, k AS INTEGER

s = 0

FOR k = 5 TO 12 s = s + 7

NEXT k

PRINT s

END var s, k : integer ;

begin s : = 0 ; for k : = 5 to 12 do s : = s + 7 ; write(s) ;

end.

Girls2352143 2 февр. 2022 г., 17:53:50 | 5 - 9 классы

Помогите решить?

Помогите решить!

Вывести на печать числа от 0 до n, считая, что все числа натуральные, нужно составить 3 программы : 1) for 2)while 3) repeat.

Глф 17 февр. 2022 г., 07:33:23 | 10 - 11 классы

Друзья?

Друзья!

Требуется Ваша помощь!

Составляю алгоритм по задаче, но не знаю, как грамотно объяснить : "На сковородку одновременно можно положить k котлет.

Каждую котлету нужно с каждой стороны обжаривать m минут непрерывно.

За какое наименьшее время удастся поджарить с обеих сторон n котлет?

Вводятся 3 числа : k, m и n.

Вывести время, за которое все котлеты будут обжарены.

" Чтобы Вы не думали, что мне только решение нужно, прилагаю свой код, который неидеален.

Помогите, пожалуйста, довести задачу до конца.

K = int(input())

m = int(input())

n = int(input())

if n>k : if n%k>0 : print (n / / k * m * 2 + m * 2) if n%k = = 0 : print (n / / k * m * 2)

if n.

Maryana11Ro 7 апр. 2022 г., 05:47:03 | 10 - 11 классы

Составить блок - схему :Заменить все отрицательные элементы массива на ноль?

Составить блок - схему :

Заменить все отрицательные элементы массива на ноль.

Эвелинка5 13 апр. 2022 г., 03:39:03 | 5 - 9 классы

Преобразуйте в код ASCII выражения :a)a + bb)FOR I = 1 TO Nc) PRINT ASd)NEXT Ie)PAUSE?

Преобразуйте в код ASCII выражения :

a)a + b

b)FOR I = 1 TO N

c) PRINT AS

d)NEXT I

e)PAUSE.

Руслан0777 6 мая 2022 г., 19:26:29 | 5 - 9 классы

Ребят, нужна пооомощь : с Найти max из : min(А, В, С) и min(А1, В1, С1)?

Ребят, нужна пооомощь : с Найти max из : min(А, В, С) и min(А1, В1, С1).

Нужна блок - схема и программа(или хотя бы что - нибудь одно из этого) : 0.

Cтепан 2 янв. 2022 г., 00:03:06 | 10 - 11 классы

Пролог?

Пролог.

Создать предикат, находящий минимальное из значений, находящихся в листьях дерева

Дмитрий Фирсов Ученик (176), Вопрос открыт 6 минут назад

Есть код для такого задания : Создать предикат, находящий минимальное из значений, находящихся в вершинах дерева.

DOMAINS

tree = e ; tr(integer, tree, tree)

PREDICATES

tree_min(tree, integer)

min(integer, integer, integer)

CLAUSES

min(X, Y, Z) : -

X

min(_, Y, Y).

Tree_min(e, 0).

Tree_min(tr(X, L, R), N) : -

tree_min (L, N1),

tree_min (R, N2),

min(X, N1, Z),

min(Z, N2, Z1),

N = Z1.

Что нужно поменять, чтобы сделать получить код для задания, которое указано в заголовке моего вопроса?

Lina250570 4 апр. 2022 г., 17:13:37 | 10 - 11 классы

С помощью while и for (2 программы) напишите программу вывода всех чисел в диапазоне от 5 до 55 включительно?

С помощью while и for (2 программы) напишите программу вывода всех чисел в диапазоне от 5 до 55 включительно.

Антонинка1230 27 июн. 2022 г., 21:01:21 | 10 - 11 классы

Program a2 ;var a, b, c, min : real ;beginwriteln('Введите три числа') ;readln(a, b, c) ;min : = a ;if bif cwriteln('min = ', min)end?

Program a2 ;

var a, b, c, min : real ;

begin

writeln('Введите три числа') ;

readln(a, b, c) ;

min : = a ;

if b

if c

writeln('min = ', min)

end.

КАК РЕШАТЬ?

А)а = 10, b = 5 и с = 1

Б)а = 10, b = 5 и с = 7

В)а = 2, b = 10, с = 5.

Витуша 22 апр. 2022 г., 11:55:07 | 10 - 11 классы

Умоляю, помогите решить пожалуйста?

Умоляю, помогите решить пожалуйста!

1)Задан массив X[1.

N]. Какой оператор надо поставить вместо многоточия, чтобы в результате в переменную nR был записан номер элемента, равного R?

Вводите ответ без пробелов.

NR : = 0 ; for k : = 1 to N do if X[k] = R then begin .

Break end ;

2)Задан массив X[1.

N]. Какой оператор надо поставить вместо многоточия, чтобы найти номер максимального элемента массива в переменной M?

Вводите ответ без пробелов.

M : = 1 ; for k : = 2 to N do if X[k]>X[M] then .

Перед вами страница с вопросом Составить блок - схему для программы упорядочивания элементов массива в QBasic?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.