Помогите решить?

Информатика | 5 - 9 классы

Помогите решить!

Вывести на печать числа от 0 до n, считая, что все числа натуральные, нужно составить 3 программы : 1) for 2)while 3) repeat.

Ответить на вопрос
Ответы (1)
Volodyacotyagi 2 февр. 2022 г., 17:53:52

1)

Program n1 ;

var n, i : integer ;

begin

readln(n) ;

for i : = 0 to n do write(i, ' ') ;

end.

2)

Program n1 ;

var n, i : integer ;

begin

readln(n) ;

i : = 0 ;

while in

end.

Примечание :

0 не является натуральным числом, поэтому если надо, чтобы числа выводились начиная с 1, надо везде строчку i : = 0 заменить на i : = 1.

ТетеринКирилл 13 янв. 2022 г., 07:39:59 | 5 - 9 классы

. Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 6?

. Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 6.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность через repeat until.

НеЕдинорог11 9 янв. 2022 г., 10:49:24 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3?

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 1000.

Введённые числа не превыша ют 30 000.

Программа должна вывести одно число — минимальное число, кратное 3.

Дашуля1995 13 февр. 2022 г., 07:26:49 | 10 - 11 классы

Составьте алгоритм для определения количества цифр в записи произвольного натурального числаЧерез оператор repeat?

Составьте алгоритм для определения количества цифр в записи произвольного натурального числа

Через оператор repeat.

Dima20066 1 февр. 2022 г., 19:46:33 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8?

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0(0 - признак окончания ввода, не входит в последовательность.

Программа должна вывести одно число : сумму всех двузначных чисел, кратных 8.

Bablosikkkk 25 февр. 2022 г., 21:25:40 | 10 - 11 классы

11. Составить программу, осуществляющую ввод числовых переменных?

11. Составить программу, осуществляющую ввод числовых переменных.

Если число положительное, то вывести соответствующую информацию и выйти из программы.

Если число отрицательное, то вывести соответствующую информацию и вернуться на ввод.

MARINABARDYMOV 25 янв. 2022 г., 02:50:21 | 5 - 9 классы

Дан одномерный массив [ - 50 : 50], нужно вывести числа больше 7, программа на Паскаль?

Дан одномерный массив [ - 50 : 50], нужно вывести числа больше 7, программа на Паскаль.

12364578 12 янв. 2022 г., 08:39:57 | 5 - 9 классы

Нужно на C + +Дано число?

Нужно на C + +

Дано число.

В этом числе необходимо изменить одну цифру таким образом, чтобы новое число делилось на 3 и было бы максимально возможным.

В исходном числе нужно обязательно изменить одну цифру, даже если исходное число уже делилось на 3.

Программа получает на вход одно длинное натуральное число.

Длина числа может достигать 100 цифр.

Программа должна вывести другое натуральное число, удовлетворяющее условиям :

1)Новое число должно отличаться от данного ровно одной цифрой.

2)Новое число должно делиться на 3.

3)Новое число должно быть максимально возможным из всех таких чисел.

EkSpErTiK 4 февр. 2022 г., 23:06:54 | 5 - 9 классы

Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке?

Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке.

Последовательность завершается числом 0, при считывании которого программа должна закончить свою работу и вывести количество членов последовательности (не считая завершающего числа 0).

Числа, следующие за числом 0, считывать не нужно.

Решить на питоне.

Рофаелка 2 янв. 2022 г., 10:18:55 | 10 - 11 классы

Программа на с + +Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр?

Программа на с + +

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Числа разделяются пробелами.

Aoverchuk 16 апр. 2022 г., 08:21:23 | 10 - 11 классы

Составить программу?

Составить программу.

Дано число N нужно поменять порядок цифр в этом числе и вывести его.

Число N вводится с клавиатуры.

На этой странице вы найдете ответ на вопрос Помогите решить?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.