ПОДСКАЖИТЕ ПОЖАЛУЙСТА, нужен оператор while - do?

Информатика | 10 - 11 классы

ПОДСКАЖИТЕ ПОЖАЛУЙСТА, нужен оператор while - do.

Надо написать программу в паскале

Вычислить значение заданной функции непосредственно и как

сумму ряда с погрешностью 0.

001. Значение аргумента выбрать самостоятельно.

Ответить на вопрос
Ответы (1)
Kkaterina367 29 окт. 2021 г., 01:06:21

Const e = 0.

001 ;

var x, a, a2, s : real ; n : integer ;

begin

write('x = ') ; readln(x) ;

a : = x ;

a2 : = x * x ;

s : = x ;

n : = 0 ;

while abs(a)>e do begin

n : = n + 1 ;

a : = a * a2 / (2 * n) / (2 * n + 1) ;

s : = s + a ;

end ;

writeln('s = ', s : 7 : 5) ;

writeln('f = ', sinh(x) : 7 : 5) ;

end.

Пример :

x = 1.

5

s = 2.

12928

f = 2.

12928.

Saneksuvorkin11 6 июн. 2021 г., 12:22:31 | 5 - 9 классы

Вычислить и вывести на экран в виде таблицы значения функции, заданной с помощью ряда Тейлора, на интервале от Xнач до Xкон с шагом dx с точностью e?

Вычислить и вывести на экран в виде таблицы значения функции, заданной с помощью ряда Тейлора, на интервале от Xнач до Xкон с шагом dx с точностью e.

Таблицу снабдить заголовком и шапкой.

Каждая строка таблицы должна содержать значение аргумента, значение функции и количество просуммированных членов ряда.

Написать программу в паскале.

SvetikaLH 23 янв. 2021 г., 22:10:56 | 5 - 9 классы

Написать программу на паскале через циклы while и repeat?

Написать программу на паскале через циклы while и repeat.

Вычислить сумму бесконечного сходящегося ряда с точностью eps = 0.

5 * 10 ^ - 6.

Школьник19 23 мар. 2021 г., 16:46:17 | 5 - 9 классы

Написать программу в Паскале через циклы while и repeat?

Написать программу в Паскале через циклы while и repeat.

Вычислить сумму бесконечного ряда с заданной точностью E = 0.

5e - 6, к = 0.

Vfhbflf 17 янв. 2021 г., 13:33:27 | 5 - 9 классы

Написать программу на паскалеДаны действительные числа x, y?

Написать программу на паскале

Даны действительные числа x, y.

Вычислить значение функции z = arcsin(x + y).

Saklakovaolesya 12 авг. 2021 г., 21:04:30 | студенческий

Помогите Написать программу на языке С#, которая по введенному значению аргумента вычисляет значение функции, заданной в виде графика?

Помогите Написать программу на языке С#, которая по введенному значению аргумента вычисляет значение функции, заданной в виде графика.

Параметр R вводится с клавиатуры.

Заранее огромное спасибо.

Катальшик 23 мар. 2021 г., 03:57:16 | 5 - 9 классы

Помогите , по программе паскаль Написать программу, которая выводит табличные значения функции у = х2 + 2?

Помогите , по программе паскаль Написать программу, которая выводит табличные значения функции у = х2 + 2.

Диапазон изменения аргумента от – 4 до 4, шаг аргумента 1.

Zoloto31 25 сент. 2021 г., 09:57:50 | 5 - 9 классы

Помогите пожалуйста написать программу и составить блок - схему :Вычислить значение функции, заданной следующим образом : Cosx, если - π?

Помогите пожалуйста написать программу и составить блок - схему :

Вычислить значение функции, заданной следующим образом : Cosx, если - π.

Timaospanov201 9 нояб. 2021 г., 07:05:48 | студенческий

Написать программу которая вычисляет сумму первых n членов ряда 1, 3, 5?

Написать программу которая вычисляет сумму первых n членов ряда 1, 3, 5.

(while, repeat, for ) на паскале.

Ilyaslukmanov 24 мая 2021 г., 16:10:58 | 10 - 11 классы

6. Составить программу для вывода на экран таблицы и графика значений функции y = f(x) на интервале значений аргумента a < x < b, изменяющегося с шагом h?

6. Составить программу для вывода на экран таблицы и графика значений функции y = f(x) на интервале значений аргумента a < x < b, изменяющегося с шагом h.

Значения a, b, h задаются при помощи оператора ввода.

Выужезадрегистрацией 4 авг. 2021 г., 02:43:46 | 5 - 9 классы

Здравствуйте?

Здравствуйте!

Помогите пожалуйста : вычислить сумму бесконечного ряда с заданной погрешностью E = 0, 001.

Вопрос ПОДСКАЖИТЕ ПОЖАЛУЙСТА, нужен оператор while - do?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.