Вычислить и вывести на экран в виде таблицы значения функции, заданной с помощью ряда Тейлора, на интервале от Xнач до Xкон с шагом dx с точностью e?

Информатика | 5 - 9 классы

Вычислить и вывести на экран в виде таблицы значения функции, заданной с помощью ряда Тейлора, на интервале от Xнач до Xкон с шагом dx с точностью e.

Таблицу снабдить заголовком и шапкой.

Каждая строка таблицы должна содержать значение аргумента, значение функции и количество просуммированных членов ряда.

Написать программу в паскале.

Ответить на вопрос
Ответы (1)
Olbah1 6 июн. 2021 г., 12:22:35

Var x0, xk, dx, e, x, a, s : real ; i : integer ;

begin readln(x0, xk, dx, e) ; x : = x0 ; writeln(' i ' : 3, ' ', ' x ' : 10, ' ', ' s ' : 10) ; repeat a : = 1 ; s : = a ; i : = 0 ; repeat i : = i + 1 ; a : = a * x / i ; s : = s + a ; writeln(i : 3, ' ', x : 10 : 3, ' ', s : 10 : 3) ; until abs(a) < ; e ; x : = x + dx ; until x > ; = xk ;

end.

Giroes 10 янв. 2021 г., 03:07:32 | 5 - 9 классы

Составить программу для вычисления значений функции F(x) на отрезке [a, b] с шагом h?

Составить программу для вычисления значений функции F(x) на отрезке [a, b] с шагом h.

Результат представить в виде таблицы, первый столбец которой - значение аргумента, а второй - соответствующие значения функций.

F(x) = sin²x.

Elechka5678 13 янв. 2021 г., 17:30:08 | 10 - 11 классы

Вычислить значения функции () в точках заданного отрезка ∈ [, ] с указанным шагом ℎ и вывести на экран в виде таблицы ?

Вычислить значения функции () в точках заданного отрезка ∈ [, ] с указанным шагом ℎ и вывести на экран в виде таблицы :

12345а4 15 янв. 2021 г., 08:43:08 | 5 - 9 классы

Вывести на экран таблицу значений функции x2 на отрезке [0 ; 1] с шагом 0, 1 ?

Вывести на экран таблицу значений функции x2 на отрезке [0 ; 1] с шагом 0, 1 .

Каждое число вывести в 8 позициях на отдельной строке.

(Использовать цикл repeat).

Илья1312 26 апр. 2021 г., 12:38:17 | 5 - 9 классы

Построить таблицу значений функции у = х ^ 3 + 2 длязначений аргументов от - 3 до 3 с шагом 0, 5?

Построить таблицу значений функции у = х ^ 3 + 2 для

значений аргументов от - 3 до 3 с шагом 0, 5.

Постройте

график функции.

Заданние выполнить в Exel.

ДомРаб2класс 27 авг. 2021 г., 09:45:19 | 10 - 11 классы

ПаскальСоставить программу для вычисления значений функции F(x) на отрезке [a, b] с шагом h?

Паскаль

Составить программу для вычисления значений функции F(x) на отрезке [a, b] с шагом h.

Результат представить в виде таблицы, первый столбец которой - значение аргумента, а второй - соответствующие значения функций.

Kykychka12 8 мая 2021 г., 13:38:28 | 10 - 11 классы

Pascal abcЗадание : Составить блок - схему алгоритма и две программы (одну с операторами присваи - вания, перехода ; вторую с использованием циклов) для вычисления значений функции при изменении аргум?

Pascal abc

Задание : Составить блок - схему алгоритма и две программы (одну с операторами присваи - вания, перехода ; вторую с использованием циклов) для вычисления значений функции при изменении аргумента.

Вывод на экран значений вводимых исходных данных и ре - зультатов вычислений оформить в виде таблицы с указанием в шапке таблицы имен аргу - ментов и функции.

Ilyaslukmanov 24 мая 2021 г., 16:10:58 | 10 - 11 классы

6. Составить программу для вывода на экран таблицы и графика значений функции y = f(x) на интервале значений аргумента a < x < b, изменяющегося с шагом h?

6. Составить программу для вывода на экран таблицы и графика значений функции y = f(x) на интервале значений аргумента a < x < b, изменяющегося с шагом h.

Значения a, b, h задаются при помощи оператора ввода.

Wodwoorker 22 мая 2021 г., 17:47:25 | 10 - 11 классы

Составить таблицу значений функции Y при изменении аргумента на интервале от А до В с шагом Н, если при некоторых значениях аргумента функция неопределена, то вывести соответствующее значение?

Составить таблицу значений функции Y при изменении аргумента на интервале от А до В с шагом Н, если при некоторых значениях аргумента функция неопределена, то вывести соответствующее значение.

Y = x sin√(x + C - 0, 00084), A = - 2.

05, B = - 4.

05, C = 3.

4, H = - 0.

2.

Ban1984 17 авг. 2021 г., 07:16:55 | 5 - 9 классы

Написать программу в Pascal ABC?

Написать программу в Pascal ABC.

Вычислить значение функции y(x) и вывести его на экран.

Pavel120707 29 окт. 2021 г., 01:06:19 | 10 - 11 классы

ПОДСКАЖИТЕ ПОЖАЛУЙСТА, нужен оператор while - do?

ПОДСКАЖИТЕ ПОЖАЛУЙСТА, нужен оператор while - do.

Надо написать программу в паскале

Вычислить значение заданной функции непосредственно и как

сумму ряда с погрешностью 0.

001. Значение аргумента выбрать самостоятельно.

На этой странице находится ответ на вопрос Вычислить и вывести на экран в виде таблицы значения функции, заданной с помощью ряда Тейлора, на интервале от Xнач до Xкон с шагом dx с точностью e?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.