Написать 2 программы на языке Pascal?

Информатика | 5 - 9 классы

Написать 2 программы на языке Pascal.

1 программа.

Задано число x.

Определить, является ли число x положительным или нет.

Выдать на экран соответствующее сообщение.

2 программа .

Дано три числа x, y, z.

Вычислить сумму только положительных чисел из трех данных.

Подсказка :

1.

Ввод исходных данных

2.

Проверка условия x>0, если условие выполняется, то sum : = sum + x.

Аналогично проверяются условия с y и z.

3. Вывод результата.

Ответить на вопрос
Ответы (2)
Ссс4 6 апр. 2022 г., 20:24:26

Программа 1.

Program p1 ;

var x : integer ;

begin

write ('x = ') ;

read (x) ;

if x>0 then

writeln ('Число x положительное.

') ;

if x = 0 then

writeln ('Число x нейтральное.

') ;

if x0 then

s : = s + x ;

if y>0 then

s : = s + y ;

if z>0 then

s : = s + z ;

if x + y + z0 then

writeln ('s = ', s) ;

end.

Gbop 6 апр. 2022 г., 20:24:31

Скачай ниже.

Maxkorzhnev 7 янв. 2022 г., 06:32:51 | 5 - 9 классы

ПОМОГИТЕ СРОЧНО1) с клавиатуры вводятся два целых числа А и В?

ПОМОГИТЕ СРОЧНО

1) с клавиатуры вводятся два целых числа А и В.

Написать программу, которая выводит число 1, если числа равны, и число 0 в противно случае.

2) написать программу, в которой подсчитывается сумма только положительных чисел из трёх данных.

3) определить принадлежит ли точка с координатами (x, y) первой четверти.

Всё надо в паскале написать.

Bablosikkkk 25 февр. 2022 г., 21:25:40 | 10 - 11 классы

11. Составить программу, осуществляющую ввод числовых переменных?

11. Составить программу, осуществляющую ввод числовых переменных.

Если число положительное, то вывести соответствующую информацию и выйти из программы.

Если число отрицательное, то вывести соответствующую информацию и вернуться на ввод.

NekoSkeleton 28 янв. 2022 г., 14:52:54 | 5 - 9 классы

1. Дано 3 числа?

1. Дано 3 числа.

Найти произведение двух наименьших из этих чисел

написать программу на pascal.

Yanastolnikowa 18 янв. 2022 г., 13:43:22 | 5 - 9 классы

Напишите программу?

Напишите программу!

Является ли сумма трех чисел четным числом?

Yulia19052004 10 апр. 2022 г., 17:58:33 | 5 - 9 классы

Дано три числа?

Дано три числа.

Упорядочите их в порядке неубывания.

Программа должна считывать три числа a, b, c, затем программа должна менять их значения так, чтобы стали выполнены условия a.

TeriLis 13 апр. 2022 г., 04:02:47 | 5 - 9 классы

Составьте программу, которая сравнивает два целых числа введенных с клавиатуры - положительное и отрицательное и выводит положительное число на экран?

Составьте программу, которая сравнивает два целых числа введенных с клавиатуры - положительное и отрицательное и выводит положительное число на экран.

Asema0502 16 янв. 2022 г., 06:24:49 | студенческий

70 балов?

70 балов.

Напишите программу на С + + которая решает даную задачу :

Пользователь вводит два числа.

Определить, делится ли первое число на второе без остатка.

Если нет вівести ближайшее целое число,

удовлетворяющее условие.

Линка43 18 апр. 2022 г., 06:02:39 | 10 - 11 классы

Дано трехзначное число?

Дано трехзначное число.

Определить, является ли сумма его цифр кратна 3 и 5.

Написать программу на C + + и Pascal.

VOVA07 5 мая 2022 г., 02:50:11 | 5 - 9 классы

Составьте программу в Pascal ABC?

Составьте программу в Pascal ABC.

Даны три числа.

Найти наименьшее.

Yuralagouda 4 мая 2022 г., 22:04:14 | 10 - 11 классы

Написать программу, которая вычисляет сумму первых n целых положительных целых чисел?

Написать программу, которая вычисляет сумму первых n целых положительных целых чисел.

Количество суммируемых чисел должно вводиться во время работы программы.

Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены жирным шрифтом).

Вычисление суммы положительных чисел.

Введите количество суммируемых чисел —> 20

Сумма первых 20 положительных чисел равна 210.

На странице вопроса Написать 2 программы на языке Pascal? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.