Выяснить, упорядочены ли цифры в записи числа по убыванию?

Информатика | 5 - 9 классы

 Выяснить, упорядочены ли цифры в записи числа по убыванию.

Написать программу в PascalABC.

NET и нарисовать блок - схему.

Ответить на вопрос
Ответы (2)
Zotov4564 3 окт. 2021 г., 01:36:49

Var n : integer ; a, b : byte ;

begin read(n) ; b : = n mod 10 ; n : = n div 10 ; a : = n mod 10 ; n : = n div 10 ; while (a > b) and (n 0) do begin b : = a ; a : = n mod 10 ; n : = n div 10 ; end ; if a > b then writeln('Цифры числа расположены по убыванию') else writeln('Цифры числа расположены не по убыванию')

end.

СкреПка22 3 окт. 2021 г., 01:36:55

Vara, b, i, k, max : integer ; beginreadln(a) ; max : = 0 ; k : = 0 ; while a1 do begin

if (a mod 10) > max then beginmax : = (a mod 10) ; endelse k + = 1 ;

a : = a div 10 ; if a max then beginmax : = (a mod 10) ; endelse k + = 1 ; a : = 1 ;

end ; end ; if k = 0 then writeln('Убывание')else writeln('Неубывание') ; end.

Kokstanuwa 7 мая 2021 г., 07:20:24 | 5 - 9 классы

Напишите (отправьте фотографию), что нужно написать в программе PascalABC?

Напишите (отправьте фотографию), что нужно написать в программе PascalABC.

NET, чтобы создать программу

《 Begin1°.

Дана сторона квадрата a.

Найти его периметр P = 4a》.

Omoonon 11 мая 2021 г., 17:07:33 | 10 - 11 классы

ДАЮ 29 баллов?

ДАЮ 29 баллов.

ПОМОГИТЕ, ПОЖАЛУЙСТА, НАПИСАТЬ ПРОГРАММУ и БЛОК - СХЕМУ : ввести целое число и найти сумму его цифр.

Chijovmv 4 дек. 2021 г., 15:41:14 | 5 - 9 классы

Даны трёхзначные числа, если число заканчивается на 4 вывести его на экран?

Даны трёхзначные числа, если число заканчивается на 4 вывести его на экран.

Надо написать блок схему и программу.

Рроорп 15 февр. 2021 г., 20:10:22 | 5 - 9 классы

Напишите программу, которая сортирует массив по убыванию и ищет в нем все значения, равные введенному числу?

Напишите программу, которая сортирует массив по убыванию и ищет в нем все значения, равные введенному числу.

PascalABC.

Goldlineminsk 11 июн. 2021 г., 10:21:29 | 5 - 9 классы

Помогите, пожалуйста, решить л?

Помогите, пожалуйста, решить л.

Р. по номером 2 на программе PascalABC.

Net вместе с блок - схемой и объяснением.

ПОЖАЛУЙСТа.

Sashaadaaa 5 апр. 2021 г., 14:20:07 | 10 - 11 классы

Помогите?

Помогите!

Тема : Циклы

Нужно нарисовать блок схему и написать программу на языке ТурбоПаскаль

Если не сложно, то по подробнее!

Во вложении.

Екатерина201995 21 авг. 2021 г., 04:09:05 | 10 - 11 классы

Помогите?

Помогите!

Тема была циклы.

Нужно нарисовать блок схему и написать программу на языке ТП( ТурбоПаскаль)

Пожалуйста, если можно то по подробнее!

Задача во вложении!

УченицаВика1 11 февр. 2021 г., 16:38:54 | 5 - 9 классы

Составьте алгоритм, блок - схему и программу вычисления суммы квадратов числа 2?

Составьте алгоритм, блок - схему и программу вычисления суммы квадратов числа 2.

Pascal abc.

Net.

Djoni7 20 сент. 2021 г., 13:23:00 | студенческий

Нарисовать данную картинку в PascalABC?

Нарисовать данную картинку в PascalABC.

NET с помощью модуля graphABC.

Дал3 16 июн. 2021 г., 01:03:25 | 10 - 11 классы

Нужно составить (нарисовать, начертить?

Нужно составить (нарисовать, начертить.

, как вам удобно) алгоритм для программы : : : Задано множество из 10 различных чисел (отрицательных и положительных), среди которых есть 0.

Нужно упорядочить числа следующие за 0 по убываниь (я так поняла, что нужно упорядочить по убыванию все числа в массиве, которые больше 0)).

На этой странице находится вопрос  Выяснить, упорядочены ли цифры в записи числа по убыванию?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.