На координатной плоскости расположены три точки : A, B, C?

Информатика | 10 - 11 классы

На координатной плоскости расположены три точки : A, B, C.

Написать программу в Pythom, определяющую, какая из двух последних точек (B или C) расположена ближе к A, вывести эту точку и расстояние от нее до точки A.

).

Ответить на вопрос
Ответы (1)
Селиваныч 26 янв. 2022 г., 03:32:05

Import math

a = list(str(input()).

Split()) #Cделано по теореме Пифагора.

Вроде работает

a1 = int(a[0])

a2 = int(a[1])

b = list(str(input()).

Split())

b1 = int(b[0])

b2 = int(b[1])

c = list(str(input()).

Split())

c1 = int(c[0])

c2 = int(c[1])

katB1 = math.

Fabs(a1 - b1)

katB2 = math.

Fabs(a2 - b2)

katC1 = math.

Fabs(a1 - c1)

katC2 = math.

Fabs(a2 - c2)

RBA = math.

Sqrt(katB1 * * 2 + katB2 * * 2)

RAC = math.

Sqrt(katC1 * * 2 + katC2 * * 2)

if RBA.

Kleo901 4 янв. 2022 г., 20:25:54 | 5 - 9 классы

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область?

Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область.

Входные данные

Входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x - координата, затем – y - координата).

Выходные данные

Программа должна вывести слово 'YES', если точка попала в заштрихованную область, и слово 'NO', если не попала.

Примеры

входные данные

0.

5 0. 5

выходные данные

YES

входные данные - 0.

5 - 0.

5

выходные данные

NO.

Zaza987654321 11 февр. 2022 г., 18:22:14 | 5 - 9 классы

Составить программу определяющих расстояние с заданной скоростью и с заданное время?

Составить программу определяющих расстояние с заданной скоростью и с заданное время.

Stashkiv175 21 мар. 2022 г., 15:50:32 | 5 - 9 классы

Информатика 6 класс (составить программу)используя команды : вверх, вниз, вправо, влево оставьте 3 программы прохождения лабиринта из1?

Информатика 6 класс (составить программу)

используя команды : вверх, вниз, вправо, влево оставьте 3 программы прохождения лабиринта из

1.

Из точки 1 до точки К1

2.

Из точки 2 до точки К2

3.

Из точки 3 до точки К3.

Death20 2 мар. 2022 г., 05:43:09 | 5 - 9 классы

РЕБЯТ ЗАДАНИЕ НУЖНО РЕШИТЬ ЧЕРЕЗ PYTHONДаны координаты двух точек на плоскости, требуется определить, лежат ли они в одной координатной четверти или нет (все координаты отличны от нуля)?

РЕБЯТ ЗАДАНИЕ НУЖНО РЕШИТЬ ЧЕРЕЗ PYTHON

Даны координаты двух точек на плоскости, требуется определить, лежат ли они в одной координатной четверти или нет (все координаты отличны от нуля).

Входные данные

Вводятся 4 числа : координаты первой точки (x1, y1) и координаты второй точки (x2, y2).

Выходные данные

Программа должна вывести слово YES, если точки находятся в одной координатной четверти, в противном случае вывести слово NO.

Примеры

Входные данные

3

3

5

1

Выходные данные

YES.

Chao777 13 янв. 2022 г., 00:09:11 | 10 - 11 классы

50 БАЛЛОВ СРОЧНО?

50 БАЛЛОВ СРОЧНО!

НАПИШИТЕ ПРОГРАММУ НА " С "Даны действительные числа x, y.

Определить принадлежит ли точка с

координатами (x, y) заштрихованной части плоскости рис.

1, a(Рисунок прилагаю).

Армянскийтеррорист 4 янв. 2022 г., 01:28:05 | студенческий

Даны 2 точки на плоскости а и b заданны своими кардинатами точка а(ха, уа) b(xb, yb) определить какая точка ближе к началу кардинат (информатика)?

Даны 2 точки на плоскости а и b заданны своими кардинатами точка а(ха, уа) b(xb, yb) определить какая точка ближе к началу кардинат (информатика).

Aneliagross 28 февр. 2022 г., 16:42:03 | студенческий

M11 official :построить программу, которая вводит координаты точки (x, y) и определяет, попадает ли точка в заштрихованную область на рисунке?

M11 official :

построить программу, которая вводит координаты точки (x, y) и определяет, попадает ли точка в заштрихованную область на рисунке.

Попадание на границу области считать попаданием в область.

Помогите пожалуйста.

Dmitretska2005 13 февр. 2022 г., 05:22:02 | 10 - 11 классы

Даю 50 баллов ?

Даю 50 баллов !

Написать программы на языке С + + 1) Данные числа x, y являются координатами точки, лежащей в первой координатной четверти.

2) Даны два трехзначных числа.

Поменять местами 2 - ю цифру первого на 3 - ю цифру второго.

Leravolk05 16 мая 2022 г., 05:51:50 | студенческий

Разработать алгоритм и написать программу вычисления принадлежности точки с заданными координатами (x, y) заштрихованной области?

Разработать алгоритм и написать программу вычисления принадлежности точки с заданными координатами (x, y) заштрихованной области.

Программа должна выдавать текстовое сообщение о принадлежности точки заданной области.

(11).

Sveta55552 29 мар. 2022 г., 07:43:14 | 10 - 11 классы

Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы?

Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы.

Программист торопился и написал программу неправильно.

Вот она :

var x, y : real ;

begin

readln(x, y) ;

if y = 0 then

if y> = x + 1 then

write('принадлежит')

else

write('не принадлежит')

end.

Последовательно выполните следующее :

1)​ приведите пример таких чисел x, y, при которых программа неверно решает поставленную задачу ;

2)​ укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы ; это можно сделать несколькими способами, поэтому можно указать любой способ доработки исходной программы.

На этой странице находится ответ на вопрос На координатной плоскости расположены три точки : A, B, C?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.