Найти сумму четных делителей введенного целого числа(Pascal abc?

Информатика | студенческий

Найти сумму четных делителей введенного целого числа(Pascal abc.

Net).

Ответить на вопрос
Ответы (1)
NastyaSW1 27 июл. 2021 г., 14:32:09

Program n1 ;

var a, sum, i : integer ;

begin

sum : = 0 ;

readln(a) ;

for i : = 1 to a div 2 do if (a mod i) = 0 then

if i mod 2 = 0 then sum : = sum + i ;

if a mod 2 = 0 then sum : = sum + a ;

writeln(sum) ;

end.

Inkognito211 25 апр. 2021 г., 00:47:11 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Найти сумму элементов с четными индексами.

Tanecka228 16 сент. 2021 г., 08:54:15 | 5 - 9 классы

Написать программу, которая проверяет, является ли четным введенное пользователем целое трехзначное число число?

Написать программу, которая проверяет, является ли четным введенное пользователем целое трехзначное число число.

Igoryn2815 16 авг. 2021 г., 22:18:08 | 5 - 9 классы

Написать программу решения задачи : Вводить целые числа с клавиатуры, пока не будет введен ноль?

Написать программу решения задачи : Вводить целые числа с клавиатуры, пока не будет введен ноль.

А) Найти сумму введенных чисел.

B) Найти количество четных отрицательных чисел среди введенных.

C) Найти максимальное число среди введенных.

УченицаВика1 11 февр. 2021 г., 16:38:54 | 5 - 9 классы

Составьте алгоритм, блок - схему и программу вычисления суммы квадратов числа 2?

Составьте алгоритм, блок - схему и программу вычисления суммы квадратов числа 2.

Pascal abc.

Net.

Афигенскаяаядевчонка 3 окт. 2021 г., 03:10:16 | студенческий

Подсчитать кол - во отрицательных чисел из 10 введенных с клавы (pascal abc?

Подсчитать кол - во отрицательных чисел из 10 введенных с клавы (pascal abc.

Net).

Sonya591 20 авг. 2021 г., 04:12:00 | 5 - 9 классы

Составьте программу, проверяющую, верно ли утверждение, что сумма цифр введенного трехзначного числа является четной?

Составьте программу, проверяющую, верно ли утверждение, что сумма цифр введенного трехзначного числа является четной.

Саааау5е5 26 окт. 2021 г., 18:21:12 | 5 - 9 классы

Найти сумму квадратов пяти целых четных чисел, начиная от 10?

Найти сумму квадратов пяти целых четных чисел, начиная от 10.

Valtieva203 19 июл. 2021 г., 14:04:55 | 5 - 9 классы

Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом?

Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом.

Пример ввода : 567.

Пример вывода : сумма цифр числа 567 - четное число

хелп, срочно!

;

NashaNatasha 22 окт. 2021 г., 08:57:50 | 5 - 9 классы

Составьте программу, определяющую, является ли последняя цифра введенного целого числа (любого) четной ли нечётной?

Составьте программу, определяющую, является ли последняя цифра введенного целого числа (любого) четной ли нечётной.

LuexoL 11 дек. 2021 г., 03:07:40 | 5 - 9 классы

Найти большее из 4 - ёх чисел pascal ABC NET?

Найти большее из 4 - ёх чисел pascal ABC NET.

Перед вами страница с вопросом Найти сумму четных делителей введенного целого числа(Pascal abc?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся студенческий. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.