Составьте программы в PACKAL ABC для следующих задач :1)С клавиатуры вводится три вещественных числа?

Информатика | 5 - 9 классы

Составьте программы в PACKAL ABC для следующих задач :

1)С клавиатуры вводится три вещественных числа.

Найти целую часть от суммы этих вещественных чисел.

2)С клавиатуры вводится целое число.

Найди дробную часть от деления целого числа на n

3)С клавиатуры вводится четыре вещественных числа.

Найти сумму этих вещественных чисел и округлить ее.

Ответить на вопрос
Ответы (1)
Kiko0120 26 сент. 2021 г., 00:11:52

1)

Program n1 ;

var a, b, c : real ;

sum : integer ;

begin

readln(a, b, c) ;

sum : = trunc(a + b + c) ;

writeln(sum) ;

end.

2)

Program n2 ;

var a, n : integer ;

x : real ;

begin

readln(a, n) ;

x : = frac(a / n) ;

writeln(x)

end.

3)

Program n3 ;

var a, b, c, d : real ;

sum : integer ;

begin

readln(a, b, c, d) ;

sum : = round(a + b + c + d) ;

writeln(sum) ;

end.

Прдоыкора 18 авг. 2021 г., 20:30:08 | 10 - 11 классы

Найти сумму квадратов всех целых чисел от a до 50 (a вводится с клавиатуры) ?

Найти сумму квадратов всех целых чисел от a до 50 (a вводится с клавиатуры) ;

MoJIoDoy174 9 июл. 2021 г., 13:42:44 | 5 - 9 классы

Задано вещественное число К?

Задано вещественное число К.

Вычислите разность целой и дробной части числа К.

Aglo65 7 мар. 2021 г., 20:13:24 | 5 - 9 классы

Составьте программу решения следующей задачи :С клавиатуры вводится двузначное число a?

Составьте программу решения следующей задачи :

С клавиатуры вводится двузначное число a.

Найти сумму его цифр.

Azazinkrin 30 июн. 2021 г., 10:18:22 | 5 - 9 классы

С клавиатуры вводится целое положительное число?

С клавиатуры вводится целое положительное число.

Определить, сколько раз в этом числе встретилась цифра 5.

Packal ABC

срочно пожалуйста.

Julipol 7 апр. 2021 г., 06:44:00 | 5 - 9 классы

С клавиатуры вводится три четырехзначных числа найдите сумму нечетных чисел в наименьшем числе (Paskal abc)?

С клавиатуры вводится три четырехзначных числа найдите сумму нечетных чисел в наименьшем числе (Paskal abc).

ЕВС65 15 авг. 2021 г., 08:36:29 | 10 - 11 классы

№2 C клавиатуры вводится последовательность вещественных чисел?

№2 C клавиатуры вводится последовательность вещественных чисел.

Выведите данные числа на экран в порядке, обратном чтению.

Помогите пожалуйста!

Dara35245 7 июн. 2021 г., 03:25:20 | 5 - 9 классы

Здравствуйте, помогите пожалуйста?

Здравствуйте, помогите пожалуйста!

Составьте программу ввода с клавиатуры и вывода на экран массива из 7 вещественных чисел.

Huggg 8 сент. 2021 г., 10:10:42 | студенческий

Написать программу, которая вводит с клавиатуры 5 вещественных чисел и вычисляет их среднее арифметическое?

Написать программу, которая вводит с клавиатуры 5 вещественных чисел и вычисляет их среднее арифметическое.

На паскале (через for to do).

KrytoichelovekGfgfh 18 июн. 2021 г., 01:28:41 | 10 - 11 классы

Помогите по ПаскалюС клавиатуры вводится вещественное число?

Помогите по Паскалю

С клавиатуры вводится вещественное число.

Вывести сумму трёх его первых цифр после десятичной точки.

Dubinina9818 29 дек. 2021 г., 15:17:33 | 5 - 9 классы

НА ПАСКАЛЕ С клавиатуры вводится вещественное число?

НА ПАСКАЛЕ С клавиатуры вводится вещественное число.

Вывести сумму

трёх его первых цифр после десятичной точки.

СРОЧНО, ПОЖАЛУЙСТА.

Если вам необходимо получить ответ на вопрос Составьте программы в PACKAL ABC для следующих задач :1)С клавиатуры вводится три вещественных числа?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.