ПаскальДана матрица (двумерный массив) размером 20 × 20?

Информатика | 10 - 11 классы

Паскаль

Дана матрица (двумерный массив) размером 20 × 20.

Каждый элемент может принимать

целочисленные значения от 0 до 200.

Опишите на русском языке или на одном из языков

программирования алгоритм, который позволяет определить, является ли данная матрица

симметричной относительно своей главной диагонали.

Исходные данные объявлены так, как

показано ниже.

Запрещается использовать переменные, не описанные ниже, но разрешается не

использовать часть из них.

Паскаль Бейсик

const N = 20 ;

var

a : array [0.

N - 1, 0.

N - 1]

of integer ;

i, j : integer ;

begin

for i : = 0 to N - 1 do

for j : = 0 to N - 1 do

readln(a[i, j]) ;

.

End.

Ответить на вопрос
Ответы (1)
MrFriman11 6 янв. 2022 г., 11:30:09

Const N = 20 ;

var

a : array [0.

N - 1, 0.

N - 1] of integer ;

i, j : integer ;

begin

for i : = 0 to N - 1 do

for j : = 0 to N - 1 do read(a[i, j]) ;

for i : = 0 to N - 1 do

begin

for j : = 0 to N - 1 do write(a[i, j], ' ') ;

writeln ;

end ;

i : = 0 ; j : = 0 ;

while (i.

Алина2187 1 янв. 2022 г., 15:00:02 | 10 - 11 классы

Перепишите программу на Паскале, исправив ошибки :Program massiv ;Var a : array( - 10?

Перепишите программу на Паскале, исправив ошибки :

Program massiv ;

Var a : array( - 10.

10) of integer ;

Begin For i : = 1 to 20 Do Read(a[i]) ; For i : = 1 to 20 Do a[i] : = a[i] / 10 ;

For i : = 1 to 20 Do Write(a[i])

End.

Tane4ka211192 11 мар. 2022 г., 11:01:57 | 10 - 11 классы

Написать программу на языке С + + :Сформировать случайным образом целочисленную матрицу N * N?

Написать программу на языке С + + :

Сформировать случайным образом целочисленную матрицу N * N.

Сформировать два одномерных массива А и В : в массив А записать элементы матрицы, расположенные на главной диагонали и ниже неё, в массив В - элементы, лежащие на побочной диагонали и ниже неё.

Сурок228 2 февр. 2022 г., 14:17:32 | студенческий

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)var n, s : integerbeginn : = 0 ;s : = 402 ;while s>0 dobegins : = s - 10 ;n : = ?

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)

var n, s : integer

begin

n : = 0 ;

s : = 402 ;

while s>0 do

begin

s : = s - 10 ;

n : = n + 3

end ;

write(n)

end.

Damirmuhamediar 22 янв. 2022 г., 23:48:51 | 10 - 11 классы

Запишите значение переменной y, полученное в результате работы следующей программы?

Запишите значение переменной y, полученное в результате работы следующей программы.

Текст программы приведён на трёх языках программирования.

Var y, i : integer ;

Begin

y : = 5 ;

For i : = 1 to 3 do

y : = y + 5 * i ;

Writeln(y) ;

End.

Alicka762 30 янв. 2022 г., 23:07:20 | 10 - 11 классы

ПАСКАЛЬ?

ПАСКАЛЬ.

1)дан целочисленный массив из 30 элементов.

Элементы массива могут принимать целые значения от 0 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти среднее арифметическое нечетных трехзначных чисел, записанных в этом массиве.

Если ни одного такого числа нет, нужно вывести сообщение об этом.

2)дан целочисленный массив из 30 элементов.

Элементы массива могут принимать целые значения от 0 до 100.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти и вывести произведение элементов массива, которые имеют четное значение и не оканчиваются на 0.

Gork345 3 мая 2022 г., 18:04:33 | 5 - 9 классы

Помогите с Паскалемconst N = 40 ;vara : array[1?

Помогите с Паскалем

const N = 40 ;

var

a : array[1.

N] of integer ;

i, j, s : integer ;

st : real ;

begin

for i : = 1 to N do readln(a[i]) ;

Alisho74 24 янв. 2022 г., 04:02:36 | 10 - 11 классы

Дан целочисленный массив из 40 элементов?

Дан целочисленный массив из 40 элементов.

Элементы массива могут принимать значения от - 10000 до 10000.

Написать алгоритм, который находит и выводит среднее арифметическое всех отрицательных элементов массива, оканчивающихся цифрой 7.

Гарантируется, что хотя бы один такой элемент в массиве есть.

Исходные данные объявлены так, как показано ниже.

Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них.

Const N = 40

var

a : array [1.

N] of integer ;

i, s, r, x : integer ;

sr : real ;

begin

for i : = 1 to N do readln (a[i]) ;

.

End. .

Елена10903 20 мая 2022 г., 00:50:20 | 10 - 11 классы

Дано матрицу В размером 5х6?

Дано матрицу В размером 5х6.

Разделить элемент каждой строки на элемент, который находится в 3 столбце этой строки.

(Язык програмирования С или С + + ).

Artur123456783316 2 мар. 2022 г., 13:46:25 | 5 - 9 классы

Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на языке программирования ПаскальVar s, k, x : integer ;begins : = 1 ;x : = 2 ;for k : = 1 to 9 dos : = s * x?

Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на языке программирования Паскаль

Var s, k, x : integer ;

begin

s : = 1 ;

x : = 2 ;

for k : = 1 to 9 do

s : = s * x ;

writeln(s) ;

end.

1q22 11 июн. 2022 г., 12:03:16 | 5 - 9 классы

Нужно составить описание к программеprogram pr1 ;const n = 5 ;var a : array[1?

Нужно составить описание к программе

program pr1 ;

const n = 5 ;

var a : array[1.

N] of integer ;

i, s1, s2 : integer ;

begin

randomize ;

s1 : = 0 ;

s2 : = 0 ;

for i : = 1 to n do begin

a[i] : = random(20) - 8 ;

writeln(a[i] : 4, ' Порядковый номер ', i) ;

end ;

writeln ;

for i : = 1 to n do begin

if i mod 20 then s1 : = s1 + sqr(a[i]) * a[i] ;

if i mod 2 = 0 then s2 : = s2 + sqr(a[i]) ;

end ;

writeln('Сумма 1 = ', s1) ;

writeln('Сумма 2 = ', s2) ;

end.

Вы открыли страницу вопроса ПаскальДана матрица (двумерный массив) размером 20 × 20?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.