Написать программу которая сумму всех цифр пятизначного числа х который вводится с клавиатуры и определит заканчивается ли эта сумма на три и четная эта сумма или нетИнформатика 8 класс?

Информатика | 5 - 9 классы

Написать программу которая сумму всех цифр пятизначного числа х который вводится с клавиатуры и определит заканчивается ли эта сумма на три и четная эта сумма или нет

Информатика 8 класс.

Ответить на вопрос
Ответы (1)
Sergeuazitov 17 мар. 2021 г., 05:21:07

Program n1 ;

var a : longint ;

procedure sumdig(var x : longint) ;

var s : longint ;

begin

s : = 0 ;

while ( x0 ) do

begin

s : = s + (x mod 10) ;

x : = x div 10 ;

end ;

if s mod 10 = 3 then writeln('оканчивается на 3')

else writeln('не оканчивается на 3') ;

if s mod 2 = 0 then writeln('четная') else

writeln('нечетная') ;

end ;

begin

writeln('введите целое число') ;

readln(a) ;

sumdig(a) ;

end.

Flatron109mailru 22 авг. 2021 г., 02:43:34 | 5 - 9 классы

ИНФОРМАТИКА 9 КЛАСС ДАЮ 50 БАЛЛОВ написать программу в ABCпаскаль которая вычислит сумму цифр пятизначного числа и определит находится ли эта сумма в диапазоне от 20 до 25 включительно(< ; = или >?

ИНФОРМАТИКА 9 КЛАСС ДАЮ 50 БАЛЛОВ написать программу в ABCпаскаль которая вычислит сумму цифр пятизначного числа и определит находится ли эта сумма в диапазоне от 20 до 25 включительно(< ; = или > ; = ).

EvaLevi 13 авг. 2021 г., 12:46:09 | 5 - 9 классы

Pascal ABCНапишите программу, которая определяет количество элементов, сумма цифр которых четна?

Pascal ABC

Напишите программу, которая определяет количество элементов, сумма цифр которых четна.

Формат ввода

Программа получает на вход последовательность целых чисел, заканчивающаяся нулем (0 - признак окончания ввода).

Формат вывода

Выведите одно число – количество чисел, сумма цифр которых четна

Пример

Ввод Вывод

2 4

3

4

1444

4

5

136

0.

Уля090730 14 янв. 2021 г., 07:49:14 | 5 - 9 классы

Дано двухзначное число которое вводится с клавиатуры?

Дано двухзначное число которое вводится с клавиатуры.

Напишите програму которая найдет сумму его цифр.

ЗАРАНЬЕ СПАСИБО.

Den174 30 апр. 2021 г., 20:21:04 | 5 - 9 классы

Написать программу которая определит сумму всех цифр пятизначного числа x(вводятся с клавиатуры) и вывести на экран сообщение?

Написать программу которая определит сумму всех цифр пятизначного числа x(вводятся с клавиатуры) и вывести на экран сообщение.

И определить заканчивается эта сумма на 3, является ли эта сумма четным.

Trolfeisnu 18 сент. 2021 г., 19:01:59 | 5 - 9 классы

Написать программу на языке паскаль?

Написать программу на языке паскаль.

С клавиатуры вводятся несколько натуральных целых чисел.

Необходимо чтобы вычислялось сколько введено чисел, сколько из них четных и общая сумма этих чисел.

Например : вводим числа 3425 - получает количество чисел - 4, количество четных чисел - 2, сумма чисел - 14.

Osubach 25 февр. 2021 г., 06:12:43 | 10 - 11 классы

Написать программу которая вводит с клавиатуры 10 чисел и вычисляет их сумму и произведение на алгоритмическом языке?

Написать программу которая вводит с клавиатуры 10 чисел и вычисляет их сумму и произведение на алгоритмическом языке.

MrGomer 1 сент. 2021 г., 12:44:32 | 5 - 9 классы

Написать в тетради программу, в которой пользователь вводит целое 3 - хзначное число, необходимо найти сумму его цифр?

Написать в тетради программу, в которой пользователь вводит целое 3 - хзначное число, необходимо найти сумму его цифр.

Katushka16 8 дек. 2021 г., 13:43:17 | 5 - 9 классы

Составьте программу, которая вводит с клавиатуры два числа и выводит их сумму, разность, произведение и частное?

Составьте программу, которая вводит с клавиатуры два числа и выводит их сумму, разность, произведение и частное.

Valtieva203 19 июл. 2021 г., 14:04:55 | 5 - 9 классы

Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом?

Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом.

Пример ввода : 567.

Пример вывода : сумма цифр числа 567 - четное число

хелп, срочно!

;

15152525 23 июл. 2021 г., 08:40:22 | 5 - 9 классы

С клавиатуры вводятся два символа?

С клавиатуры вводятся два символа.

Определить четная ли сумма их кодов?

( паскаль).

На этой странице сайта, в категории Информатика размещен ответ на вопрос Написать программу которая сумму всех цифр пятизначного числа х который вводится с клавиатуры и определит заканчивается ли эта сумма на три и четная эта сумма или нетИнформатика 8 класс?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.